Subject: [Pals] PALS WG LC for draft-ietf-pals-vccv-for-gal-00

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 18 Feb 2015 07:38:30 -0500

As we have now heard from all of the authors regarding IPR, this begins the
two-week PALS WG LC for
http://tools.ietf.org/html/draft-ietf-pals-vccv-for-gal-00, ending on
Wednesday, March 4. Please review the draft and respond with comments, or
an indication that you have read the draft and support it being forwarded
to the IESG for publication. As this draft affects the default modes for
VCCV, I would like to make sure it gets a good review by the WG.

Thanks,
Andy

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 18 Feb 2015 13:52:45 +0000

On 18/02/2015 12:38, Andrew G. Malis wrote:
> As we have now heard from all of the authors regarding IPR, this 
> begins the two-week PALS WG LC for 
> Wednesday, March 4. Please review the draft and respond with comments, 
> or an indication that you have read the draft and support it being 
> forwarded to the IESG for publication. As this draft affects the 
> default modes for VCCV, I would like to make sure it gets a good 
> review by the WG.
>
> Thanks,
> Andy
>
>
>
> _______________________________________________
> Pals mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pals

Andy

I have some edits to be released, following my discussion with Matthew.

Please can we run this on -01 which should be out today or tomorrow.

Stewart

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 18 Feb 2015 08:59:26 -0500

Are the edits major? If not, can you post them as part of the LC?

> On Feb 18, 2015:8:52 AM, at 8:52 AM, Stewart Bryant <[email-masked]> wrote:
> 
>> As we have now heard from all of the authors regarding IPR, this begins the two-week PALS WG LC for http://tools.ietf.org/html/draft-ietf-pals-vccv-for-gal-00 <http://tools.ietf.org/html/draft-ietf-pals-vccv-for-gal-00>, ending on Wednesday, March 4. Please review the draft and respond with comments, or an indication that you have read the draft and support it being forwarded to the IESG for publication. As this draft affects the default modes for VCCV, I would like to make sure it gets a good review by the WG.
>> 
>> Thanks,
>> Andy
>> 
>> 
>> 
>> [email-masked] <mailto:[email-masked]>
>> https://www.ietf.org/mailman/listinfo/pals <https://www.ietf.org/mailman/listinfo/pals>
> 
> Andy
>

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 18 Feb 2015 14:08:47 +0000

On 18/02/2015 13:52, Stewart Bryant wrote:
>> Wednesday, March 4. Please review the draft and respond with 
>> comments, or an indication that you have read the draft and support 
>> it being forwarded to the IESG for publication. As this draft affects 
>> the default modes for VCCV, I would like to make sure it gets a good 
>> review by the WG.
>>
>> Thanks,
>> Andy
>>
>>
>>
We both got the version number wrong - it is version 02 just uploaded and
available here:

http://datatracker.ietf.org/doc/draft-ietf-pals-vccv-for-gal/

- Stewart

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 19 Feb 2015 09:28:40 -0500

My apologies ... yes, this last call is revision -02, available at
http://tools.ietf.org/html/draft-ietf-pals-vccv-for-gal-02 .

Thanks,
Andy

On Wed, Feb 18, 2015 at 9:08 AM, Stewart Bryant <[email-masked]> wrote:

> As we have now heard from all of the authors regarding IPR, this begins
> the two-week PALS WG LC for
> Pals mailing [email-masked]://www.ietf.org/mailman/listinfo/pals
>
>
> Andy
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 23 Feb 2015 14:16:06 +0000

Andy and all,
I have read the draft and support it being forwarding to IESG for publication.

I have two minor editorial comments that IMO should be addressed (now or at some later stage):

1.       The last para in Section 1 says:
   For reasons of network efficiency and due to hardware constraints it
   is not possible to address these issue by mandating that all PWs use
   the PW CW, hence the introduction of this new VCCV CC type.  PWs
   without the CW are widely deployed, and hence mandating that all PWs
   use the CW is not a viable way to address this issue.
Looks to me as two separate reasons not to mandate comprehensive usage of the PW CW. May I suggest re-phrasing this fragment along the following lines:
  Mandating all PWs to use the PW CW is not a viable way to address this issue because:

-          PWs without the CW are already widely deployed, and

-          Already deployed HW in many cases does not support usage of the PW CW for some PW types.

2.       The following two text fragments look almost identical:

a.       In the last para of Section 3:
   Note that the inclusion of a GAL following the PW LSE over a label
   switched path subject to Equal-Cost Multi-path (ECMP) load balancing
   can cause the OAM packet to take a different path through the network
   from the corresponding PW data packets.  If that is not acceptable,
   then an alternative VCCV type MUST be used.

b.      In the last para of Section 4:
   Note that the use of a GAL in place of the flow label over a label
   switched path subject to ECMP can cause the OAM packet to take a
   different path through the network from the corresponding PW data
   packets.  If that is not acceptable, then an alternative VCCV type
   MUST be used.
From my POV this similarity masks substantive difference between the scenarios discussed in Section 3 and Section 4:

o   In the first case usage of ECMP along the LSP that carries the PW may or may not occur

o   In the second case usage of ECMP is the main reason for inserting the flow label in the first place.
        May I suggest re-phrasing the second fragment along the following lines:
   Flow labels are inserted in order to allow distribution of the PW traffic
   among multiple equal cost multiple label switched paths.
   The use of GAL in place of the flow label will cause all OAM packets to take exactly
   one of these paths, and this path may be different from the paths taken by any
   traffic flows. If this is not acceptable, then an alternative VCCV type MUST be
   used.

Hopefully these notes will be useful.
Regards,
       Sasha
Email: [email-masked]
Mobile: 054-9266302

From: Pals [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Thursday, February 19, 2015 4:29 PM
To: Stewart Bryant
Cc: [email-masked]
Subject: Re: [Pals] PALS WG LC for draft-ietf-pals-vccv-for-gal-00

My apologies ... yes, this last call is revision -02, available at http://tools.ietf.org/html/draft-ietf-pals-vccv-for-gal-02 .

Thanks,
Andy

On Wed, Feb 18, 2015 at 9:08 AM, Stewart Bryant <[email-masked]<mailto:[email-masked]>> wrote:
On 18/02/2015 13:52, Stewart Bryant wrote:
On 18/02/2015 12:38, Andrew G. Malis wrote:
As we have now heard from all of the authors regarding IPR, this begins the two-week PALS WG LC for http://tools.ietf.org/html/draft-ietf-pals-vccv-for-gal-00, ending on Wednesday, March 4. Please review the draft and respond with comments, or an indication that you have read the draft and support it being forwarded to the IESG for publication. As this draft affects the default modes for VCCV, I would like to make sure it gets a good review by the WG.

Thanks,
Andy

Pals mailing list

[email-masked]<mailto:[email-masked]>

Andy

Stewart

- Stewart

---

From: Stewart Bryant <[email-masked]>
Date: Mon, 23 Feb 2015 14:52:23 +0000

Sasha

Those changes look OK. I will do an update at close of WG LC.

Stewart

On 23/02/2015 14:16, Alexander Vainshtein wrote:
> 1.The last para in Section 1 says:
>
> Looks to me as two separate reasons not to mandate comprehensive usage 
> of the PW CW. May I suggest re-phrasing this fragment along the 
> following lines:
>
> -PWs without the CW are already widely deployed, and
>
> -Already deployed HW in many cases does not support usage of the PW CW 
> for some PW types.
>
> 2.The following two text fragments look almost identical:
>
> a.In the last para of Section 3:
>
> b.In the last para of Section 4:
>
> From my POV this similarity masks substantive difference between the 
> scenarios discussed in Section 3 and Section 4:
>
> oIn the first case usage of ECMP along the LSP that carries the PW may 
> or may not occur
>
> oIn the second case usage of ECMP is the main reason for inserting the 
> flow label in the first place.
>
> *From:*Pals [mailto:[email-masked]] *On Behalf Of *Andrew G. Malis
> *Sent:* Thursday, February 19, 2015 4:29 PM
> *To:* Stewart Bryant
> *Cc:* [email-masked]
> *Subject:* Re: [Pals] PALS WG LC for draft-ietf-pals-vccv-for-gal-00
>
>         As we have now heard from all of the authors regarding IPR,
>         this begins the two-week PALS WG LC for
>         http://tools.ietf.org/html/draft-ietf-pals-vccv-for-gal-00,
>         ending on Wednesday, March 4. Please review the draft and
>         respond with comments, or an indication that you have read the
>         draft and support it being forwarded to the IESG for
>         publication. As this draft affects the default modes for VCCV,
>         I would like to make sure it gets a good review by the WG.
>
>         Thanks,
>
>         Andy
>

-- 
For corporate legal information go to:

http://www.cisco.com/web/about/doing_business/legal/cri/index.html

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 23 Feb 2015 15:38:26 +0000

Stewart,
Lots of thanks for a prompt and encouraging response.

Regards,
       Sasha

From: Stewart Bryant [mailto:[email-masked]]
Sent: Monday, February 23, 2015 4:52 PM
To: Alexander Vainshtein; Andrew G. Malis
Cc: [email-masked]
Subject: Re: [Pals] PALS WG LC for draft-ietf-pals-vccv-for-gal-00

Sasha

Stewart

Hopefully these notes will be useful.
Regards,
       Sasha
Email: [email-masked]<mailto:[email-masked]>
Mobile: 054-9266302

From: Pals [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Thursday, February 19, 2015 4:29 PM
To: Stewart Bryant
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [Pals] PALS WG LC for draft-ietf-pals-vccv-for-gal-00

Thanks,
Andy

Thanks,
Andy

Pals mailing list

Andy

Stewart

- Stewart

--