Subject: [Pals] I-D Action: draft-ietf-pals-endpoint-fast-protection-00.txt

From: [email-masked]
Date: Wed, 06 May 2015 09:27:58 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Pseudowire And LDP-enabled Services Working Group of the IETF.

        Title           : PW Endpoint Fast Failure Protection
        Authors         : Yimin Shen
                          Rahul Aggarwal
                          Wim Henderickx
                          Yuanlong Jiang
	Filename        : draft-ietf-pals-endpoint-fast-protection-00.txt
	Pages           : 29
	Date            : 2015-05-06

Abstract:
   This document specifies a fast mechanism for protecting pseudowires
   against egress endpoint failures, including egress attachment circuit
   failure, egress PE failure, multi-segment PW terminating PE failure,
   and multi-segment PW switching PE failure.  Designed on the basis of
   multi-homed CE, redundant PWs, upstream label assignment and context
   specific label switching, the mechanism enables local repair to be
   performed by the router upstream adjacent to a failure.  The router
   can restore PW traffic in the order of tens of milliseconds, by
   transmitting the traffic to a protector through a pre-established
   bypass tunnel.  Therefore, the mechanism can be used to reduce
   traffic loss before global repair reacts to the failure and the
   network converges on the topology changes due to the failure.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pals-endpoint-fast-protection/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-pals-endpoint-fast-protection-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: "Andrew G. Malis" <[email-masked]>
Date: Wed, 6 May 2015 12:39:29 -0400

PALSers,

Please note that this is not a brand new draft, it's a continuation of
draft-ietf-pwe3-endpoint-fast-protection, which was updated to address WG
LC comments.

Cheers,
Andy

On Wed, May 6, 2015 at 12:27 PM, <[email-masked]> wrote:

> _______________________________________________
> Pals mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pals
>

---

From: Yimin Shen <[email-masked]>
Date: Wed, 6 May 2015 20:45:29 +0000

Hi Steward, Sasha,

I’d like to thank you for your valuable comments in the previous LC for this draft. Sorry for the delay, but I’ve finally got to spend time addressing these comments with a new ver.

The major updates are in section 3, section 4.1 and section 6. I made some clarification for the reference models, the general relationship between this mechanism and other global/protocol/multi-homing protection mechanisms, failure handling for traffic of reverse direction, ECMP case for IP/LDP tunnels, applicability, revertive behaviors, etc. Hope that I have covered all. Please let me know if you have further questions.

Thanks,

/Yimin

From: Pals [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Wednesday, May 06, 2015 12:39 PM
To: [email-masked]
Subject: Re: [Pals] I-D Action: draft-ietf-pals-endpoint-fast-protection-00.txt

PALSers,

Please note that this is not a brand new draft, it's a continuation of draft-ietf-pwe3-endpoint-fast-protection, which was updated to address WG LC comments.

Cheers,
Andy

On Wed, May 6, 2015 at 12:27 PM, <[email-masked]<mailto:[email-masked]>> wrote:

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

_______________________________________________
Pals mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pals

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 7 May 2015 05:54:37 +0000

?Yimin,

I have been waiting with interest for the new version.

I will try to read it and to provide additional comments (or to acknowledge that my previous comments have been  successfully resolved) within the next few days.

Regards,

Sasha

________________________________
From: Yimin Shen <[email-masked]>
Sent: Wednesday, May 6, 2015 11:45 PM
To: Andrew G. Malis; [email-masked]; Alexander Vainshtein
Subject: RE: [Pals] I-D Action: draft-ietf-pals-endpoint-fast-protection-00.txt

Hi Steward, Sasha,

I'd like to thank you for your valuable comments in the previous LC for this draft. Sorry for the delay, but I've finally got to spend time addressing these comments with a new ver.

Thanks,

/Yimin

PALSers,

Cheers,
Andy

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

---

From: Yimin Shen <[email-masked]>
Date: Thu, 7 May 2015 18:40:05 +0000

Correction…. The major updates are in section 3, section 4.1 and section 5, not section 6.

Thanks,

/Yimin

From: Pals [mailto:[email-masked]] On Behalf Of Yimin Shen
Sent: Wednesday, May 06, 2015 4:45 PM
To: Andrew G. Malis; [email-masked]; Alexander Vainshtein
Subject: Re: [Pals] I-D Action: draft-ietf-pals-endpoint-fast-protection-00.txt

Hi Steward, Sasha,

Thanks,

/Yimin

From: Pals [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Wednesday, May 06, 2015 12:39 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Pals] I-D Action: draft-ietf-pals-endpoint-fast-protection-00.txt

PALSers,

Cheers,
Andy

Abstract: