Subject: [Pals] PALS WGLC on draft-ietf-pals-mpls-tp-pw-over-bidir-lsp

From: Stewart Bryant <[email-masked]>
Date: Thu, 12 Nov 2015 12:00:19 +0000

This email is to do two things:

1) To start the PALS WG call on draft-ietf-pals-mpls-tp-pw-over-bidir-lsp
The document can be found at

https://datatracker.ietf.org/doc/draft-ietf-pals-mpls-tp-pw-over-bidir-lsp/

This last call will run until 25th November 2015.

Please respond to this email with substantive comments on the document. It
is also useful if those that have read the text and believe that it is ready
to send to the IESG confirm that.

2) To verify that all IPR known to the WG has been declared. Please 
declare this
regardless of whether you are an author or not.

However I specifically need to have a response from the first three 
authors in the
author list on this.

Thanks

Stewart

---

From: Alexander Vainshtein <[email-masked]>
Date: Thu, 12 Nov 2015 14:27:59 +0000

Stewart and all,

I have a couple of (possibly, naïve) concerns regarding this draft.

Clarifying these concerns would help me to form an opinion regarding its support in the WG LC.

1.       The draft mentions (in many places) "a single  bidirectional co-routed LSP or two LSPs that share the same route" and uses this construct as if its two comprising components are equivalent. I do not think this is correct because:

a.       A co-routed bidirectional LSP is defined in RFC 5654<https://datatracker.ietf.org/doc/rfc5654/?include_text=1>, and its most important characteristic is that the two unidirectional LSPs comprising it, in addition to crossing the same sequence of nodes and links, have common life span (quoting from 5456: "Both directions are setup, monitored and protected as a single entity"). So it makes sense for one of the PEs terminating a PW and selecting one direction of a co-routed bi-directional LSP to request that the PE containing the remote PW endpoint  uses the reverse direction of such an LSP

b.      To the best of my understanding "two LSPs that share the same route" but do not form two directions of a co-routed bidirectional LSP by definition cannot have common life span. E.g., they could originally share the same route but, following some network event, could follow diverse routes (e.g., if each of them uses RSVP-TE-like FRR in link-and-node protection mode). So using such a pair of LSPs for carrying a PW that is supposed to be carried across the same set of links in two directions cannot be guaranteed and seems inconsistent with the perceived purpose of the draft.

c.       One possible way to resolve this issue would be to restrict the draft to just co-routed bidirectional LSPs, but I am not sure whether this matches the authors' intention.

2.        The draft seems to use MPLS-TP Node Identifiers as defined in RFC 6370<https://datatracker.ietf.org/doc/rfc6370/?include_text=1>. I have two concerns in this regard:

a.       RFC 6923<https://datatracker.ietf.org/doc/rfc6923/?include_text=1> defines an alternative format of MPLS-TP identifiers based on ITU-T.  But the draft neither supports this alternative format nor explicitly states that it must be supported

b.      6370 explicitly states that "the Node_ID does not  need to have any association with the IPv4 address space used in the  operator's IGP or EGP". At the same time in order to set up a tLDP adjacency with the MPLS-TP node containing the remote endpoint of a PW, the active PE (as defined in the draft) must use one of its some routable IP addresses. To me that means that in order to use the draft each MPLS-TP node MUST support 1:1 mapping between routable IP addresses used as the endpoints of tLDP adjacencies and MPLS-TP Node Identifiers for all the nodes in the domain. A trivial way to achieve that would be using loopback IP addresses of these nodes as their MPLS-TP node identifiers, but the draft does not mention this possibility (or any alternative).

Hopefully these notes will be useful.

My 2c,

Sasha

Office: +972-39266302

Cell:      +972-549266302

Email:   [email-masked]

-----Original Message-----
From: Pals [mailto:[email-masked]] On Behalf Of Stewart Bryant
Sent: Thursday, November 12, 2015 2:00 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [Pals] PALS WGLC on draft-ietf-pals-mpls-tp-pw-over-bidir-lsp

Please respond to this email with substantive comments on the document. It is also useful if those that have read the text and believe that it is ready to send to the IESG confirm that.

2) To verify that all IPR known to the WG has been declared. Please declare this regardless of whether you are an author or not.

However I specifically need to have a response from the first three authors in the author list on this.

Thanks

Stewart

_______________________________________________

Pals mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/pals