Subject: Re: [Pals] ldp sync

From: Sinbad <[email-masked]>
Date: Thu, 3 Dec 2015 11:20:12 +0530

can anyone shed light on this ?

On Sat, Nov 28, 2015 at 6:24 AM, Sinbad <[email-masked]> wrote:

> Hi,
>
> In ldp igp synchronization rfc5443., it states that the igp link is
> advertised
> with the highest cost when ldp is not reached operational state yet,
> so that it is excluded from the topology. since ldp relies on igp to
> establish
> a session (especially if the peer address is a loopback address), doesn't
> this
> make a deadlock, ldp waiting for igp to converge and vice versa.
>
> thanks
> sinbad
>

---

From: "Stewart Bryant (stbryant)" <[email-masked]>
Date: Thu, 3 Dec 2015 09:13:05 +0000

Sinbad

This is really a question for the MPLS WG.

What you need to understand is that LDP is strictly layered on the underlying IP network, which needs to converge first. If your IGP is ISIS, then this in turn is strictly layered on CLNP.

It can take a while for the network to converge, but it comes up one layer at a time.

Stewart

Sent from my iPad

On 3 Dec 2015, at 05:50, Sinbad <[email-masked]<mailto:[email-masked]>> wrote:

On Sat, Nov 28, 2015 at 6:24 AM, Sinbad <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

In ldp igp synchronization rfc5443., it states that the igp link is advertised
with the highest cost when ldp is not reached operational state yet,
so that it is excluded from the topology. since ldp relies on igp to establish
a session (especially if the peer address is a loopback address), doesn't this
make a deadlock, ldp waiting for igp to converge and vice versa.

thanks
sinbad

_______________________________________________
Pals mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pals