Subject: RE: reliability and congestion control

From: George Tsirtsis <[email-masked]>
Date: Wed, 9 Jan 2002 12:45:30 -0500

Yoshihiro,

It is unfortunate that the charter seems to include *requirements*, rather
than just *scope* statements, since the first task is to produce a
requirements document. Congestion control is needed when you expect to have
significant traffic. If all you do is sending a couple packets and you are
expecting a couple of packets back congestion control is not possible.
Reliability can be handled with exponencial back-off timers and both SNARD
and EAPoverICMP can use those.

Regards
George
-----Original Message-----
From: Yoshihiro Ohba [mailto:[email-masked]]
Sent: Wednesday, January 09, 2002 5:26 PM
To: [email-masked]
Subject: reliability and congestion control

I have a basic question on ICMP-based schemes (SNARD and EAPoverICMP).

There is a statement in the charter:

"The PANA protocol needs reliability and congestion ontrol, taking
into account that the PANA protocol needs to be able to operate over
multiple router hops.  The congestion control principles are
documented in RFC 2914."

When a PAA is more than one-hop away from a device, is it easy for
ICMP to provide reliability and congestion control?  (I don't think
so.)

Yoshihiro Ohba

---

From: Reinaldo Penno <[email-masked]>
Date: Wed, 9 Jan 2002 10:57:34 -0800 (PST)

> expecting a couple of packets back congestion

I respectfully disagree. This is what TCP is
all-about. If you loose, for instance, your second
packet this means that there is congestion on the
network and you will not augment your window size. If
has already you would reduce it to one again.

> ICMP to provide reliability and congestion control? 

__________________________________________________
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!
http://promo.yahoo.com/videomail/

---

From: "James Kempf" <[email-masked]>
Date: Wed, 9 Jan 2002 11:40:12 -0800

There is also an issue about what network element
acts as the termination point for the PANA
transaction. I wonder if it makes much sense
to consider it beyond the last hop network.
Certainly, that isn't the case for current day
NASs, so I'd expect to see some strong arguments
(other than a general desire for flexibility)
why the current architecture isn't working.

    jak

----- Original Message -----
From: "George Tsirtsis" <[email-masked]>
To: "'Yoshihiro Ohba'" <[email-masked]>;
<[email-masked]>
Sent: Wednesday, January 09, 2002 9:45 AM
Subject: RE: reliability and congestion control