Subject: RE: Re: IETF53 PANA WG agenda

From: Paal Engelstad <[email-masked]>
Date: Sat, 9 Mar 2002 0:58:06 +0100

Hesham

> If not, then I think it's premature to say
> use EAP or not. Of course there are different 
> levels of knowledge in the WG and some might 

There are also different levels of engineering decisions that PANA will take on the path into solution space. To-EAP-or-not-to-EAP is one of the higher-level decisions that need to be taken early in the process. 

The point I was trying to make is that I fear that a separate LSA slot (i.e. not targeted at the LSA contradiction in the requirements document) will easily bring us into solution space discussions. If we are at all going to look forward into solution space in Minneapolis, the first issue that should be clarified is probably the EAP question.

Paal

> already 'know' that EAP will solve the problem
> no matter what the requirements are, but that 
> doesn't seem to be entirely clear on a WG
> level. So why the rush?
> 
> 
>   > - Add EAP-slot
> 
> => To say what?
> 
> Hesham
> 
>

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Sat, 9 Mar 2002 00:19:51 +0100

James

  > The issue that I have and I think some of us have had with 
  > PANA is that
  > doing an extensive requirements analysis under the 
  > assumption that the
  > WG is free to define whatever it wants for the carrier is swimming
  > against a massive tide in favor of EAP. Because of its 
  > widespread use,
  > assuming that EAP is not part of the requirements is sort of like
  > assuming that IP isn't part of the requirements, IMHO. If EAP is not
  > explicitly in the requirements, then I think it should be 
  > an unstated
  > assumption that it will be used. If this is not an unstated 
  > assumption,
  > then I think we had better discuss it and either state it or come up
  > with some really good reasons why we shouldn't use EAP. If 
  > we can come
  > up with some good reasons then I think it might make some 
  > sense to not
  > use it, but the reasons better be *really good*.

=> OK, I don't think we should have unstated assumptions. 
So I suppose you're proposing that it should 
be part of the requirements. As I said, I haven't 
formed an opinion on EAP, but it would be good 
to know what others think and why. I think the 'why'
part is just as important.

Hesham

  > 
  >             jak
  > 
  > ----- Original Message -----
  > From: "Hesham Soliman (ERA)" <[email-masked]>
  > To: "'Paal Engelstad'" <[email-masked]>; "Alper E. YEGIN"
  > <[email-masked]>; "James Kempf" 
  > <[email-masked]>;
  > "John Schnizlein" <[email-masked]>
  > Cc: <[email-masked]>
  > Sent: Friday, March 08, 2002 11:57 AM
  > Subject: RE: Re: IETF53 PANA WG agenda
  > 
  > 
  > > [note I have no opinion on what PANA should use]
  > >
  > > The question that comes to mind when I see this
  > > thread is: Do people think the requirements
  > > are done and we're now looking at solutions?
  > >

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Sat, 9 Mar 2002 01:43:02 +0100

> There are also different levels of engineering decisions 
  > that PANA will take on the path into solution space. 
  > To-EAP-or-not-to-EAP is one of the higher-level decisions 
  > that need to be taken early in the process. 

=> That's fine, but the rationale for these decision
must be given. When picking a solution I thought
one possible rationale would be 'it meets our requirements'.  
And there could be others. A discussion along 
this path would be more logical IMHO. That's why
Im wondering if it's a bit premature (before requirements
are done) to ask EAP or no EAP.

Hesham

---

From: George Tsirtsis <[email-masked]>
Date: Mon, 11 Mar 2002 08:31:37 -0500

Hesham,

The question here is not 'why EAP' but rather 'why not EAP'. I have yet to
hear one opinion against it...
We can progress much faster if we use EAP as a starting point and see what
pieces are missing for the PANA purpose.

George

-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: Friday, March 08, 2002 11:20 PM
To: 'James Kempf'; Hesham Soliman (ERA); 'Paal Engelstad'; Alper E.
YEGIN; John Schnizlein
Cc: [email-masked]
Subject: RE: Re: IETF53 PANA WG agenda

James

Hesham

---

From: George Tsirtsis <[email-masked]>
Date: Mon, 11 Mar 2002 08:39:22 -0500

Hesham,

I really hope that despite growing numbers the IETF will manage to avoid
being buried in pointless process. When something clearly make sense then we
should just do it or someone should argue why it does not makes sense. Just
blindly following a process is sad IMO....and I suspect that this is not
what you meant either.

George

-----Original Message-----
From: Hesham Soliman (ERA) [mailto:[email-masked]]
Sent: Saturday, March 09, 2002 12:43 AM
To: 'Paal Engelstad'; Hesham Soliman (ERA); Alper E. YEGIN; James Kempf;
John Schnizlein

Hesham

---

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 11 Mar 2002 20:51:17 +0100

George,

  > blindly following a process is sad IMO....and I suspect 

=> Yes that's not what I meant. I meant that
if it's so obvious then put it in the 
requirements draft. If it's not so obvious
to everyone then let's compare it against 
the requirements draft when it's finished. 
I just wanted to put the discussion in the 
context of the requirements draft. 

Hesham