Subject: RE: Comments on draft-ietf-pana-requirement-00.txt

From: "Hesham Soliman (ERA)" <[email-masked]>
Date: Mon, 11 Mar 2002 20:25:14 +0100

> In the MR case, the DI can be a MAC address
  > and the packets forwarded by the MR on behalf
  > of the clients behind it shouldn't be a problem.

=> OK, this addresses the DI issue, but 
it doesn't address the definition of 
a PaC being tied to a single IP address.

  > 
  > (you don't really want your MR to be aware of all
  > IP addresses of the clients in its mobile network and
  > do PANA for them)
  > 
  > If the ingress filtering of the access network is an issue,
  > probably MR has to reverse tunnel packets to a home
  > network, in which case the access network will only
  > see the IP address of the MR as the source of traffic.

=> That's getting into the solution space for monet.
This maybe one solution but I wouldn't want to 
rule out others that might come up by basing any
design decision on the model above.

  > Also, what is the privacy issue with the IP address as the DI?

=> If you want to use RFC3041, would you then
update the PAA when you configure a new
address? 

  > >    PANA SHOULD allow various types of identifiers to be 
  > used for the 
  > >    PaC (e.g., NAI, IP address, FQDN, etc.) 
  > >    PANA SHOULD allow various types of identifiers to be 
  > used as the DI 
  > >    (IP address, link-layer address, port number of a 
  > switch, etc.)  
  > > 
  > > => We have to mandate the support of at least one identifier 
  > > for interoperability. 
  > 
  > So, the requirements should say that the "PANA MUST mandate
  > at least one identifier", right? Just checking to make sure you are
  > not saying the requirements draft must set that one type.

=> I think it's good to say which identifier(s)
MUST be supported. I doubt it would have any
serious impacts on the protocol work. It's just
for interoperability.

Hesham

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Mon, 11 Mar 2002 11:33:30 -0800

> update the PAA when you configure a new

If the DI is the IP address of the PaC, then yes.
If the DI is the MAC address of the PaC, then no.

> serious impacts on the protocol work. It's just

alper