Subject: RE: Device ID and MitM attacks

From: "Mohan Parthasarathy" <[email-masked]>
Date: Wed, 6 Nov 2002 11:41:36 -0800

> 
> Some thoughts on device ID and man-in-the-middle attacks.
> 
> In the requirements draft, we had stated that device id (DI) 
> must be integrity protected against MitM attacks (req 4.1.1).
> 
> When PANA is used in networks where underlying layers are 
> secured (see sections 4.1, 4.2 of usage scenarios draft), 
> protection of DI should not be an issue. Assumption is that 
> there cannot be a MitM on the link to alter DI information.
> 
If the device identifier is the IP address, layer 2 security
does not help. I can still send packets with somebody else's
IP address but pass the layer 2 authentication.

-mohan

> But, when there is no lower layer security at all (see 
> section 4.3 of usage scenarios draft), it seems like we have 
> to make sure DI is integrity protected. But, having the right 
> DI should not be sufficient for a client to gain access once 
> it's authenticated. 
> Since these are unprotected links, nothing prevents an 
> attacker from spoofing DI of an already authenticated client 
> for gaining network 
> access. A complete solution would require this DI to be used with 
> per-packet authentication, e.g., by using IPsec. So, being able to 
> alter the DI information during PANA exchanges would not help 
> an attacker.
> 
> As long as per-packet authentication is based on a security 
> association that was bootstraped using a shared secret that 
> was a by-product of the EAP authentication method, that should work.
> 
> Comments?
> 
> alper
> 
> 
> 
>

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Wed, 6 Nov 2002 12:15:05 -0800

-----Original Message-----
	From: Hesham Soliman (EAB)
[mailto:[email-masked]] 
	Sent: Wednesday, November 06, 2002 11:50 AM
	To: Mohan Parthasarathy; Alper E. YEGIN; Pana (E-mail)
	Subject: RE: Device ID and MitM attacks

	=> I think the assumption is that the DI will be tied 
	to the L2 security credential

How do you tie the IP address  to the L2 security credential ?
Access Point (that verifes the L2 credential) need not be the
same as the EP that verifies the DI.
 
-mohan

 Hesham

		-mohan

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 6 Nov 2002 21:41:55 +0100

> I have one question.  If we consider a DSL scenario in which the
  > customer's network beyond the DSL modem uses insecure link layer
  > (i.e., legacy 802.11 with static WEP or no WEP) and the PaC 
  > is on the
  > insecure link layer, do we need DI protection for PANA or 
  > not?  I mean
  > that DSL link is physically secured but the entire access 
  > network may
  > not be secured.

=> I think it's a deployment question for operators. We need to provide the 
options for the PAA to require this. The PaC (AFAICS) does not know
how far the l2 security goes. So in cases where there are multiple 
L2's some operators might be happy with physical security (no one 
ever tapped my phone line and made calls that appeared on my phone bill  :) )
or they can require some form of secure encapsulation like IPsec.

Hesham

  > Yoshihiro Ohba

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Wed, 6 Nov 2002 12:51:48 -0800

> 
> Any chance you could turn off HTML? thanks.
> 
Sure..as I understand, it happens only when I respond to
HTML mail.

> => Well, link layers that have point to point link
> layer security (cellular) also have signalling 
> from "APs" to "ARs" so that they can maintain 
> this association. On an abstract sense, you're correct,
> but in practice this situation does not exist
> (i.e. p2p l2 encryption where the AR cannot bind 
> the IP address to the source). 
> 
In 802.11, if the AP (that uses 802.1x for L2 authentication)
and EP (as described by PANA), are different, it can happen,
right ? How does AP tell the EP ?

-mohan

---

From: "Hesham Soliman (EAB)" <[email-masked]>
Date: Wed, 6 Nov 2002 22:00:43 +0100

=> Not sure about that, my mail was in plain text :) 

=> But 802.11 does not have a point to point security
does it? 
So you'd only use the IP address as a DI "safely" if 
you trust that no one on-link will spoof IP addresses
e.g. our network in Ericsson has this type of 
security because the admin assumes that no one will
spoof anyone else's address. But in a public network
you can't make this assumption. So that's why I didn't
even consider this case. I was referring to L2s that
have point to point links, i.e. not multiaccess links. 
If each point to point link is secured with a different
key, then you can use the IP address as a DI. If the 
"AP" is separated from the EP these networks always
have protocols running between these boxes to keep
track of mapping between channels and IP addresses. 

Hesham

-mohan

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Wed, 6 Nov 2002 13:12:54 -0800

> In that case, DI should be the link-layer address of the PaC. 
> L2 security mechanism can ensure that the sender is 
> authorized to use the particular L2 address to get on the 
> link. By the time the packets are received by the L3 EP, they 
> are already verified for legitimate use of L2 address (no DI 
> spoofing possible). 

What are we trying to achieve by preventing device identifier spoofing ?
If one can spoof packets anyway using the IP address, then we have not
gained
much. Or are we saying that it is the outside the scope of PANA to
prevent all spoofing.

I think there are 2 different things being talked about in this thread.
In the context of the PANA requirements and PANA over TLS draft, it
talks
about Device Identifier protection during the authentication process to
prevent unauthorized access into the network. And then there is the
normal data traffic which needs DI protection. If my understanding is
correct, perhaps we should discuss this separately.

-mohan

> Now this EP can do further enforcement, such as whether packets can 
> get on the Internet, or tunneling them to specific ISP, etc.
>

---

From: "Mohan Parthasarathy" <[email-masked]>
Date: Wed, 6 Nov 2002 13:29:01 -0800

> => But 802.11 does not have a point to point security

Each client and the Access Point (actually any 2 stations)
can share a security association as mentioned in 
http://www.drizzle.com/~aboba/IEEE/11-02-TBDr0-I-Pre-Authentication.doc
i.e in the future.

-mohan