Subject: RE: About the NAP/ISP distinction in the usage-scenarios draft...

From: <[email-masked]>
Date: Fri, 10 Jan 2003 10:19:45 +0200

Ohba,

Thank you for these email attachements. I read them through and they described the multihoming problem, but I didn't mean multihoming. The PaC doesn't have to get an IP address from the SP network if NAP provides it (I don't know if I'm using the right terms). Anyway, IP address allocation is out of the scope. My picture is probably limited, because AR in the SP network could be a GW too.

So, PaC can use the existing IP address and request access to the SP network. This kind of scenario could support VPN networks too (PPVPN?).

Generally speaking, there could be multiple hops between EP and PaC. So, why to limit this with a requirement. A more general requirement could be to limit the number of hops between PAA and it's related EPs, if that is really needed.

- Dan

> -----Original Message-----
> From: ext Yoshihiro Ohba [mailto:[email-masked]]
> Sent: 09 January, 2003 19:56
> To: Forsberg Dan (NRC/Helsinki)
> Cc: [email-masked]; [email-masked]; 
> [email-masked]; Patil Basavaraj 
> (NET/Dallas); [email-masked]
> Subject: Re: About the NAP/ISP distinction in the 
> usage-scenarios draft...
> 
> 
> On Wed, Jan 08, 2003 at 04:45:20PM +0200, 
> [email-masked] wrote:
> > Hi all and Happy New Year!
> > 
> > The multi-method authentication happens in serial and in 
> the same "session", thus it doesn't fit for all cases.
> > 
> > As PANA is carried over IP, I never really understood the 
> requirement for the PAA to be in the same link than PaC. For 
> discovery purposes this is not necessary, especially in cases 
> where PAA initiates the authentication/authorization. Usage 
> scenario below.
> > 
> > When PaC utilizes multiple ISPs, the auth. happens when PaC 
> starts to access the ISP's network.
> 
> The usage scenario team actually considered that scenario before
> submitting the current version.  But we concluded we should not
> describe it due to the difficulty of supporting multihomed
> single-interface hosts.  I attach related email discussion in IPv6
> WG (sorry for long attachment).
> 
> > 
> >              . . . . . . . . . . . . . .
> >              .             .           .        
> >    PaC . . . AR--PAA   |  AR--PAA  |  AR--PAA  |
> >                   |    |       |   |       |   |
> >                  AAA   |      AAA  |      AAA  |
> >                (NAP)   |   (ISP)   |   (ISP)   | 
> > 
> > - Dan
> > 
> > 
> 
> Yoshihiro Ohba
>

---

From: "Alper E. YEGIN" <[email-masked]>
Date: Fri, 10 Jan 2003 10:07:23 -0800

> Generally speaking, there could be multiple hops between EP and PaC. So,
why to limit this with a requirement. A more general requirement could be to
limit the number of hops between PAA and it's related EPs, if that is really
needed.

There is no requirement regarding the number of hops between the EP and PaC.
But there is one for between PAA and PaC. The decision was to require
them to be one hop away, because having multiple hops incurs complexity
which
was not justified by an essential usage scenario.

alper