Subject: [Fwd: RE: comments on draft-ietf-pana-threats-01.txt]

From: Subir Das <[email-masked]>
Date: Mon, 20 Jan 2003 17:46:32 -0500

-------- Original Message --------
Subject: RE: comments on draft-ietf-pana-threats-01.txt
Date: Mon, 20 Jan 2003 17:43:14 -0500 (EST)
From: Bernard Aboba <[email-masked]>
To: Mohan Parthasarathy <[email-masked]>
CC: [email-masked]

> > So how do you prevent hijacking?
> >
> By setting up SAs. Once the authentication is complete, it is assumed that
> keys can be derived using the EAP framework (this is where PANA needs to
> provide additional details for 4-way) and that can be used as input to
> securing the future communications. I agree that these details
> are missing as to how this will happen. The service theft section discusses
> this to the extent that there are vulnerabilities but it does not
> go into details about what could be done as it was outside the scope of
> the threats evaluation document itself. It says ".... PANA should be able
> to provide keys...". I will clarify this further.

EAP is not a good mechanism for keying IPsec SAs -- unless perhaps you
were to run IKE over EAP.

> Ok. Perhaps, we should revisit to see why PAA and EP cannot be always
> co-located.

That would be better.

---

From: Alper Yegin <[email-masked]>
Date: Mon, 20 Jan 2003 23:39:04 -0800

> were to run IKE over EAP.

When needed (that is, in the absence of phy and L2 protection), the current
thinking is to run IKE after PANA... PANA would help create (bootstrap) a
shared secret for IKE to build the needed SAs for IPsec..

alper