Subject: RE: [issue9] Message format

From: "Mohan Parthasarathy" <[email-masked]>
Date: Mon, 23 Jun 2003 12:40:18 -0700

> 
> On Mon, Jun 23, 2003 at 11:14:03AM -0700, Mohan Parthasarathy wrote:
> > > > When L2 ciphering is already used in the network, what kind of
> > > > protection is gained by also enabling IPsec between the 
> PaC and EP 
> > > > (other than potentially solving IP address ownership issues)?
> > > 
> > > Insider attacker (meaning that he has L2 ciphering keys) can
> > > spoof other insider's higher-layer fields in data packets 
> > > (though he cannot spoof L2 headers).  I think SEND only 
> > > protects ND messages, not data packets.  For the same reason,
> > 
> > Right. Ipsec will prevent someone spoofing at layer 3. But 
> what does 
> > it buy for the attacker ? Here the attacker is the one who is also 
> > using L2 cipher. What is the motivation for the attacker to 
> spoof the 
> > L3 fields ? He can potentially launch some attack with spoofed L3 
> > fileds. What else ?
> 
> He can also spoof L4 and higher-layer fields of a legitimate 
> client's traffic in addition to L3 fields.  Note that a 

If the PaC needs to protect against that, why would it not
use some other end-to-end mechanism rather than resorting
to securing just the first hop with IPsec ?

> legitimate client with using IPsec in the access network (or 
> VPN or end-to-end ) can also spoof its own higher-layer 
> traffic, but that is completely out of the scope of network 
> access security and should be protected by using
> transport- and/or application-layer security.
> 
> Yoshihiro Ohba
> 
mohan

---

From: Yoshihiro Ohba <[email-masked]>
Date: Mon, 23 Jun 2003 13:51:26 -0700

> to securing just the first hop with IPsec ?

You are right.  On the other hand, I just answered to your question on
what fields an attacker on the first hop can spoof when there is no
first hop IPsec.

Yoshihiro Ohba