Subject: FW: [issue17] Error handling

From: <[email-masked]>
Date: Mon, 11 Aug 2003 18:41:47 +0300

Dan Forsberg <[email-masked]> added the comment:

Alper Yegin (with editorial fixes): 

PANA-error message MAY be sent by either PaC or PAA when a
badly formed PANA message is received (see section 4.1.7).
If the cause of this error message was a request message
(e.g., PANA-PAA-Discover or *-Request), then the request MAY
be retransmitted immediately without waiting for its
retransmission timer to go off. If the cause of the error
was a response message, the receiver of the PANA-error
SHOULD NOT resend the same response until it receives the
next request.

Yoshihiro Ohba:

When an error message is sent unprotected with MAC AVP and
the lower-layer is insecure, the error message is treated as
an informational message.  The receiver of such an error
message MUST NOT change its state unless the error persists
and the PANA session is not making any progress.

----------
status: No Discussion -> Text Proposed
________________________________________________
PANA Issues <[email-masked]>
http://danforsberg.info:8080/pana-issues/issue17
________________________________________________

---

From: <[email-masked]>
Date: Thu, 21 Aug 2003 13:31:10 +0300

Error message handling:
---------------------------------------------------------
PANA-error message MAY be sent by either PaC or PAA when a
badly formed PANA message is received or in case of other
errors.  If the cause of this error message was a request
message (e.g., PANA-PAA-Discover or *-Request), then the
request MAY be retransmitted immediately without waiting for
its retransmission timer to go off. If the cause of the
error was a response message, the receiver of the PANA-error
SHOULD NOT resend the same response until it receives the
next request.

To defend against DoS attacks a timer MAY be used. One (1)
error notification is sent to each different sender each N
seconds. N is a configurable parameter.

Error message format:
---------------------------------------------------------

   PANA-Error ::= < PANA-Header: 12 >
                   < Session-Id > 
		   < Result-Code >
                   { Failed-AVP }
                 * [ AVP ] 
               0*1 < MAC >