Subject: new [issue20] Retransmission timers and counts

From: <[email-masked]>
Date: Wed, 13 Aug 2003 12:54:25 +0300

http://danforsberg.info:8080/pana-issues/issue20
"Define default timer and retransmission counts for 
the discover, start, reauth, bind, and terminate
 messages."

---

From: <[email-masked]>
Date: Thu, 21 Aug 2003 14:50:06 +0300

How about this? Copied this text from mipv6 draft (24) with modifications 
for pana. In most cases PAA is doing retransmissions, but for PANA-Discover 
and PANA-Reauth-Request from PaC, PaC is doing retransmissions.

The TIMEOUT values are not from any spec.

------------
The retransmissions MUST use an exponential back-off process, in which the timeout period is doubled upon each retransmission until either the node receives a response or the timeout period reaches the value MAX_RESPONSE_TIMEOUT. The first timeout period is MIN_RESPONSE_TIMEOUT. PaC MAY continue sending PANA-Discover messages indefinetly with MIN_INDEFINIT_DISCOVER interval.

MIN_INDEFINIT_DISCOVER_TIMEOUT   1s ??
MAX_RESPONSE_TIMEOUT             64s ??
MIN_RESPONSE_TIMEOUT             250ms ??
------------

Br,
- Dan

> -----Original Message-----
> From: ext [mailto:[email-masked]]
> Sent: 13 August, 2003 12:54
> To: [email-masked]
> Subject: new [issue20] Retransmission timers and counts
> 
>