Subject: Re: new [issue20] Retransmission timers and counts

From: Alper Yegin <[email-masked]>
Date: Wed, 27 Aug 2003 17:50:53 -0700

Hi Dan,

How about following the rfc3315 model? This spec first identifies the
various components of a retransmission policy (section 14) and for each
message it specifies what they should be (like in 17.1.2 where
IRT=SOL_TIMEOUT for solicit messages). And finally defines the default
values for the constants in 5.5 (e.g., SOL_TIMEOUT=1sec)

The PANA messages that require retransmission are:

PANA-PAA-Discover
PANA-Start-Request 
PANA-Bind-Request  
PANA-Reauth-Request
PANA-Termination-Request

Comments?

Alper

> How about this? Copied this text from mipv6 draft (24) with modifications
> for pana. In most cases PAA is doing retransmissions, but for PANA-Discover
> and PANA-Reauth-Request from PaC, PaC is doing retransmissions.
> 
> The TIMEOUT values are not from any spec.
> 
> ------------
> The retransmissions MUST use an exponential back-off process, in which the
> timeout period is doubled upon each retransmission until either the node
> receives a response or the timeout period reaches the value
> MAX_RESPONSE_TIMEOUT. The first timeout period is MIN_RESPONSE_TIMEOUT. PaC
> MAY continue sending PANA-Discover messages indefinetly with
> MIN_INDEFINIT_DISCOVER interval.
> 
> MIN_INDEFINIT_DISCOVER_TIMEOUT   1s ??
> MAX_RESPONSE_TIMEOUT             64s ??
> MIN_RESPONSE_TIMEOUT             250ms ??
> ------------
> 
> 
> Br,
> - Dan
> 
>> -----Original Message-----
>> From: ext [mailto:[email-masked]]
>> Sent: 13 August, 2003 12:54
>> To: [email-masked]
>> Subject: new [issue20] Retransmission timers and counts
>> 
>> 
>> http://danforsberg.info:8080/pana-issues/issue20
>> "Define default timer and retransmission counts for
>> the discover, start, reauth, bind, and terminate
>>  messages."
>> 
>> 
> 
> 
>

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 28 Aug 2003 13:02:18 -0700

> values for the constants in 5.5 (e.g., SOL_TIMEOUT=1sec)

I agree on using the RFC3315 methodology for defining retransmission
policy and default values.  This is very nice.

> The PANA messages that require retransmission are:

Considering the case of using optional stateless cookie, I'd suggest
retransmitting PANA-Start-Answer instead of PANA-Start-Request.

> PANA-Termination-Request

Yoshihiro Ohba

---

From: Alper Yegin <[email-masked]>
Date: Thu, 28 Aug 2003 13:21:11 -0700

> retransmitting PANA-Start-Answer instead of PANA-Start-Request.

I think this makes sense. Especially, if there are multiple PAAs on the
link, and the PaC will choose one of them to move forward with the PANA
exchange.

Alper