Subject: RE: [Pana] FW: [issue154] PANA SA description: liveness test failure

From: [email-masked]
Date: Tue, 28 Dec 2004 11:34:52 +0200

Alper,

It's hard to find "message retransmission timeout" for the word
"timeout" in this context. Thus, it makes sense to include something
about this. 

For example, it was a bit new for me that expiration for ANY PANA
message can result in session expiration. I think the interpretation
can differ and that is why we should be more explicit here.

- Dan

> -----Original Message-----
> From: ext Alper Yegin [mailto:[email-masked]]
> Sent: 27 December, 2004 19:55
> To: Forsberg Dan (Nokia-NRC/Helsinki); [email-masked]
> Subject: RE: [Pana] FW: [issue154] PANA SA description: liveness test
> failure
> 
> 
> Hi Dan,
> 
> The "timeout" in the text already covers for this case. It 
> stands for a
> timer expiration for any PANA message, including PANA-Ping-Request.
> 
> Alper
> 
> 
> > -----Original Message-----
> > From: [email-masked] [mailto:[email-masked]] On Behalf
> Of
> > [email-masked]
> > Sent: Monday, December 27, 2004 1:40 AM
> > To: [email-masked]
> > Subject: [Pana] FW: [issue154] PANA SA description: liveness test
> failure
> > 
> > New submission from Dan Forsberg <[email-masked]>:
> > 
> > The liveness test failure result should be reflected in this text as
> well.
> > 
> > Change (07d):
> > 
> > PANA Session:
> > 
> >      A PANA session begins with the handshake between the 
> PANA Client
> >      (PaC) and the PANA Authentication Agent (PAA), and 
> terminates as
> >      a result of an authentication failure, a timeout, or 
> an explicit
> >      termination message.  A fixed session identifier is maintained
> >      throughout a session.  A session cannot be shared 
> across multiple
> >      network interfaces. Only one device identifier of the PaC is
> >      allowed to be bound to a PANA session for simplicity.
> > 
> > TO:
> > 
> > PANA Session:
> > 
> >      A PANA session begins with the handshake between the 
> PANA Client
> >      (PaC) and the PANA Authentication Agent (PAA), and 
> terminates as
> >      a result of an authentication or liveness test failure 
> failure, a
> >      timeout, or an explicit termination message.  A fixed session
> >      identifier is maintained throughout a session.  A 
> session cannot
> >      be shared across multiple network interfaces. Only one device
> >      identifier of the PaC is allowed to be bound to a PANA session
> >      for simplicity.
> > 
> > 
> > Br,
> > - Dan
> > 
> > ----------
> > assignedto: dforsber
> > category: Editorial
> > document: draft-ietf-pana-pana-06.txt
> > messages: 541
> > nosy: dforsber
> > priority: Should Fix
> > status: Text Proposed
> > title: PANA SA description: liveness test failure
> > ___________________________________________________
> > PANA Issues <[email-masked]>
> > <http://danforsberg.info:8080/pana-issues/issue154>
> > ___________________________________________________
> 
> 

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 28 Dec 2004 10:09:57 -0500

I agree with Dan.  (I thought "timeout" here meant "expiration of
session lifetime".)

A message retransmission timeout does not cause session termination
unless the number of retransmission reaches its maximum value.  So, 
it should not mean "retransmission timeout".

Yoshihiro Ohba

---

From: Alper Yegin <[email-masked]>
Date: Tue, 28 Dec 2004 11:35:22 -0800

This should do it then: 

PANA Session:

      A PANA session begins with the handshake between the
      PANA Client (PaC) and the PANA Authentication Agent (PAA), and
      terminates as a result of an authentication or liveness test 
      failure, a message delivery failure after retransmissions reach
      maximum values,  session lifetime expiration, or an explicit 
      termination message.  A fixed session identifier is maintained 
      throughout a session.  A session cannot be shared across multiple
      network interfaces. Only one device identifier of the PaC is 
      allowed to be bound to a PANA session for simplicity.

Alper

> From: Yoshihiro Ohba [mailto:[email-masked]]
> Sent: Tuesday, December 28, 2004 7:10 AM
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: [Pana] FW: [issue154] PANA SA description: liveness test
> failure
>

---

From: Yoshihiro Ohba <[email-masked]>
Date: Tue, 28 Dec 2004 17:55:54 -0500

The text looks fine.  

Thanks,

Yoshihiro Ohba