Subject: RE: [Pana] Issue 143: CTP and PANA editorial clarification

From: Gerardo Giaretta <[email-masked]>
Date: Mon, 06 Dec 2004 17:29:19 +0100

> On Fri, Dec 03, 2004 at 02:33:25PM -0800, Alper Yegin wrote:
> > > >
> > > > So, if we want to remove the specifics from the text, 
> let's remove
> > all.
> > > > Leaving some parts does not help, it only leaves more unanswered
> > > > questions behind.
> > > 
> > > The members who came up with the proposed text discussed 
> this also as
> > > an alternative.  The conclusion among them was that once 
> we remove the
> > > entire section, then it would be difficult to add the 
> functionality of
> > > mobility optimization later, since it affects the PANA protocol
> > > behavior (it is not just adding some optional AVP, it also defines
> > > optimized PANA message sequence).  Especially from the 
> state machine
> > > perspective, I think it is better to keep the framework mobility
> > > optimization solution in the base PANA specification.
> > 
> > I don't think we have to worry about that. Even if we have 
> no mention of
> > an optimization in the base spec, we should be able to add 
> new AVPs on
> > existing messages, update the flow, and come up with an 
> updated state
> > machine accordingly. We can do this right and not break anything.
> > 
> > Putting a sketch of a solution without the matching details 
> in the spec
> > is problematic in my opinion. First of all, it raises many questions
> > which are only answered in the full-solutions (now we'll 
> have to deal
> > with those during reviews). Secondly, fixing a framework may
> > unintentionally limit the solution space down the road. 
> > 
> > Three options we have are:
> > 1- Proceed with an instance of a full mobility optimization (current
> > text --  does not limit the solutions to that one)
> > 2- Provide a framework but not a full solution
> > 3- Remove mobility optimization from the spec completely, 
> and produce a
> > separate document on that. 
> > 
> > I recommend we do either 1 or 3, but not 2.
> 
> If we will have a good chance to modify the base specification as well
> as the state machine to support mobility optimization in a future (my
> original impression was that it would be less likely to do that), I
> would go with option 3.  I don't agree with option 1 for which
> significant issues were already raised.
> 

I'm in favour of option 3 too.

--Gerardo

> Yoshihiro Ohba
> 
> > 
> > Alper
> > 
> > 
> 
> _______________________________________________
> Pana mailing list
> [email-masked]
> https://www1.ietf.org/mailman/listinfo/pana
> 

Gruppo Telecom Italia - Direzione e coordinamento di Telecom Italia S.p.A.

====================================================================
CONFIDENTIALITY NOTICE
This message and its attachments are addressed solely to the persons
above and may contain confidential information. If you have received
the message in error, be informed that any use of the content hereof
is prohibited. Please return it immediately to the sender and delete
the message. Should you have any questions, please send an e_mail to
[email-masked]. Thank you
====================================================================

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: [email-masked]
Date: Thu, 9 Dec 2004 11:17:44 +0200

agreed.
- Dan

> -----Original Message-----
> From: ext Rafa Marin Lopez [mailto:[email-masked]]
> Sent: 08 December, 2004 19:08
> To: Yoshihiro Ohba
> Cc: Forsberg Dan (Nokia-NRC/Helsinki); [email-masked];
> [email-masked]; Rafa Marin Lopez
> Subject: Re: [Pana] Issue 143: CTP and PANA editorial clarification
> 
> 
> Hi Dan,
> 
> Agree with Yoshi...
> 
> I think only place we are talking to send Session-Id AVP is when PaC
> wants mobility-optimization( and it is carried in PSA).
> 
> Regards.
> 
> 
> Yoshihiro Ohba wrote:
> 
> >Hi Dan,
> >
> >I think we are removing session id from PSA in the base 
> specification,
> >because it is not needed in PSA if we don't talk about 
> mobility in the
> >base specification.
> >
> >Yoshihiro Ohba
> >
> >
> >On Wed, Dec 08, 2004 at 10:45:04AM +0200, 
> [email-masked] wrote:
> >  
> >
> >>I don't think we are removing session Id.
> >>- Dan
> >>
> >>    
> >>
> >>>-----Original Message-----
> >>>From: [email-masked] 
> [mailto:[email-masked]]On Behalf Of
> >>>ext Rafa Marin Lopez
> >>>Sent: 07 December, 2004 20:11
> >>>To: Alper Yegin
> >>>Cc: 'Yoshihiro Ohba'; [email-masked]
> >>>Subject: Re: [Pana] Issue 143: CTP and PANA editorial clarification
> >>>
> >>>
> >>>Hi Alper,
> >>>
> >>>Alper Yegin wrote:
> >>>
> >>>      
> >>>
> >>>> 
> >>>>
> >>>>        
> >>>>
> >>>>>If we will have a good chance to modify the base 
> >>>>>          
> >>>>>
> >>>specification as well
> >>>      
> >>>
> >>>>>as the state machine to support mobility optimization in a 
> >>>>>          
> >>>>>
> >>>future (my
> >>>      
> >>>
> >>>>>would go with option 3.  
> >>>>The mobility optimization would be in another spec. Hence, 
> >>>>        
> >>>>
> >>>the base spec
> >>>      
> >>>
> >>>>would not be modified (it does not have to be modified...).
> >>>>
> >>>>        
> >>>>
> >>>I have a doubt here: let suppose we remove this section then 
> >>>PANA spec 
> >>>does not know anything about that. Then we add in another 
> >>>document, for 
> >>>example, solution exposed in the current PANA spec. Here 
> we would be 
> >>>introducing new AVPs (session Id ) and a change of  PaC and PAA 
> >>>behaviour  and their state machines... If I understand well, this 
> >>>mobility optimization would not be valid because we are 
> changing PANA 
> >>>spec (behaviour and new AVPs) (is this your thought?) ... or 
> >>>there would 
> >>>not be problem by adding this new AVPs and changing state 
> machines in 
> >>>the new spec?
> >>>
> >>>Regards.
> >>>
> >>>      
> >>>
> >>>>Alper
> >>>>
> >>>>
> >>>>
> >>>>
> >>>-- 
> >>>------------------------------------------------------
> >>>Rafael Marin Lopez
> >>>Faculty of Computer Science-University of Murcia
> >>>30071 Murcia - Spain
> >>>Telf: +34968367645    e-mail: [email-masked]
> >>>------------------------------------------------------
> >>>
> >>>
> >>>
> -- 
> ------------------------------------------------------
> Rafael Marin Lopez
> Faculty of Computer Science-University of Murcia
> 30071 Murcia - Spain
> Telf: +34968367645    e-mail: [email-masked]
> ------------------------------------------------------
> 
> 
>