Subject: [Pana] issue135: reject?

From: Yoshihiro Ohba <[email-masked]>
Date: Mon, 06 Dec 2004 15:27:58 -0500

In this particular case of rejected authorization, the PANA session
can be deleted immediately after completion of PANA-Bind exchange, and
thus no PTR/PTA exchange is needed.

Yoshihiro Ohba

-----------
>>-- "When this occurs, the PAA MUST send PANA-Bind-Request with a result
>>code PANA_AUTHORIZATION_REJECTED. If a AAA-Key is established between
>>PaC and PAA by the time when the EAP-Success is generated by the EAP
>>server (this is the case when the EAP method provides protected success
>>indication), this PANA-Bind message exchange MUST be protected with a
>>MAC AVP and with carrying a Key-Id AVP. The AAA-Key and the PANA session
>>MUST be deleted after the PANA-Bind message exchange".
>>
>>Would it make sense finish the session by using a traditional PTR/PTA
>>exchange?
>>    
>>
>
>Since PTR/PTA does not contain a Key-Id AVP, you cannot use PTR/PTA to
>derive PAMA_MAC_KEY and then immediately terminate the session.
>

Rafa: 

Maybe I didn't understand your answer but AFTER PANA-Bind-X exchange and
in order to remove the session... is it not possible to send PTR/PTA
with a Termination cause related with problem?

Yoshihiro Ohba

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Alper Yegin <[email-masked]>
Date: Tue, 07 Dec 2004 15:03:56 -0800

Makes sense to me.

Alper

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
> Yoshihiro Ohba
> Sent: Monday, December 06, 2004 12:28 PM
> To: [email-masked]
> Subject: [Pana] issue135: reject?
>