Subject: RE: [Pana] PANA and lower layer ciphering

From: "Salowey, Joe" <[email-masked]>
Date: Tue, 21 Jun 2005 20:17:46 -0700

> I think that we do not need to seperate the first and second 
> halves, since each EP is uniquely identified by the 
> address-family and address pair and the pair is contained in 
> Device-Id AVP.  We can simply involve not only the address 
> but also address-family in the computation of PaC-EP master 
> keys, something like:
> 
> 
> PaC-EP-Master-Key = HMAC-SHA-1 (AAA-Key, "PaC-EP master key" |
>                                 Session ID | Key-ID | EP-Device-Id)
> 
> (EP-Device-Id: the value field of Device-Id AVP)
> 

[Joe] This seems OK.  Just to clarify the device ID appears to be
optional ( this is OK, but you need to specify what to do if it isn't
there).  

> Yoshihiro Ohba

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: Yoshihiro Ohba <[email-masked]>
Date: Wed, 22 Jun 2005 08:07:55 -0400

Hi Joe,

> optional ( this is OK, but you need to specify what to do if it isn't

Why should device ID be optional?  I would assume that every EP that
is capable of ciphering has a device id, except for PPP EP.  So are
you considering bootstrapping PPP encryption from PANA?

Yoshihiro Ohba