Subject: [Pana] Piggybacking EAP in PAN

From: Yoshihiro Ohba <[email-masked]>
Date: Mon, 16 Apr 2007 19:00:59 -0400

In Section 4.1:

"
   EAP messages are carried in PANA-Auth-Request messages.
   PANA-Auth-Answer messages are simply used to acknowledge receipt of
   the requests.  As an optimization, a PANA-Auth-Answer message MAY
   include the EAP message.  This optimization SHOULD NOT be used when
   it takes time to generate the EAP message (due to, e.g., intervention
   of human input), in which case returning an PANA-Auth-Answer message
   without piggybacking an EAP message can avoid unnecessary
   retransmission of the PANA-Auth-Request message.
"

I think this piggybacking is allowed for PAN generated by PaC only.
Piggybacking EAP for PAN generated by PAA should not allowed,
otherwise the protocol operation can be complex.

Yoshihiro Ohba

_______________________________________________
Pana mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pana

---

From: "Alper Yegin" <[email-masked]>
Date: Thu, 19 Apr 2007 09:25:04 +0300

I agree.

Most of the benefits are realized when the PaC's "answer" can carry "EAP
response". 

The case where PAA needs to send PAN and can hang on to it until it receives
the next EAP Request seems less likely and possibly not worth the
complication.

Alper

> -----Original Message-----
> From: Yoshihiro Ohba [mailto:[email-masked]]
> Sent: Tuesday, April 17, 2007 2:01 AM
> To: [email-masked]
> Subject: [Pana] Piggybacking EAP in PAN
> 
> In Section 4.1:
> 
> "

---

From: "MORAND Lionel RD-CORE-ISS" <[email-masked]>
Date: Thu, 19 Apr 2007 09:21:58 +0200

I agree too.

Lionel 

> -----Message d'origine-----
> De : Alper Yegin [mailto:[email-masked]] 
> Envoyé : jeudi 19 avril 2007 08:25
> À : 'Yoshihiro Ohba'; [email-masked]
> Objet : RE: [Pana] Piggybacking EAP in PAN
> 
> I agree.
> 
> Most of the benefits are realized when the PaC's "answer" can 
> carry "EAP response". 
> 
> The case where PAA needs to send PAN and can hang on to it 
> until it receives the next EAP Request seems less likely and 
> possibly not worth the complication.
> 
> Alper
> 
> 
>

---

From: Yoshihiro Ohba <[email-masked]>
Date: Thu, 19 Apr 2007 07:45:50 -0400

OK.  Here is suggested text ("sent from the PaC" is added in the 2nd sentence):

"
   the requests.  As an optimization, a PANA-Auth-Answer message sent from the PaC MAY

Yoshihiro Ohba