Subject: [Pana] Fwd: I-D Action: draft-yegin-pana-unspecified-addr-05.txt

From: Alper Yegin <[email-masked]>
Date: Fri, 16 Dec 2011 18:37:33 +0200

Folks,

Please see below for the latest revision of pana-unspecified-addr draft.
Authors' objective is to have an "independent submission" with this draft. (http://www.rfc-editor.org/indsubs.html)

This is a good time to register one last round of comments, if any.

Alper

Begin forwarded message:

> From: [email-masked]
> Subject: I-D Action: draft-yegin-pana-unspecified-addr-05.txt
> Date: December 16, 2011 3:38:44 PM GMT+02:00
> To: [email-masked]
> Reply-To: [email-masked]
> 
> 
> A New Internet-Draft is available from the on-line Internet-Drafts directories.
> 
> 	Title           : Protocol for Carrying Authentication for Network Access (PANA) with IPv4 Unspecified Address
> 	Author(s)       : Alper Yegin
>                          Yoshihiro Ohba
>                          Lionel Morand
>                          John Kaippallimalil
> 	Filename        : draft-yegin-pana-unspecified-addr-05.txt
> 	Pages           : 9
> 	Date            : 2011-12-16
> 
>   This document defines how PANA client (PaC) can perform PANA
>   authentication prior to configuring an IP address.
> 
> 
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-yegin-pana-unspecified-addr-05.txt
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> This Internet-Draft can be retrieved at:
> ftp://ftp.ietf.org/internet-drafts/draft-yegin-pana-unspecified-addr-05.txt
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: Rafa Marin Lopez <[email-masked]>
Date: Tue, 20 Dec 2011 19:45:06 +0100

Hi all:

I have been reading this document, and I believe the work is useful in some scenarios, so I support it. Also its content is clear to me and, therefore, I do not have really major concerns. 

However I was just wondering if some text could be included giving some comments about how to relate the obtention of the IP address after a successful authentication. I believe that there should be a relationship between them, since the PaC should not configure any IP address unless it is well authenticated (in the scenarios where this document applies). That link is missing in the document.

Best regard.

El 16/12/2011, a las 17:37, Alper Yegin escribió:

> Pana mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pana

-------------------------------------------------------
Rafael Marin Lopez, PhD
Dept. Information and Communications Engineering (DIIC)
Faculty of Computer Science-University of Murcia
30100 Murcia - Spain
Telf: +34868888501 Fax: +34868884151 e-mail: [email-masked]
-------------------------------------------------------

---

From: Alper Yegin <[email-masked]>
Date: Wed, 21 Dec 2011 11:18:03 +0200

Hi Rafa,

> However I was just wondering if some text could be included giving some comments about how to relate the obtention of the IP address after a successful authentication. I believe that there should b…

Good point. We can expand on that. We can informatively talk about how DHCP server/relay may be co-located with the PAA and how it responds to the PaC node only when the PANA authentication succeeds. This is one way of implementing/deploying the solution. There can be other ways as well. If that's what you were thinking, I can turn this into proposed text.

Alper

---

From: Rafa Marin Lopez <[email-masked]>
Date: Wed, 21 Dec 2011 11:58:50 +0100

Hi Alper:

> Good point. We can expand on that. We can informatively talk about how DHCP server/relay may be co-located with the PAA and how it responds to the PaC node only when the PANA authentication succeed…

Yes, that's basically what I meant.

Thanks.