Subject: [PANRG] PANRG draft on "dont-do-this"

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 16 Nov 2017 14:03:56 +0800

Dear PANRG,

I just volunteered  to start the draft on failed proposals for path
awareness, so that we make it easy for people to learn from experience.

This note is at least partially so people can find me.

What I'd suggest, is that I start with a couple of projects that I worked
on, and see what kind of template makes sense.

If you can suggest path aware projects that should be included, please drop
me an email with the name of the project. I'll circle back when I know what
to ask about that project.

"Thanks in advance"

Spencer, as co-chair for TRIGTRAN

---

From: "Scharf, Michael (Nokia - DE/Stuttgart)" <[email-masked]>
Date: Thu, 16 Nov 2017 08:05:39 +0000

One document in this space is the experimental RFC 4782 (“QuickStart for TCP and IP”).

We had a Linux TCP/IP and a network processor based router implementation (see e.g., http://www.ikr.uni-stuttgart.de/Content/Publications/Archive/Sf_PFLDnet2008_36632.pdf) , and in addition some other research groups have looked at QuickStart ten years ago. But I am not really aware of any real adoption.

Michael

From: Panrg [mailto:[email-masked]] On Behalf Of Spencer Dawkins at IETF
Sent: Thursday, November 16, 2017 7:04 AM
To: [email-masked]
Subject: [PANRG] PANRG draft on "dont-do-this"

Dear PANRG,

I just volunteered  to start the draft on failed proposals for path awareness, so that we make it easy for people to learn from experience.

What I'd suggest, is that I start with a couple of projects that I worked on, and see what kind of template makes sense.

If you can suggest path aware projects that should be included, please drop me an email with the name of the project. I'll circle back when I know what to ask about that project.

"Thanks in advance"

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Thu, 16 Nov 2017 16:45:13 +0800

> One document in this space is the experimental RFC 4782 (“QuickStart for

Thank you for this.

> We had a Linux TCP/IP and a network processor based router implementation
> (see e.g., http://www.ikr.uni-stuttgart.de/Content/Publications/
> Archive/Sf_PFLDnet2008_36632.pdf) , and in addition some other research
> groups have looked at QuickStart ten years ago. But I am not really aware
> of any real adoption.
>

That last line is EXACTLY the kind of thing I'm looking for :-)

Spencer

> Michael
>
>
>
>
>
>
>
> *From:* Panrg [mailto:[email-masked]] *On Behalf Of *Spencer
> Dawkins at IETF
> *Sent:* Thursday, November 16, 2017 7:04 AM
> *To:* [email-masked]
> *Subject:* [PANRG] PANRG draft on "dont-do-this"
>
>
>
> Dear PANRG,
>
>
>
> If you can suggest path aware projects that should be included, please
> drop me an email with the name of the project. I'll circle back when I know
> what to ask about that project.
>
>
>
> "Thanks in advance"
>
>
>

---

From: Katsushi Kobayashi <[email-masked]>
Date: Thu, 16 Nov 2017 17:45:53 +0800

Hi, 

Couple of  projects exploring path, or link, aware mechanism that I worked on are:

1. K. Nakauchi and K. Kobayashi. An explicit router feedback framework for
high bandwidth-delay product networks. Comput. Netw., 51, May 2007.

2. D. Mochinaga, et al,"i-Path: Improving Path Visibility for the Future Internet” ,
12th IEEE/IPSJ International Symposium on Applications and the Internet, July, 2012

In the later project, i-Path, we explored not only to improve transport performance,
but also applications to take advantage of path information. While we also implemented
L3.5 stack on three OS platforms, FreeBSD, Linux, MacOSX, any career and vendor
was not interested in, unfortunately. 

---
Katsushi Kobayashi

> 2017/11/16 午後2:03、Spencer Dawkins at IETF <[email-masked]>のメール:
> 
> Dear PANRG,
> 
> _______________________________________________
> Panrg mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/panrg