Subject: [PANRG] IETF/IRTF huddle about Performance Implications of PATH Characteristics (PIPC)

From: Spencer Dawkins at IETF <[email-masked]>
Date: Tue, 23 Jul 2019 16:21:30 -0400

Dear PANRG,

The PILC ("Performance Implications of Link Characteristics") working group
produced a number of BCPs providing guidance for protocol designers working
with links that were slow, error-prone, and asymmetric, for subnetwork
designers, and for Performance Enhancing Proxies (PEPs), between 1999 and
2004.

Networks and protocols have changed significantly since 2004.

I believe it's time to revisit this topic, and to focus on PATH
characteristics, rather than first-hop link characteristics.

We had a side meeting about this at IETF 104, and there was significant
interest, so we are ready to move forward.

I'll be hosting a side meeting in the IETF Code Lounge at 8:30-9:30AM on
WEDNESDAY (moved from Tuesday to accommodate attendance at Technology Deep
Dive on NICs), to talk about next steps. Any recommendations will come out
of the IETF, but I'm inviting IRTF people to help us separate what's
research, and what's close enough to engineering to be used as the basis
for IETF recommendations.

Thanks - andplease come if you should be there.

Spencer

---

From: Kuhn Nicolas <[email-masked]>
Date: Tue, 23 Jul 2019 20:33:45 +0000

Hi,

I can hardly make it tomorrow morning but I can confirm that IETF104’s session was very interesting.

>>“I believe it's time to revisit this topic, and to focus on PATH characteristics, rather than first-hop link characteristics.”
+1

Moreover, we have slot at PANRG where we present some ‘QUIC 4 SATCOM’ aspects where we focus on the use of in-sequence paths that have (very) different characteristics (typically in sequence use of SATCOM and Wi-Fi or SATCOM for backhauling cellular networks).
Please find here an extract of the introduction of the related document.

   Satellite systems has long been used to support point-to-
   point links and specialised networks.  The predominate current use is
   as a link-layer for Internet Protocols.  Typical example applications
   include: use as an access technology for remote locations, backup and
   rapid deployment of new services, transit networks, and backhaul of
   various types of IP networks, and provision to mobile (maritime,
   aircraft, etc).  The satellite IP network segment usually only forms
   one part of the end-to-end path.  This means user traffic can
   experience a path that includes satellites satellite capacity together
   with a wide variety of other network technologies (Ethernet, cable
   modems, WiFi, cellular, radio links, etc).  Although a user can
   sometimes the presence of the satellite service, a typical user does
   not deploy special software or applications because they expect a
   satellite network is being used.  Often a user is unaware of the
   technologies underpinning the links forming the network path.

Cheers,

Nico

De : Panrg <[email-masked]> De la part de Spencer Dawkins at IETF
Envoyé : mardi 23 juillet 2019 22:22
À : [email-masked]
Objet : [PANRG] IETF/IRTF huddle about Performance Implications of PATH Characteristics (PIPC)

Dear PANRG,

The PILC ("Performance Implications of Link Characteristics") working group produced a number of BCPs providing guidance for protocol designers working with links that were slow, error-prone, and asymmetric, for subnetwork designers, and for Performance Enhancing Proxies (PEPs), between 1999 and 2004.

I believe it's time to revisit this topic, and to focus on PATH characteristics, rather than first-hop link characteristics.

We had a side meeting about this at IETF 104, and there was significant interest, so we are ready to move forward.

I'll be hosting a side meeting in the IETF Code Lounge at 8:30-9:30AM on WEDNESDAY (moved from Tuesday to accommodate attendance at Technology Deep Dive on NICs), to talk about next steps. Any recommendations will come out of the IETF, but I'm inviting IRTF people to help us separate what's research, and what's close enough to engineering to be used as the basis for IETF recommendations.

Spencer