Subject: [paws] FW: Hello folks

From: "Richard Shockey" <[email-masked]>
Date: Mon, 7 Feb 2011 19:07:16 -0500

Really .. just when I was going to suggest ENUM as the query mechanism .. J
J 

From: Parker, Erik [mailto:[email-masked]] 
Sent: Monday, February 07, 2011 2:27 PM
To: Richard Shockey
Subject: Re: [paws] Hello folks

I think your humor may have been lost on some of the list.. :)

--

Erik Parker, CISSP

Senior Wireless Engineer

Amazon.com

On Feb 7, 2011, at 11:18 AM, Richard Shockey wrote:

So HTTPS GET and we're done? J

Richard Shockey
Shockey Consulting
Chairman of the Board of Directors SIP Forum
PSTN Mobile: +1 703.593.2683
<mailto:richard(at)shockey.us>
skype-linkedin-facebook: rshockey101
http//www.sipforum.org

<ATT00001..txt>

---

From: Paul Lambert <[email-masked]>
Date: Mon, 7 Feb 2011 17:27:45 -0800

HTTPS sounded like a serious proposal ...
Why not UDP based?
Paul

Paul A. Lambert |  Marvell  | +1 650 787 9141

--
Erik Parker, CISSP
Senior Wireless Engineer
Amazon.com<http://Amazon.com>

So HTTPS GET and we're done? :)

Richard Shockey
Shockey Consulting

<ATT00001..txt>

---

From: "Parker, Erik" <[email-masked]>
Date: Mon, 7 Feb 2011 17:54:50 -0800

On Feb 7, 2011, at 5:27 PM, Paul Lambert wrote:

HTTPS sounded like a serious proposal …
Why not UDP based?
Paul

Sorry my response was in private reply, unsure why it was forwarded to the list hours later since it provided no valuable information in it.

HTTPS itself could have been serious, but the 'and we're done' part sounded like humor to me.

For corporations utilizing these databases, a TCP based transport method is likely going to be easier to handle from a filtering perspective, but either would certainly work.  It's unclear to me what data is being sent that would actually require cryptography, unless there is a want to have private for-profit databases with their own unique source of information.   Is there a thought that the 9 providers will be licensing this data and access,  so devices will need an authentication mechanism to access it?

The FCCs own searchable (and available in raw tsv) database is out there today which makes it pretty easy to process the actual data of lat/lon, channel utilization.  Not sure about other regions.   It'd be seemingly ideal to have a simple API that can be called, send a lat/lon with a search radius and return results. Though, it's unclear to me if the database should be enforcing things like radius and search area, and it how the hardware will actually ensure it is where it's suppose to be. (ie, like Carrier based pico cells including GPS to ensure they are being used within the proper regions to avoid "free" international calling).   Does it remain an honor system that people input their devices are where they say they are, a technical integration of GPS,  or an auto detection mechanism in the unit that scans and fingerprints channel utilization nearby to narrow down the possible locations its in? (ie, I see data on this 15 frequencies, the only possible area I could be is..  these 10 locations).

It would be nice to have web based APIs available though, as integrators would not have to learn too many different things.   I could certainly see an easy to implement Busybox tool compiled that can speak whatever language so busybox/embedded Linux based systems would have a trivial time implementing the protocol without any custom libraries required beyond being able to speak HTTP..

--
Erik

From: Parker, Erik [mailto:erparker@]
Sent: Monday, February 07, 2011 2:27 PM
To: Richard Shockey
Subject: Re: [paws] Hello folks

So HTTPS GET and we’re done? :)

Richard Shockey
Shockey Consulting

<ATT00001..txt>

<ATT00001..txt>

---

From: Paul Lambert <[email-masked]>
Date: Mon, 7 Feb 2011 18:10:54 -0800

Authentication is required: http://edocket.access.gpo.gov/2010/pdf/2010-30184.pdf

Web technologies (HTTPS/XML) is too often applied as the hammer to fix all problems ... however inappropriately.   This is more akin to DRM for spectrum usage than a new web API for integrators.  Users/integrators will not have access to the "change to any channel" knob.

Paul

From: Parker, Erik [mailto:[email-masked]]
Sent: Monday, February 07, 2011 5:55 PM
To: Paul Lambert
Cc: [email-masked]
Subject: Re: [paws] FW: Hello folks

--
Erik

Richard Shockey
Shockey Consulting

<ATT00001..txt>

<ATT00001..txt>