Subject: RE: [Pce] PCE and ForCES WG difference

From: "Kulkarni, Hrishikesh (Hrishikesh)" <[email-masked]>
Date: Wed, 13 Oct 2004 19:12:41 +0530

Hi Adrian,

Thanks for the clarification.

I have question regarding section 4.5

So the outcome of the path computation done by the PCE needs to communicated

to the forwarding plane (please allow me to assume "forwarding plane " as 
"network element which doesnt have control plane or routing plane").
Does PCE proposes to provide a protocol for this exchange of info?
isnt this protocol which is addressed in GSMP or forces?

rishi

> -----Original Message-----
> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Wednesday, October 13, 2004 4:57 PM
> To: Kulkarni, Hrishikesh (Hrishikesh); [email-masked]
> Subject: Re: [Pce] PCE and ForCES WG difference
> 
> 
> Hi Rishi,
> 
> This is a good question which probably applies equally to 
> ForCES and GSMP.
> 
> If you were to draw a simplistic picture of the ForCES or 
> GSMP model it would show a clear
> separation of the control and data planes. The programming 
> protocol (e.g. NetLink or GSMP)
> operates between the control element and the data element to 
> achieve programming in the
> data plane.
> 
> PCE, on the other hand, is a facilitator for the control 
> plane. Thus the PCC is a control
> element and makes requests of the PCE which is also 
> functionally a control element. There
> is no new interaction with the data plane in this model.
> 
> In fact, PCE could be used in the ForCES model, the GSMP 
> model, or the MPLS/GMPLS model
> where the data and control plane elements are co-resident in an LSR.
> 
> Does this answer your question?
> 
> Thanks,
> Adrian
> 
> ----- Original Message ----- 
> From: "Kulkarni, Hrishikesh (Hrishikesh)" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, October 13, 2004 11:41 AM
> Subject: [Pce] PCE and ForCES WG difference
> 
> 
> > Hi all,
> >
> > I was going through Forwarding and Control Element 
> Separation (ForCES)
> > Framework http://www.ietf.org/rfc/rfc3746.txt
> >
> > which provides a framework to separate the control (routing) and the
> > forwarder functionality.
> >
> > How is this working group goals or architecture suggestions 
> different from
> > the one being
> > suggested by PCE?
> >
> > is one of them a subset of the other?
> >
> > thanks
> > rishi.
> >
> > _______________________________________________
> > Pce mailing list
> > [email-masked]
> > https://www1.ietf.org/mailman/listinfo/pce
> >
> >
> 

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 13 Oct 2004 21:15:17 +0100

Hi again,

> isnt this protocol which is addressed in GSMP or forces?

Two answers:

My understanding is that GSMP and ForCES are intended to supply communication between the
control and forwarding planes. In the case described in section 4.5 there is no control
plane so these mechanisms do not come into play.

As section 4.5 says, it is describing a situation where 'legacy' equipment is currently
controlled by the management plane and "all cross-connections are made from the management
plane." No change to this mode of operation is intended - that is, although PCE may be
used to compute a path, the path is installed through the use of the management plane. You
could, I suppose, regard the PCC in this case as being an element of the management plane.

I think it is helpful that you have raised this point and we will try to clarify that no
change in the mode of operation is intended. And specifically that no matter how PCE is
used, there is no change to how the data plane is programmed.

Thanks,
Adrian