Subject: RE : [Pce] Proposed Charter for a PCE WG

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Thu, 14 Oct 2004 23:40:52 +0200

Hi Adrian and all,

This proposed charter sounds good

Just two points:

 -Could it be possible to explicitely include PCE-based backup path computation within the charter ? Either include it in the first item or in a dedicated item

 -It would be good to explicitely mention GMPLS aspects as part of the charter

Regards,

JL

>-----Message d'origine-----
>De : [email-masked] 
>[mailto:[email-masked]] De la part de Adrian Farrel
>Envoyé : samedi 9 octobre 2004 00:33
>À : [email-masked]
>Objet : [Pce] Proposed Charter for a PCE WG
>
>
>Hi,
>
>The main purposes of the PCE BOF in Washington DC will be to 
>discuss the PCE architecture, and the need for and scope of a 
>PCE WG. Hence the proposed charter is particularly important.
>
>JP and I have put together the following as a starting point, 
>and we would very much appreciate your comments on the mailing 
>list in advance of the meeting. Specific milestones are 
>pending agreement on the major work areas.
>
>Thanks,
>Adrian
>============
>Proposed Charter
>
>WG items:
>- Functional specification of Generalized Traffic Engineered LSP path
>  computation techniques involving Path Computation Element(s). This
>  includes the case of intra IGP area, inter IGP area, inter-AS and
>  inter-provider TE LSPs path computation for both Point to Point,
>  Point to Multipoint and Multipoint to Multipoint TE LSPs.
>- Specification of routing (OSPF, ISIS, BGP) and signaling (RSVP-TE)
>  extensions required by PCE-based path computation techniques.
>  Specification of routing extensions in support of PCE discovery
>  techniques within an IGP area and across multiple IGP areas, ASes
>  and Provider networks. The proposed extensions will done in
>  conjunction with the WGs in charge of the specification of those
>  protocols.
>- Specification of new protocols or modifications to existing
>  protocols to facilitate communication between LSRs and PCEs, and
>  between a PCE and other PCEs.
>- Definition of protocol-independent metrics defining path quality
>  measurement criteria, algorithm complexity and scalability criteria
>  related to path computation techniques.
>- Specification of requirements and protocol extensions related to the
>  policy, security and confidentiality aspects of PCE-based path
>  computation techniques involving PCEs of multiple Providers.
>- Definition of MIBs and management procedures related to the new
>  protocols, protocol extensions and operational elements defined
>  by the WG.
>
>The WG will work closely with the following other WGs: CCAMP, 
>MPLS, ISIS, OSPF; and will also cooperate with the ITU-T and 
>OIF where appropriate.
>
>
>_______________________________________________
>Pce mailing list
>[email-masked]
>https://www1.ietf.org/mailman/listinfo/pce
>

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: JP Vasseur <[email-masked]>
Date: Thu, 14 Oct 2004 18:29:10 -0400

Hi Jean-Louis,

> This proposed charter sounds good

Thanks.

> Just two points:
>
>  -Could it be possible to explicitely include PCE-based backup path 
> computation within the charter ? Either include it in the first item 
> or in a dedicated item
>

Agree, we should list as a specific item since the problems to handled 
may be specific to this problem space.

We will update the proposed charter accordingly.

- Functional specification of Generalized Traffic Engineered LSP path
   computation techniques involving Path Computation Element(s).

so this covers GMPLS, since indeed PCE-based computation is a good 
candidate for Generalized LSP path computation considering the 
complexity of multi-constraints algorithms, a quite common case in 
GMPLS environments.

Thanks for your feed-backs.

JP.

---

From: "Igor Bryskin" <[email-masked]>
Date: Fri, 15 Oct 2004 10:24:16 -0400

Hi,

I don't understand the part about signaling (RSVP-TE) extensions required by PCE-based path computation techniques. I hope this is about things like signaling of constraints during LSP setup and not about PCC-PCE and PCE-PCE signaling.

I would also like to add to the charter the framework and the architecture of the distributed path computation involving multiple PCEs

Igor

  ----- Original Message ----- 
  From: JP Vasseur 
  To: LE ROUX Jean-Louis RD-CORE-LAN 
  Cc: [email-masked] 
  Sent: Thursday, October 14, 2004 6:29 PM
  Subject: Re: RE : [Pce] Proposed Charter for a PCE WG

  Hi Jean-Louis,

    Hi Adrian and all,

  Thanks.

    Just two points:

  Agree, we should list as a specific item since the problems to handled may be specific to this problem space.

  so this covers GMPLS, since indeed PCE-based computation is a good candidate for Generalized LSP path computation considering the complexity of multi-constraints algorithms, a quite common case in GMPLS environments.

  JP.

    Regards,

    JL

      -----Message d'origine-----
      De : [email-masked] 
      [mailto:[email-masked]] De la part de Adrian Farrel
      Envoyé : samedi 9 octobre 2004 00:33
      À : [email-masked]
      Objet : [Pce] Proposed Charter for a PCE WG

      Hi,

      Thanks,
      Adrian
      ============
      Proposed Charter

      WG items:

------------------------------------------------------------------------------