Subject: [Pce] WG feedback required on PCE Capability Discovery

From: "LE ROUX Jean-Louis RD-CORE-LAN" <[email-masked]>
Date: Mon, 18 Apr 2005 11:02:32 +0200

Hi all,

There has been several discussions within the PCE com Design Team and
among PCE discovery requirements co-authors, regarding dynamic discovery
of PCE capabilities. 

Once we agree that there is a need for dynamic PCE capability discovery,
then it appears that there are three options:

Option 1: A single specific PCE discovery mechanism is used to discover
all PCE capabilities (as currently required in the PCE discovery
requirements I-D
http://www.ietf.org/internet-drafts/draft-leroux-pce-discovery-reqs-00.t
xt).

Option 2: All PCE capabilities are discovered through added
functionality in the PCE communication protocol
(http://www.ietf.org/internet-drafts/draft-ash-pce-comm-protocol-gen-req
s-00.txt).

Option 3: Discovery of some generic PCE capabilities (computation
domain, scope...) is done by the PCE discovery mechanism and discovery
of detailed capabilities (e.g. type of constraints supported...) relies
on the PCE communication protocol.

In 1) since PCC knows all PCE capabilities, it is the reponsibility of
the PCC to select the appropriate PCE for a particular path computation.
So, no capability-related request parameters are needed in the
communication protocol, since the PCC alreay knows what is expected from
the PCE.

In 3) PCC knows certain basic capabilities, but for the capabilities
that it is unaware of, it may request specific parameters in the
communication protocol when a path computation request is made to the
PCE. If the PCE is not capable of the requested paramters, then
appropriate failure is reported.

Note that this does not take into account discovery of PCE location,
that can be done either statically or dynamically through functionality
in the PCE discovery mechanism (here the PCE communication protocol
cannot help).  
Note also that PCE capabilities could of course be configured statically
but this is out of the scope of this discussion focused on dynamic
capability discovery.

WG feedback on this topic would be highly desired. 
Please give us your comments and preferences regarding these three
options.

JL

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: Zhang Renhai <[email-masked]>
Date: Mon, 18 Apr 2005 17:33:47 +0800

WG feedback required on PCE Capability DiscoveryHi,
 I go for option 1.
 Because there will be least needless protocol peckets sent by PCCs and replied by PCEs when a PCC asks a computation, most efficient one.

Zhang
  ----- Original Message ----- 
  From: LE ROUX Jean-Louis RD-CORE-LAN 
  To: [email-masked] 
  Sent: Monday, April 18, 2005 5:02 PM
  Subject: [Pce] WG feedback required on PCE Capability Discovery

  Hi all, 

  There has been several discussions within the PCE com Design Team and among PCE discovery requirements co-authors, regarding dynamic discovery of PCE capabilities. 

  Once we agree that there is a need for dynamic PCE capability discovery, then it appears that there are three options: 

  Option 1: A single specific PCE discovery mechanism is used to discover all PCE capabilities (as currently required in the PCE discovery requirements I-D http://www.ietf.org/internet-drafts/draft-leroux-pce-discovery-reqs-00.txt).

  Option 2: All PCE capabilities are discovered through added functionality in the PCE communication protocol (http://www.ietf.org/internet-drafts/draft-ash-pce-comm-protocol-gen-reqs-00.txt).

  Option 3: Discovery of some generic PCE capabilities (computation domain, scope...) is done by the PCE discovery mechanism and discovery of detailed capabilities (e.g. type of constraints supported...) relies on the PCE communication protocol.

  In 1) since PCC knows all PCE capabilities, it is the reponsibility of the PCC to select the appropriate PCE for a particular path computation. So, no capability-related request parameters are needed in the communication protocol, since the PCC alreay knows what is expected from the PCE.

  In 3) PCC knows certain basic capabilities, but for the capabilities that it is unaware of, it may request specific parameters in the communication protocol when a path computation request is made to the PCE. If the PCE is not capable of the requested paramters, then appropriate failure is reported.

  Note that this does not take into account discovery of PCE location, that can be done either statically or dynamically through functionality in the PCE discovery mechanism (here the PCE communication protocol cannot help).  

  Note also that PCE capabilities could of course be configured statically but this is out of the scope of this discussion focused on dynamic capability discovery.

  WG feedback on this topic would be highly desired. 
  Please give us your comments and preferences regarding these three options. 

  JL 

------------------------------------------------------------------------------

---

From: dimitri papadimitriou <[email-masked]>
Date: Wed, 20 Apr 2005 12:50:48 +0200

hi jean-louis,

option (3) makes sense but it also requires to sort out these generic
base capabilities that are expected from a PCE (i.e. the common baseline
to have a working interoperable system)

this would constitute a good balance allowing to avoid high rejection
rate w/o overloading the discovery exchange and increase requirements in
terms of information propagation and processing, i.e., the following
constraint is imho important to take into account [variation rate of
generic PCE cap. >> convergence time]

now, in any case, it will be very difficult to make this exchange
lightweight even when using the so-called PCC-PCE communication protocol
(as the set of supported type of constraints is expected to be exchanged
from i can read from the below); therefore, some abstraction and/or
classification may probably help in avoiding being fully explicit
concerning all these capabilities, and in particular, the computational
constraints.

thanks,
- dimitri.

LE ROUX Jean-Louis RD-CORE-LAN wrote:

> ------------------------------------------------------------------------
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 25 Apr 2005 16:56:12 +0100

Hi JL,

Well, it all depends on how much information, how many PCEs, how many
PCCs, and how often the information is re-distributed.

If you use an IGP to achieve option 1 then you are requiring that all
routers in the network store the PCE capabilities information so that they
can flood it. So we must hope that the product {number of PCEs}x{volume of
capabilities information} is not too large.

If you are talking about a list of bit flags then option 1 is probably
cool. If the information is extensive you probably need  option 3. If you
don't yet know, I suggest you follow option 1 with the knowledge that
option 3 can be added. (Option 3 is not such a burden since it is a
request/response interaction and that is exactly what the PCE-PCC
communications protocol does best.)

Note that the PCE-PCC comms draft currently says that items like Policies
must be advertised as part of the PCE capabilities. These could be
non-trivial and many in number.

To pick you up on one point...

> in the PCE discovery mechanism (here the PCE communication protocol

This is not true. You may wish to distinguish the two functions and keep
them in separate protocols, and this may be a really good idea, but it is
also possible to point at many client/server protocols where the client
discovers the servers as part of the protocol operation.

Cheers,
Adrian

----- Original Message ----- 
From: "LE ROUX Jean-Louis RD-CORE-LAN"
<[email-masked]>
To: <[email-masked]>
Sent: Monday, April 18, 2005 10:02 AM
Subject: [Pce] WG feedback required on PCE Capability Discovery

Hi all,

JL

--------------------------------------------------------------------------
------

---

From: Zhang Renhai <[email-masked]>
Date: Sat, 30 Apr 2005 16:32:13 +0800

WG feedback required on PCE Capability DiscoveryHi, JL

If every PCE know well of the capabilities of other's PCE, before PCE reject
a request because of its computation capabilities , it can get the appropriate one and 
return it to PCC. if so ,at any time ,the PCC need not to know the detailed 
capabilities,knowing only generic PCE capabilities is enough for PCC.
Could this be  another choise?

Thanks.
Zhang

----- Original Message ----- 
From: LE ROUX Jean-Louis RD-CORE-LAN 
To: [email-masked] 
Sent: Monday, April 18, 2005 5:02 PM
Subject: [Pce] WG feedback required on PCE Capability Discovery

Hi all, 

JL 

--------------------------------------------------------------------------------