Subject: [Pce] New I-D:draft-yasukawa-pce-p2mp-app-00.txt

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 28 Feb 2007 01:20:00 -0000

Hi,

We have written an I-D to discuss how PCE might be applicable to P2MP 
MPLS-TE.

This I-D is not necessarily going all the way to RFC (although it could). It 
is mainly designed to stimulate debate about how and if PCE should be used 
to address path computation for P2MP LSPs.

Comments solicited.

Thanks,
Adrian
----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>
Sent: Tuesday, February 27, 2007 8:50 PM
Subject: I-D ACTION:draft-yasukawa-pce-p2mp-app-00.txt

>A New Internet-Draft is available from the on-line Internet-Drafts
> directories.
>
>
> Title : Applicability of the Path Computation Element (PCE) to 
> Point-to-Multipoint (P2MP) Multiprotocol Label Switching (MPLS) and 
> Generalized MPLS (GMPLS) Traffic Engineering (TE)
> Author(s) : S. Yasukawa, A. Farrel
> Filename : draft-yasukawa-pce-p2mp-app-00.txt
> Pages :
> Date : 2007-2-27
>
>   The Path Computation Element (PCE) provides path computation
>   functions in support of traffic engineering in Multi-Protocol Label
>   Switching (MPLS) and Generalized MPLS (GMPLS) networks.
>
>   Extensions to the MPLS and GMPLS signaling and routing protocols have
>   been made in support of point-to-multipoint (P2MP) Traffic Engineered
>   (TE) Label Switched Paths (LSPs).
>
>   This document examines the applicability of PCE to path computation
>   P2MP TE LSPs in MPLS and GMPLS networks. It describes the motivation
>   for using a PCE to compute these paths, and examines which of the
>   PCE architectural models are appropriate.
>
> A URL for this Internet-Draft is:
> http://www.ietf.org/internet-drafts/draft-yasukawa-pce-p2mp-app-00.txt
>

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: "ASH, GERALD R, ATTLABS" <[email-masked]>
Date: Wed, 28 Feb 2007 18:09:22 -0600

Brief comments:

1. It certainly seems worthwhile to include path computation for P2MP
LSPs within PCE capability; is this within the PCE charter scope, or
does it require an extension?
2. Real-time P2MP path computation seems like an especially good
application of PCE (offload large computational tasks needed in real
time).
3. Need to be careful to confine the complexity of P2MP path
computation.  E.g., it isn't obvious that fragmenting the computation of
the P2MP tree, as described in Section 3, does not significantly
increase the complexity of P2MP path computation.
4. Editorial: Section 3 (Manageability Considerations) follows Section 7
(Disjoint Paths).

Overall support/encourage to progress the work.

Thanks,
Jerry

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Tuesday, February 27, 2007 8:20 PM
To: [email-masked]
Subject: [Pce] New I-D:draft-yasukawa-pce-p2mp-app-00.txt 

Hi,

This I-D is not necessarily going all the way to RFC (although it
could). It 
is mainly designed to stimulate debate about how and if PCE should be
used 
to address path computation for P2MP LSPs.

Comments solicited.

Thanks,
Adrian