Subject: RE: [Pce] A New Internet-Draft on Advertising of inter-AS TE links

From: "Greg Mirsky" <[email-masked]>
Date: Thu, 1 Feb 2007 11:58:52 -0800

Dear Zhang,
I have couple questions related to Link ID of inter-AS link. According to the document it is the Router ID of Remote ASBR. My question:
- as I understand the mechanism of how TE information for links R6-R9 and R8-R10 is populated into R5's TE DB is outside the scope of this document. I this mechanism is not IGP but EGP (BGP), then what is the benefit to introduce new LSA in IGP (OSPF) and not use exisitng mechanisms.

	Regards,
		Greg

PS. I think that OSPF WG needs to be informed as well.

-----Original Message-----
From: Zhang Renhai [mailto:[email-masked]]
Sent: Tuesday, January 30, 2007 7:38 PM
To: [email-masked]; [email-masked]
Subject: [Pce] A New Internet-Draft on Advertising of inter-AS TE links

Hi, allWe have just submitted the following draft in which we describe some problemsin inter-AS TE scenarios and the corresponding OSPF extension is introduced.PCE environment is also considerd in this I-d so I'd also like pce working groupto pay attention to it.we'd highly appreciate your comments.Thanks a lot,Zhang Renhai & Mach A New Internet-Draft is available from the on-line Internet-Drafts 
directories.

	Title		: OSPF Extensions in Support of Inter-AS (G)MPLS TE 
	Author(s)	: M. Chen, R. Zhang
	Filename	: draft-chen-ccamp-ospf-interas-te-extension-00.txt
	Pages		: 9
	Date		: 2007-1-30
	
   This document describes extensions to the OSPF to support inter-AS 
   Traffic engineering (TE). It defines OSPF extensions for the flooding 
   of inter-AS links information which can be used to perform inter-AS 
   path computation. 

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-chen-ccamp-ospf-interas-te-extension-00.txt

To remove yourself from the I-D Announcement list, send a message to 
i-d-announce-request at ietf.org with the word unsubscribe in the body of 
the message. 
You can also visit https://www1.ietf.org/mailman/listinfo/I-D-announce 
to change your subscription settings.

Internet-Drafts are also available by anonymous FTP. Login with the 
username "anonymous" and a password of your e-mail address. After 
logging in, type "cd internet-drafts" and then 
"get draft-chen-ccamp-ospf-interas-te-extension-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	mailserv at ietf.org.
In the body type:
	"FILE /internet-drafts/draft-chen-ccamp-ospf-interas-te-extension-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.
<ftp://ftp.ietf.org/internet-drafts/draft-chen-ccamp-ospf-interas-te-extension-00.txt> 
_______________________________________________
I-D-Announce mailing list
I-D-Announce at ietf.org
https://www1.ietf.org/mailman/listinfo/i-d-announce

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

_______________________________________________
Pce mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pce

---

From: Zhang Renhai <[email-masked]>
Date: Fri, 02 Feb 2007 10:35:39 +0800

Hi, Greg

Thanks a lot for your question.
See inline please.

Dear Zhang,
I have couple questions related to Link ID of inter-AS link. According to the document it is the Router ID of Remote ASBR. 
[ZRH]Yes, and this can be easily got by manual configuration in the local ASBR.

My question:

[ZRH]I think BGP could also be another alternative especially for PCE scenario, but it's not very applicable to per-domian method because the inter-AS TE information may be needed throughout the local AS in case that the path computation function is distributed among LSRs in the local AS, and BGP can hardly advertise the TE information among those LSRs if BGP sessions are not established between the ASBR and those LSRs. So IGP extension is considered in this draft.

We have submitted the revised version of this draft, hoping make the problem statement more clear, and relax the use of type 11 opaque lsa, also allow Type 10 lsa (by which the advertising scope is an area of OSPF).
http://www.ietf.org/internet-drafts/draft-chen-ccamp-ospf-interas-te-extension-01.txt

Cheers,
Zhang Renhai

Regards,
Greg

-----Original Message-----
From: Zhang Renhai [mailto:[email-masked]]
Sent: Tuesday, January 30, 2007 7:38 PM
To: [email-masked]; [email-masked]
Subject: [Pce] A New Internet-Draft on Advertising of inter-AS TE links

Send a message to:
mailserv at ietf.org.
In the body type:

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 2 Feb 2007 19:41:19 -0000

Hi all,

>> I have couple questions related to Link ID
>> of inter-AS link. According to the document
>> it is the Router ID of Remote ASBR.

To be precise, the I-D says "TE Router ID". I think the difference is very 
important.

>> - as I understand the mechanism of how TE
>> information for links R6-R9 and R8-R10 is
>> populated into R5's TE DB is outside the
>> scope of this document. I this mechanism
>> is not IGP but EGP (BGP), then what is the
>> benefit to introduce new LSA in IGP (OSPF)
>> and not use exisitng mechanisms.

I think you mean R8-R9 (at least in the latest revision of the I-D).

When you say an "existing mechanism" I don't think there is any mechanism 
for advertising TE information in BGP although there are proposed 
extensions. But there would be two issues:

1. How to stop the information propagating further than AS2 (AS1 does not 
want/need to know about the inter-AS links between AS2 and AS3). I guess we 
could use the new AS_PATHLIMIT stuff.

2. How to get the information into the TED of every LSR in AS2 without them 
all having to be BGP speakers. I think this is why the IGP is more 
appealing. The question arrises (as indicated by Renhai, below) as to 
whether this information only needs to reach PCEs, PCEs and ASBR, or all 
LSRs.

> [ZRH]I think BGP could also be another alternative
> especially for PCE scenario, but it's not very
> applicable to per-domian method because the inter-AS
> TE information may be needed throughout the local AS
> in case that the path computation function is
> distributed among LSRs in the local AS, and BGP can
> hardly advertise the TE information among those LSRs
> if BGP sessions are not established between the ASBR
> and those LSRs. So IGP extension is considered in this
> draft.

[SNIP]

>> PS. I think that OSPF WG needs to be informed as well.

Yes. If CCAMP and/or PCE think that this is something they want to pursue, 
then we will definitely need to discuss this with the OSPF working group. 
But I don't want to waste their time or energy before we have discussed this 
a bit more.

Thanks,
Adrian