Subject: [Pce] PCE computation time

From: Meral Shirazipour <[email-masked]>
Date: Mon, 04 Aug 2008 19:24:31 -0400

Hi,
   Does anyone have actual values for the min/average/max PCE computation times
in a real network?
I remember that the issue was discussed for the monitoring draft.

Thanks,
Meral

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 5 Aug 2008 14:55:41 +0100

Now then, Meral,

I think computation times *might* be dependent on CPU power, loading, 
compiler efficiency, software implementation, algorithm choice, network 
complexity, etc.

Some observations suggest that computation for single LSPs with normal 
constraints can be achieved using CSPF and there are studies recording the 
number of logical steps needed to perform such a computation. In general, 
for this type of computation, we observe that a remote PCEP communication 
takes far more time than the computation. (Times may vary according to the 
pre-existence of the PCEP session.)

Other observations note that some computation problems are quite hard and 
need a few more cycles. In these cases, given the low power of CPUs on NEs, 
the communication time may be less significant.

Cheers,
Adrian

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 05 Aug 2008 12:44:07 -0400

Hi Adrian,
  For the PCE computation time, I was considering all that you mentioned except
the compiler efficiency/software implementation dependencies.

  Also when you say:
> In general,

are we talking "worse case" PCEP communication time in the order of seconds?
minutes? ..?

I am assuming that:
PCE response time = PCEP communication time + PCE computation time

Then the total response time is some sort of a summation of the response times
of all the PCEs in the PCE chain.

Any further comments would be greatly apperciated. I am trying to come up with
"typical/realistic" PCE response times for the single LSP computation case. I
do understand that this time could greatly vary depending on the criterias you
mentioned (CPU power, etc.), but just knowing if in practice it is typically in
the orders of seconds, minutes, hours would be of great help to me.

many thanks,
Meral

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 5 Aug 2008 18:21:01 +0100

I think you might predict PCEP communication time as...

TCP connection setup
PCEP session establishment
PCEP request/response

You might approximate this with a web browser or any other TCP-based 
application.

FWIW I would expect a simple CSPF to be computed in a few hundred ms at 
absolute most (but probably in a less than a few tens of ms) and 
communication time to be of the order of one second tops. YMMV.

Cheers,
Adrian
----- Original Message ----- 
From: "Meral Shirazipour" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, August 05, 2008 5:44 PM
Subject: Re: [Pce] PCE computation time

>> >   Does anyone have actual values for the min/average/max PCE 
>> > computation
>> > times
>> > in a real network?

---

From: "Eric Gray" <[email-masked]>
Date: Tue, 5 Aug 2008 12:32:42 -0500

Adrian,

	You would not take into consideration the potential for
relayed communication times in the distributed PCE case?

--
Eric Gray
Principal Engineer
Ericsson  

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of Adrian Farrel
> Sent: Tuesday, August 05, 2008 1:21 PM
> To: Meral Shirazipour
> Cc: [email-masked]
> >  For the PCE computation time, I was considering all that 
> you mentioned 
> > except
> >> takes far more time than the computation. (Times may vary 
> according to 
> >> the
> > Then the total response time is some sort of a summation of 
> the response 
> > times
> > Any further comments would be greatly apperciated. I am 
> trying to come up 
> > with
> > "typical/realistic" PCE response times for the single LSP 
> computation 
> > case. I
> > do understand that this time could greatly vary depending 
> on the criterias 
> > you
> >> constraints can be achieved using CSPF and there are 
> studies recording 
> >> the
> >> takes far more time than the computation. (Times may vary 
> according to 
> >> the
> >> need a few more cycles. In these cases, given the low 
> power of CPUs on 
> >> NEs,

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 05 Aug 2008 13:47:41 -0400

Thanks alot... that fully answered my concern.

cheers,
Meral

---

From: Meral Shirazipour <[email-masked]>
Date: Tue, 05 Aug 2008 14:03:42 -0400

Hi,
    Please correct me if I am missing something,  I am simply adding the PCE
response times of all the PCEs interrogated along the way.

If the relaying is done in parallel like in :
		 --> PCE31--> PCE32--> PCE33
		/
PCE1---->PCE2 	----> PCE41--> PCE42--> PCE43--> PCE44
		\
		 -->PCE51-> PCE52

assuming in this example that all PCEs have the same response time, then the
total response time will be the longest one, in this case that of :
PCE1---->PCE2 	----> PCE41--> PCE42--> PCE43--> PCE44

= RESPONSE TIMES OF (PCE2 + PCE41+PCE42+ PCE43+ PCE44)

Cheers,
Meral