Subject: Re: [Pce] New Version Notification for draft-zhang-pce-udp-for-pcecp-00

From: Fatai Zhang <[email-masked]>
Date: Fri, 22 Jan 2010 11:23:29 +0800

Hi PCEers,

We just uploaded a draft, which is about PCECP over UDP.

I think it is very interesting to investigate the feasibility and advantages of using UDP as transport protocol for PCECP.

If you are interested in this topic, hope you can have a look and review this draft.

We would like to appreciate your comments or suggestions.

Thanks
 
Fatai
 
Huawei Technologies Co., LTD.
Huawei Base, Bantian, Longgang,
Shenzhen 518129 P.R.China
Tel: +86-755-28972912
Fax: +86-755-28972935

----- Original Message ----- 
From: "IETF I-D Submission Tool" <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
Sent: Thursday, January 21, 2010 2:31 PM
Subject: New Version Notification for draft-zhang-pce-udp-for-pcecp-00

> 
> A new version of I-D, draft-zhang-pce-udp-for-pcecp-00.txt has been successfuly submitted by Fatai Zhang and posted to the IETF repository.
> 
> Filename: draft-zhang-pce-udp-for-pcecp
> Revision: 00
> Title: UDP as Transport Protocol for PCECP
> Creation_date: 2010-01-21
> WG ID: Independent Submission
> Number_of_pages: 17
> 
> Abstract:
> The Path Computation Element Communication Protocol defines a 
> request/response protocol used for the communication between a Path 
> Computation Client (PCC) and a Path Computation Element (PCE), or 
> between two PCEs. PCEP employs Transmission Control Protocol (TCP) as 
> the transport layer protocol by using a registered TCP port. 
> 
> This document proposes the possibility of employing UDP as the 
> transport layer protocol instead of TCP. 
> 
> UDP is a connectionless protocol within TCP/IP protocol suite that 
> corresponds to the transport layer in the ISO/OSI reference model. 
> UDP converts data messages generated by an application into packets 
> to be sent through IP. The reliability is not guaranteed by UDP and 
> should be ensured by the application that generates the data message. 
> 
> The PCECP application is flexible to ensure the reliability of PCECP 
> messages. This document explains on how the reliability of the PCECP 
> messages can be achieved by means of PCECP, while operating PCECP 
> over UDP.
>                                                                                  
> 
> 
> The IETF Secretariat.
> 
> 
>

---

From: JP Vasseur <[email-masked]>
Date: Fri, 22 Jan 2010 11:30:34 +0100

Hi,

On Jan 22, 2010, at 4:23 AM, Fatai Zhang wrote:

> I think it is very interesting to investigate the feasibility and  
> advantages of using UDP as transport protocol for PCECP.
>

Co-chair Hat off.

Do you see an issue with TCP that motivates this ID ?
BAsed on experience, experimentation and deployment, I do not see any  
reason for proposing an alternative to TCP in this context.

Thanks.

JP.

> Cc: <[email-masked]>; <[email-masked]>; <[email-masked] 
> >
> > A new version of I-D, draft-zhang-pce-udp-for-pcecp-00.txt has  
> been successfuly submitted by Fatai Zhang and posted to the IETF  
> repository.
> >
> > <draft-zhang-pce-udp-for- 
> pcecp-00.txt>_______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: Fatai Zhang <[email-masked]>
Date: Mon, 25 Jan 2010 09:23:50 +0800

Hi JP,

We have already given the advantages of using UDP rather than TCP in section 3.2 and 3.1 of our draft.

You know if PCE is deployed in the network element, it is usually desirable to use a kind of light transpoft protocol for PCECP(e.g., UDP) to reduce the burden of memory and CPU. In addition, if we use UDP, it does not need to create session before sending path computation request, so it can get the required route more quickly, especially, it is very important in the case of recovery.

We also have clearly explained other advantages like parsing effectiveness, retransmission control, overall simplicity of UDP compared to TCP etc.,

Thanks
 
Fatai

  ----- Original Message ----- 
  From: JP Vasseur 
  To: Fatai Zhang ; Jun Sun 
  Cc: [email-masked] 
  Sent: Friday, January 22, 2010 6:30 PM
  Subject: Re: [Pce] New Version Notification for draft-zhang-pce-udp-for-pcecp-00

  Hi,

    Hi PCEers,

  Co-chair Hat off.

  Do you see an issue with TCP that motivates this ID ?
  BAsed on experience, experimentation and deployment, I do not see any reason for proposing an alternative to TCP in this context.

  Thanks.

  JP.

    Thanks
     
    Fatai

     
    ----- Original Message -----
    From: "IETF I-D Submission Tool" <[email-masked]>
    To: <[email-masked]>
    Cc: <[email-masked]>; <[email-masked]>; <[email-masked]>
    Sent: Thursday, January 21, 2010 2:31 PM
    Subject: New Version Notification for draft-zhang-pce-udp-for-pcecp-00

    > <draft-zhang-pce-udp-for-pcecp-00.txt>_______________________________________________
    Pce mailing list
    [email-masked]

---

From: JP Vasseur <[email-masked]>
Date: Mon, 25 Jan 2010 14:19:03 +0100

Hi Fatai,

On Jan 25, 2010, at 2:23 AM, Fatai Zhang wrote:

> You know if PCE is deployed in the network element, it is usually  
> desirable to use a kind of light transpoft protocol for PCECP(e.g.,  
> UDP) to reduce the burden of memory and CPU. In addition, if we use  
> UDP, it does not need to create session before sending path  
> computation request, so it can get the required route more quickly,  
> especially, it is very important in the case of recovery.
>
> We also have clearly explained other advantages like parsing  
> effectiveness, retransmission control, overall simplicity of UDP  
> compared to TCP etc.,

Thanks for your reply. Just to clarify (with co-chair hat off), as you  
know, there are a number of implementations of PCEP, and I haven't  
heard any issue related to the use of TCP here. Current stacks can  
very easily handle a large number of TCP sessions (if at all needed in  
these environments) and although one can always propose changes and  
use other transport (e..g UDP but we also had discussion about the use  
of SCTP for other reason) I must say that I do not see any reasons for  
doing so.

Others on the list will comments of course.

Again this is a "co-chair hat off" comment.

Thanks.

JP.

> BAsed on experience, experimentation and deployment, I do not see  
> any reason for proposing an alternative to TCP in this context.
>
> Thanks.
>
> JP.
>
>>
>>
>>
>>
>> Thanks
>>
>> Fatai
>>