Subject: [Pce] New I-D : draft-wang-pce-inter-as-extentions-00.txt

From: [email-masked]
Date: Mon, 14 Mar 2011 09:45:16 +0800

Dear all, 

We have uploaded a draft, which is about  extensions of Backward-Recursive 
PCE-Based Computation (BRPC) to support bidirectional  inter-AS LSP path 
computation.
 
I think it is important  to get bidirectional Inter-AS TE link information 
for inter-AS  path  computation.
 
If you are interested in this topic, hope you can have a look and review 
this draft.
URL : http://www.ietf.org/id/draft-wang-pce-inter-as-extentions-00.txt
 
We would like to appreciate your comments and suggestions.
 
Thanks
 Xuerong

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: JP Vasseur <[email-masked]>
Date: Mon, 28 Mar 2011 10:47:48 +0200

Dear Authors,

Thanks for your document. Quick question: when relaying the PCReq, why not simply
check the TED in the reverse direction and stop relying if constraints are not satisfied ?

Thanks.

JP.

On Mar 14, 2011, at 2:45 AM, [email-masked] wrote:

> 
> Dear all,  
> We have uploaded a draft, which is about  extensions of Backward-Recursive PCE-Based Computation (BRPC) to support bidirectional  inter-AS LSP path  computation. 
>   
> I think it is important  to get bidirectional Inter-AS TE link information for inter-AS  path  computation. 
>   
> If you are interested in this topic, hope you can have a look and review this draft. 
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: [email-masked]
Date: Tue, 29 Mar 2011 03:05:01 +0800

Dear JP,

Thanks for your good question, and we'll consider this in the next 
version.

For the scenarios that there are serveral Inter-AS links between two ASes, 

if all of them do not satisfy the constraints, PCE will return PCRep with
NOTH-PATH object, and the PCReq will not be relayed. 

However, when not all of the inter-AS links satisfy the constraints, we 
just
select the ones that satisfy the constraints in the both direction, and 
return
these links within PCRep. 

Thanks
Xuerong

JP Vasseur <[email-masked]> 写于 2011-03-28 16:47:48:

> We have uploaded a draft, which is about  extensions of Backward-
> Recursive PCE-Based Computation (BRPC) to support bidirectional 
> inter-AS LSP path  computation. 
> 
> I think it is important  to get bidirectional Inter-AS TE link 
> information for inter-AS  path  computation. 
> 

> ZTE Information Security Notice: The information contained in this 
> mail is solely property of the sender's organization. This mail 
> communication is confidential. Recipients named above are obligated 
> to maintain secrecy and are not permitted to disclose the contents 
> of this communication to others.
> This email and any files transmitted with it are confidential and 
> intended solely for the use of the individual or entity to whom they
> are addressed. If you have received this email in error please 
> notify the originator of the message. Any views expressed in this 
> message are those of the individual sender.

---

From: [email-masked]
Date: Mon, 28 Mar 2011 22:33:37 +0800

Dear JP,
There maybe several inter-AS links between two adjacent ASes, so we just 
selected some of them that can satisfy the constraints in both of the 
directions. Of cause, if all of the inter-as links can not satisfy the 
constraints, PCE will stop relying as you say,and will reply an PCRep
   message including a NO-PATH object.
 
Thanks for your questions
Xuerong

JP Vasseur <[email-masked]> 
2011-03-28 16:47

收件人
[email-masked]
抄送
[email-masked]
主题
Re: [Pce] New I-D : draft-wang-pce-inter-as-extentions-00.txt

Dear Authors,

Thanks for your document. Quick question: when relaying the PCReq, why not 
simply
check the TED in the reverse direction and stop relying if constraints are 
not satisfied ?

Thanks.

JP.

Dear all,  

  
 
Thanks
 Xuerong

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is 
solely property of the sender's organization. This mail communication is 
confidential. Recipients named above are obligated to maintain secrecy and 
are not permitted to disclose the contents of this communication to 
others.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the originator of 
the message. Any views expressed in this message are those of the 
individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.

---

From: JP Vasseur <[email-masked]>
Date: Tue, 29 Mar 2011 07:40:11 +0200

Hi,

On Mar 28, 2011, at 4:33 PM, <[email-masked]> <[email-masked]> wrote:

> 
> Dear JP, 
> There maybe several inter-AS links between two adjacent ASes, so we just selected some of them that can satisfy the constraints in both of the directions. Of cause, if all of the inter-as links can not satisfy the constraints, PCE will stop relying as you say,and will reply an PCRep
> 

Thanks for your reply - this s understood but precisely my point: why would you need
protocol extensions ?

thanks.

JP.

---

From: [email-masked]
Date: Tue, 29 Mar 2011 15:25:25 +0800

Hi,
We need to extend PCEP as well as BRPC.

With extending PCEP to distinguish and being compatible with the BRPC 
procedure defined in RFC5441, we introduce a new flag to indicate that the 
Inter-AS links which satisfy the congstraints must be carried in PCRep.
We may carry the inter-as links in two ways,use ERO or define a new 
object(i.e. CRO in the draft).

There may be less extensions by using ERO to carry the inter-AS links, but 
this method will also carry some repeated information. 

For example, there are more than one inter-AS links from R9 to AS2, and we 
assume that 
all the inter-AS links satisfy the constraints.
VSPT computed by PCE3  is extended to include Inter-AS link from AS3 to 
AS2, some duplicated information as shown follwing:

If we define a new object,that will be more efficent:

Besides of that,BRPC procedure will be extended to include follwing steps 
in red colour:

Best Regards,

Xuerong Wang

2011-03-29 13:40

收件人
"<[email-masked]>" <[email-masked]>
抄送
<[email-masked]>
主题
Re: [Pce] 答复: Re:  New I-D : draft-wang-pce-inter-as-extentions-00.txt

Hi,

On Mar 28, 2011, at 4:33 PM, <[email-masked]> <
[email-masked]> wrote:

Dear JP, 

Thanks for your reply - this s understood but precisely my point: why 
would you need
protocol extensions ?

thanks.

JP.

Xuerong 

收件人
[email-masked] 
抄送
[email-masked] 
主题

Dear Authors, 

Thanks. 

JP. 

Dear all,  

 

Thanks
Xuerong

---

From: JP Vasseur <[email-masked]>
Date: Tue, 29 Mar 2011 09:54:00 +0200

I have a different read, but let's discuss ... and listen what the WG thinks.

On Mar 29, 2011, at 9:25 AM, [email-masked] wrote:

> With extending PCEP to distinguish and being compatible with the BRPC procedure defined in RFC5441, we introduce a new flag to indicate that the Inter-AS links which satisfy the congstraints must be carried in PCRep. 
> We may carry the inter-as links in two ways,use ERO or define a new object(i.e. CRO in the draft). 
> 
> There may be less extensions by using ERO to carry the inter-AS links, but this method will also carry some repeated information. 
> 
> <Mail Attachment.gif> 
> For example, there are more than one inter-AS links from R9 to AS2, and we assume that 
> VSPT computed by PCE3  is extended to include Inter-AS link from AS3 to AS2, some duplicated information as shown follwing:
>   
> <Mail Attachment.gif> 
> <Mail Attachment.gif> 
> Besides of that,BRPC procedure will be extended to include follwing steps in red colour: 
> <Mail Attachment.gif> 
> 
> <Mail Attachment.gif> 
> 
> 
> Best Regards, 
> 
> Xuerong Wang 
> 
> 
> 
> 
> 
>