Subject: [Pce] Compute ingress and egress backup LSP

From: JP Vasseur <[email-masked]>
Date: Tue, 29 Mar 2011 07:38:30 +0200

Thanks for your drafts. When proposing these solutions to the WG, you may want to
specify how the head-end router of the backup LSP gets the labels for the backup 
LSPs ?

Thanks.

JP.

---

From: "Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>
Date: Tue, 29 Mar 2011 18:04:00 +0200

Hi, 

I have an additional question 

According to the document introduction the goal is  to use the PCE to
compute a backup ingress or egress node/detour path in case of P2MP and
P2P TE-LSP.

I would like to understand what is missing in doing the following
requests, using the topology shown in the PCEP IETF80 presentation
(http://tools.ietf.org/wg/pce/agenda?item=agenda80.html,
http://tools.ietf.org/agenda/80/slides/pce-7.ppt) , slide number 7
 
Request #1 :
o PCReq : 
  - END-POINTS : CE3, leaf : CE1, CE2
o PCRep :  
  - ERO : PE5....PE1,CE1 
  - SERO : n..PE3,CE2
Request #2 (backup ingress) : 
O PCReq :
  - END-POINTS : CE4, leaf : CE1,CE2
  - XRO : {F bit set, exclude : PE5) 
  - RRO : PE5....PE1, CE1
  - SRRO : n..PE3,CE2
O PCRep : 
  - ERO : PE6....PE1,CE1 
  - SERO : n..PE3,CE2
Request #3 (backup egress) : 
O PCReq :
  - END-POINTS : CE3, leaf : CE1,CE2
  - XRO : {F bit set, exclude : PE1, PE4) 
  - RRO : PE5....PE1, CE1
  - SRRO : n..PE3,CE2
O PCRep : 
  - ERO : PE6....PE2,CE1 
  - SERO : n..PE4,CE2

The information provided in the response allow the PCC to identify the
backup nodes/detour routes, can you indicate which information is
missing?

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> ext JP Vasseur
> Sent: Tuesday, March 29, 2011 7:39 AM
> To: [email-masked]
> Subject: [Pce] Compute ingress and egress backup LSP
> 
> Thanks for your drafts. When proposing these solutions to the WG, you
> may want to specify how the head-end router of the backup LSP gets the
> labels for the backup LSPs ?
> 
> Thanks.
> 
> JP.
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: Huaimo Chen <[email-masked]>
Date: Wed, 30 Mar 2011 20:57:57 +0000

Hi Cyril,

    Thanks for your email!
    My answer is inline below.

Best Regards,
Huaimo
-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Margaria, Cyril (NSN - DE/Munich)
Sent: Tuesday, March 29, 2011 11:04 AM
To: [email-masked]
Subject: Re: [Pce] Compute ingress and egress backup LSP

Hi, 

 
Request #1 :
o PCReq : 
  - END-POINTS : CE3, leaf : CE1, CE2
o PCRep :  
  - ERO : PE5....PE1,CE1 
  - SERO : n..PE3,CE2
Huaimo: This request should be for computing a P2MP TE LSP path from PE5 (Ingress) to PE1 (Egress) and PE3 (Egress).It seems that your request is for the P2MP path from CE3 (Ingress) to CE1 (Egress/Leaf) and CE2 (Egress/Leaf).

Request #2 (backup ingress) : 
O PCReq :
  - END-POINTS : CE4, leaf : CE1,CE2
  - XRO : {F bit set, exclude : PE5) 
  - RRO : PE5....PE1, CE1
  - SRRO : n..PE3,CE2
O PCRep : 
  - ERO : PE6....PE1,CE1 
  - SERO : n..PE3,CE2
Huaimo: This request should be for computing a backup ingress of the P2MP TE LSP in red color, which is from PE5 to PE1 and PE3. The reply for the request may just contain the backup ingress such as PE6 and backup path from the backup ingress such as PE6 to the next hop node of the ingress PE5. The request should indicate that the backup ingress computed must be able to get the same data that the ingress such as PE5 receives and imports into the P2MP TE LSP from a node (external source node), which may not be in the same domain as the ingress. 
It seems that your request does not have this information.

Request #3 (backup egress) : 
O PCReq :
  - END-POINTS : CE3, leaf : CE1,CE2
  - XRO : {F bit set, exclude : PE1, PE4) 
  - RRO : PE5....PE1, CE1
  - SRRO : n..PE3,CE2
O PCRep : 
  - ERO : PE6....PE2,CE1 
  - SERO : n..PE4,CE2
Huaimo: This request should be for computing a given set of backup egress nodes of the P2MP TE LSP. For example, we may request PCE to compute a backup egress for PE1 and a backup egress for PE3 in one request. In this case, we need to indicate that the backup egress for egress PE1 must have a connection to CE1, to which the data coming out from the egress PE1 of the P2MP TE LSP is sent; and the backup egress for egress PE3 must have a connection to CE3, to which the data coming out from egress PE3 of the P2MP TE LSP is sent.
It seems that your request does not have this information.

---

From: "Margaria, Cyril (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 31 Mar 2011 11:08:58 +0200

Hi, 
Thanks for your answer, I was not detailed enough, please see inline 

<cut> 
>   - END-POINTS : CE3, leaf : CE1, CE2
    - IRO : PE5, link CE3-PE5, PE1, Link PE1-CE1, PE3, Link PE3-CE3
   
> o PCRep :
>   - ERO : PE5....PE1,CE1
>   - SERO : n..PE3,CE2
> Huaimo: This request should be for computing a P2MP TE LSP path from
> PE5 (Ingress) to PE1 (Egress) and PE3 (Egress).It seems that your
> request is for the P2MP path from CE3 (Ingress) to CE1 (Egress/Leaf)
> and CE2 (Egress/Leaf).
> 
This is correct, I do request the path from the CE node, 
the term ingress/egress can be misleading, it is not required that the
endpoint of the path are the LSP ingress/egress

this is the PCC which decide to create an LSP from PE. 
I missed one important point here : the PE5, as LSP endpoint and likely
PCC,
want the path to go though him, hence the IRO (added to the message)

>   - XRO : {F bit set, exclude : PE5)
    - IRO : PE1, Link PE1-CE1, PE3, Link PE3-CE3

>   - SRRO : n..PE3,CE2
> O PCRep :
>   - ERO : PE6....PE1,CE1
>   - SERO : n..PE3,CE2
> Huaimo: This request should be for computing a backup ingress of the
> P2MP TE LSP in red color, which is from PE5 to PE1 and PE3.

Same here, the request is NOT matching the signaling path, this is
intentional
and do *not* mean that the LSP is required to have a 1:1 mapping between
PCReq
 endpoints and LSP ingress/egress.

> The reply
> for the request may just contain the backup ingress such as PE6 and
> backup path from the backup ingress such as PE6 to the next hop node
of
> the ingress PE5. The request should indicate that the backup ingress
> computed must be able to get the same data that the ingress such as
PE5
> receives and imports into the P2MP TE LSP from a node (external source
> node), which may not be in the same domain as the ingress.

This is correct, I forgot the IRO, its working with the IRO.

>   - XRO : {F bit set, exclude : PE1, PE4)

    - IRO : PE5, link CE3-PE5,

>   - RRO : PE5....PE1, CE1
>   - SRRO : n..PE3,CE2
> O PCRep :
>   - ERO : PE6....PE2,CE1
>   - SERO : n..PE4,CE2
> Huaimo: This request should be for computing a given set of backup
> egress nodes of the P2MP TE LSP. For example, we may request PCE to
> compute a backup egress for PE1 and a backup egress for PE3 in one
> request. In this case, we need to indicate that the backup egress for
> egress PE1 must have a connection to CE1, to which the data coming out
> from the egress PE1 of the P2MP TE LSP is sent; and the backup egress
> for egress PE3 must have a connection to CE3, to which the data coming
> out from egress PE3 of the P2MP TE LSP is sent.

This is also correct, the IRO is missing, this is a key point to force
the request to use the LSP ingress/egress.

Does it fit with the corrected request (IRO) and responses?

Best Regards