Subject: [Pce] Comments on draft-chen-pce-forward-search-p2p-path-computation-00.txt

From: JP Vasseur <[email-masked]>
Date: Mon, 28 Mar 2011 10:35:44 +0200

Few comments:
1) What makes you think that you cannot enforce the set of domains that you want to explore with BRPC 
using the IRO object specified in RFC5441?
2) If you have a mesh of domains and you try to compute the shortest inter-domain LSP according to some
metric, you just cannot afford not to explore all of them (unless you make use of some super-TED comprising 
resources information on all domains). This is true whether you use of forward or backward path computation ?

I am trying to understand your claim about why forward computation would solve these problems ?

Thanks.

JP.

---

From: JP Vasseur <[email-masked]>
Date: Mon, 28 Mar 2011 22:38:07 +0200

Hi,

On Mar 28, 2011, at 10:32 PM, Huaimo Chen wrote:

> Hi JP,
> 
>    Thanks for your comments!
>    My answers are inline below.
> 
> Best Regards,
> Huaimo
> -----Original Message-----
> From: JP Vasseur [mailto:[email-masked]] 
> Sent: Monday, March 28, 2011 3:36 AM
> To: Huaimo Chen
> Cc: [email-masked]
> Subject: Comments on draft-chen-pce-forward-search-p2p-path-computation-00.txt
> 
> Few comments:
> Huaimo: This seems that there are some misunderstandings. I did not say that we could not enforce the sequence of domains or the set of domains that we want BRPC to explore using the IRO object. What I say is that the sequence of domains needs to be provided to BRPC in advance. 
> 

Not quite either, you could rely on BGP and furthermore this is orthogonal to the backward or
forward path computation aspect

> Huaimo: My understanding is that BRPC will explore all the possible sequence of domains, compute the shortest path for each sequence of domains and select the shortest one.

Not really, you could restrict the search or explore all of them.

> The forward search method works differently. It searches the shortest path in the way same as the normal CSPF does. It searches the special topology once and gets the shortest path. It will not explore all the possible sequence of domains.
> 
> Huaimo: In the sense of that the forward search computation does not need any sequence of domains in advance, it guarantees that the path found is shortest, and it is efficient even for a topology of meshed domains.

But if you want to find the shortest constrained path and we have a mesh of domains, you still need to explore them all.

Thanks.

JP.

---

From: Huaimo Chen <[email-masked]>
Date: Mon, 28 Mar 2011 20:32:57 +0000

Hi JP,

Best Regards,
Huaimo
-----Original Message-----
From: JP Vasseur [mailto:[email-masked]] 
Sent: Monday, March 28, 2011 3:36 AM
To: Huaimo Chen
Cc: [email-masked]
Subject: Comments on draft-chen-pce-forward-search-p2p-path-computation-00.txt

Few comments:

Huaimo: My understanding is that BRPC will explore all the possible sequence of domains, compute the shortest path for each sequence of domains and select the shortest one. The forward search method works differently. It searches the shortest path in the way same as the normal CSPF does. It searches the special topology once and gets the shortest path. It will not explore all the possible sequence of domains.

Thanks.

JP.

---

From: Huaimo Chen <[email-masked]>
Date: Wed, 30 Mar 2011 21:45:44 +0000

Hi JP,

    Thanks for your comments.
    My answers are inline below.

Best Regards,
Huaimo 

> Sent: Monday, March 28, 2011 3:38 PM
> To: Huaimo Chen
> Cc: [email-masked]
> Subject: Re: Comments on 
> draft-chen-pce-forward-search-p2p-path-computation-00.txt
> 
> Hi,
> 
> > Subject: Comments on 
> > draft-chen-pce-forward-search-p2p-path-computation-00.txt
> > 
> > Few comments:
> > 1) What makes you think that you cannot enforce the set of domains 
> > that you want to explore with BRPC using the IRO object 
> specified in RFC5441?
> > 
> > Huaimo: This seems that there are some misunderstandings. I 
> did not say that we could not enforce the sequence of domains 
> or the set of domains that we want BRPC to explore using the 
> IRO object. What I say is that the sequence of domains needs 
> to be provided to BRPC in advance. 
> > 
> 
> Not quite either, you could rely on BGP and furthermore this 
> is orthogonal to the backward or forward path computation aspect
> 
We can not rely on BGP. BGP does not have any TE information. 
Forward Search path computation and BRPC is not symetric in many aspects. For example, the former does not need any domain sequence, but the latter needs a sequence of domains.  The former guarantees that the path found from a source to a distination is shortest, but the latter may not (if the sequence of domains given to BRPC does not contain the shortest path from the source to the destination, then BRPC can not find the shortest path).

> > 2) If you have a mesh of domains and you try to compute the 
> shortest 
> > inter-domain LSP according to some metric, you just cannot 
> afford not 
> > to explore all of them (unless you make use of some 
> super-TED comprising resources information on all domains). 
> This is true whether you use of forward or backward path computation ?
> > 
> > Huaimo: My understanding is that BRPC will explore all the 
> possible sequence of domains, compute the shortest path for 
> each sequence of domains and select the shortest one.
> 

How do you restrict the search? 

> 
> > The forward search method works differently. It searches 
> the shortest path in the way same as the normal CSPF does. It 
> searches the special topology once and gets the shortest 
> path. It will not explore all the possible sequence of domains.
> > 
> > Huaimo: In the sense of that the forward search computation 
> does not need any sequence of domains in advance, it 
> guarantees that the path found is shortest, and it is 
> efficient even for a topology of meshed domains.
> 
> But if you want to find the shortest constrained path and we 
> have a mesh of domains, you still need to explore them all.

Not really.