Subject: [Pce] I-D Action: draft-ietf-pce-rfc7150bis-00.txt

From: [email-masked]
Date: Tue, 22 Jul 2014 06:41:30 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Path Computation Element Working Group of the IETF.

        Title           : Conveying Vendor-Specific Constraints in the Path Computation Element communication Protocol
        Authors         : Fatai Zhang
                          Adrian Farrel
	Filename        : draft-ietf-pce-rfc7150bis-00.txt
	Pages           : 12
	Date            : 2014-07-22

Abstract:
   The Path Computation Element communication Protocol (PCEP) is used to
   convey path computation requests and responses both between Path
   Computation Clients (PCCs) and Path Computation Elements (PCEs) and
   between cooperating PCEs.  In PCEP, the path computation requests
   carry details of the constraints and objective functions that the PCC
   wishes the PCE to apply in its computation.

   This document defines a facility to carry vendor-specific information
   in PCEP using a dedicated object and a new Type-Length-Variable that
   can be carried in any existing PCEP object.

   This document obsoletes RFC 7150.  The only change from that document
   is the allocation of a different code point for the
   VENDOR-INFORMATION object.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pce-rfc7150bis/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-pce-rfc7150bis-00

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 30 Jul 2014 09:53:49 +0000

Hi Authors, WG,

As we are in midst of a bis for 7150, I wanted to bring this to the notice of the WG. 
There was a offline discussion about the use of VENDOR-INFORMATION-TLV in the LSP object defined in stateful PCE draft. 

In Abstract it says..

                     ^^^^^^^^^^^^    

In Introduction it says..

   This document also defines a new PCEP TLV, the VENDOR-INFORMATION-TLV
   that can be used to carry arbitrary information within any PCEP
   object that supports TLVs.                             ^^^     
                             
Surely the intention was to allow the use of VENDOR-INFORMATION-TLV in *any* PCEP object (existing or defined in future) that allow optional TLVs. 
We hope this can be clarified / made explicit in the bis to avoid any confusion. 

Regards,
Dhruv 

> -----Original Message-----
> From: Pce [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: 22 July 2014 19:12
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Pce] I-D Action: draft-ietf-pce-rfc7150bis-00.txt
> 
> 
>         Title           : Conveying Vendor-Specific Constraints in the Path
> Computation Element communication Protocol
>         Authors         : Fatai Zhang
>                           Adrian Farrel
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: Julien Meuric <[email-masked]>
Date: Wed, 30 Jul 2014 12:26:53 +0200

Hi Dhruv.

I would say that, if the intend was to allow the specified TLV in 
objects where optional TLVs do not exist, it would not be phrased like 
this. All the same, it makes no harm to add explicitly "allowing 
optional TLVs" in the I-D.

By the way, your quotes allows us to catch a weird expansion of "TLV": 
"V" stands for "Value", not "Variable"...

Thanks,

Julien

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 30 Jul 2014 10:46:41 +0000

Hi Julien, 

> 
> Hi Dhruv.
> 
> I would say that, if the intend was to allow the specified TLV in objects
> where optional TLVs do not exist, it would not be phrased like this. All the
> same, it makes no harm to add explicitly "allowing optional TLVs" in the I-D.

Here is my suggested wording -  

Abstract - 
OLD: 
   This document defines a facility to carry vendor-specific information
   in PCEP using a dedicated object and a new Type-Length-Variable that
   can be carried in any existing PCEP object.
NEW:
   This document defines a facility to carry vendor-specific information
   in PCEP using a dedicated object and a new Type-Length-Value (TLV) that
   can be carried in a PCEP object that supports TLVs.

Introduction - 
OLD: 
   This document also defines a new PCEP TLV, the VENDOR-INFORMATION-TLV
   that can be used to carry arbitrary information within any PCEP
   object that supports TLVs.
NEW:
   This document also defines a new PCEP TLV, the VENDOR-INFORMATION-TLV
   that can be used to carry arbitrary information within any existing or 
   future defined PCEP object that supports TLVs.

> "V" stands for "Value", not "Variable"...

Oh yes! Good catch! Updated above..

Regards,
Dhruv

> > There was a offline discussion about the use of VENDOR-INFORMATION-TLV in
> the LSP object defined in stateful PCE draft.
> >
> > In Abstract it says..
> >
> > Surely the intention was to allow the use of VENDOR-INFORMATION-TLV in
> *any* PCEP object (existing or defined in future) that allow optional TLVs.
> >> Please note that it may take a couple of minutes from the time of
> >> submission until the htmlized version and diff are available at
> tools.ietf.org.
> >>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 30 Jul 2014 14:14:56 +0100

This looks good to me.

Thanks,
Adrian

> From: Dhruv Dhody [mailto:[email-masked]]
> Sent: 30 July 2014 11:47
> To: Julien Meuric; [email-masked]; 'Adrian Farrel' ([email-masked]); Fatai
> Zhang
> Cc: Siva Sivabalan (msiva)
> Subject: RE: [Pce] I-D Action: draft-ietf-pce-rfc7150bis-00.txt
> 
> Hi Julien,
> 
> >
> > Hi Dhruv.
> >

---

From: Cyril Margaria <[email-masked]>
Date: Wed, 30 Jul 2014 09:32:26 -0400

Hi,

I think Dhruv addition is good.
Should be added to the document.

On 30 July 2014 06:46, Dhruv Dhody <[email-masked]> wrote:

> > > As we are in midst of a bis for 7150, I wanted to bring this to the
> notice
> > of the WG.
> > >>          Title           : Conveying Vendor-Specific Constraints in
> the
> > Path