Subject: [Pce] I-D Action: draft-ietf-pce-pcep-service-aware-05.txt

From: [email-masked]
Date: Sun, 10 Aug 2014 20:53:18 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Path Computation Element Working Group of the IETF.

        Title           : Extensions to the Path Computation Element Communication Protocol (PCEP) to compute service aware Label Switched Path (LSP).
        Authors         : Dhruv Dhody
                          Vishwas Manral
                          Zafar Ali
                          George Swallow
                          Kenji Kumaki
	Filename        : draft-ietf-pce-pcep-service-aware-05.txt
	Pages           : 19
	Date            : 2014-08-10

Abstract:
   In certain networks like financial information network (stock/
   commodity trading) and enterprises using cloud based applications,
   Latency (delay), Latency-Variation (jitter) and Packet Loss is
   becoming a key requirement for path computation along with other
   constraints and metrics.  Latency, Latency-Variation and Packet Loss
   is associated with the Service Level Agreement (SLA) between
   customers and service providers.

   IGP Traffic Engineering (TE) Metric extensions describes mechanisms
   with which network performance information is distributed via OSPF
   and IS-IS respectively.  The Path Computation Element Communication
   Protocol (PCEP) provides mechanisms for Path Computation Elements
   (PCEs) to perform path computations in response to Path Computation
   Clients (PCCs) requests.  This document describes the extension to
   PCEP to carry Latency, Latency-Variation and Packet Loss as
   constraints for end to end path computation.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pce-pcep-service-aware/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-pce-pcep-service-aware-05

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-pce-pcep-service-aware-05

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 11 Aug 2014 04:05:30 +0000

Hi All, 

With this update in the I.D., we have - 

~ Removed any code points from the I.D. TBA by IANA and corresponding update in the IANA section.
~ Objective Function: Adding a new objective function to minimize packet loss called MPLP (Minimum Packet Loss Path). 

  As this is the only technical change, I am listing it right here for a quick look:

   o  A network comprises a set of N links {Li, (i=1...N)}.

   o  A path P is a list of K links {Lpi,(i=1...K)}.

   o  Packet loss of link L is denoted PL(L) in percentage.

   o  Packet loss in fraction of link L is denoted FPL(L) = PL(L) / 100.

   o  The Packet loss of a path P (in percentage) is denoted PL(P),
      where PL(P) = (1 - ((1-FPL(Lp1)) * (1-FPL(Lp2)) * .. *
      (1-FPL(LpK))) * 100.

   Objective Function Code: (TBA - IANA)

   Name: Minimum Packet Loss Path (MPLP)

   Description: Find a path P such that PL(P) is minimized.

~ Editorial Changes: Removing reference from abstract; changing reference names; etc

Diff: http://www.ietf.org/rfcdiff?url2=draft-ietf-pce-pcep-service-aware-05

We currently have no open issues in the draft.
On behalf of the co-authors and contributors, we request WG to look at the document and provide us with any comments/suggestion to help progress the draft.

Regards,
Dhruv  

> -----Original Message-----
> From: Pce [mailto:[email-masked]] On Behalf Of [email-masked]
> Sent: 11 August 2014 09:23
> To: [email-masked]
> Cc: [email-masked]
> Subject: [Pce] I-D Action: draft-ietf-pce-pcep-service-aware-05.txt
> 
> 
>         Title           : Extensions to the Path Computation Element
> Communication Protocol (PCEP) to compute service aware Label Switched Path
> (LSP).
>         Authors         : Dhruv Dhody
>                           Vishwas Manral
>                           Zafar Ali
>                           George Swallow
>                           Kenji Kumaki
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce