Subject: [Pce] Preaching about code points in drafts

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 18 Sep 2014 03:43:12 +0100

PCE working group,

draft-ietf-pce-rfc7150bis is fixing a clash between an IANA allocation for RFC
7150 and an unallocated code point documented in a working group Internet-Draft
that had been picked up and used by multiple implementations.

Another clash has just been pointed out to me between RFC 7150 and
draft-ietf-pce-gmpls-pcep-extensions.

The specifying of unallocated values in PCE I-Ds has got to stop before
significant clashes happen in the field. Cease! Desist! It is not necessary, and
there is a simple solution to get code points if you need them.

Steps to be followed:

1. Identify all I-Ds that state or recommend values for code points (see below).

2. Decide whether the values shown are needed to support existing
implementations.
2a. If so, make an immediate request to the WG chairs for early allocation of
the code points using the procedures of RFC 7120.
2b. If not, make an immediate revision of the I-D removing the specific code
point values.

3. In the future, when implementations of an I-D become advanced enough to be
close shipping or starting interop testing, use RFC 7120 to get code points
allocated.

4. Do not adopt any I-D as a working group draft if it specifies code points.

Current drafts

draft-ietf-pce-pce-initiated-lsp specifies unallocated values
draft-ietf-pce-pcep-stateful-pce-gmpls suggests values
draft-ietf-pce-remote-initiated-gmpls-lsp specifies an unallocated value
draft-ietf-pce-stateful-pce suggests multiple unallocated values
draft-ietf-pce-stateful-sync-optimizations specifies and suggests multiple
unallocated values

Recently-expired drafts

draft-ietf-pce-gmpls-pcep-extensions specifies multiple unallocated values
draft-ietf-pce-inter-layer-ext recommends multiple unallocated values

Thanks,
Adrian

---

From: Fatai Zhang <[email-masked]>
Date: Thu, 18 Sep 2014 08:31:51 +0000

Hi Adrian,

I think the steps you proposed really make sense. 

I have one comment for clarification on step (2a) and (4), did you mean that it only needs to use "TBD" rather than the suggested values? 

In addtion, for the new drafts (or non-existing drafts with clash), can I re-order your steps as follows? :-)

1. Do not adopt any I-D as a working group draft if it specifies code points.

2. In the future, when implementations of an I-D become advanced enough to be close shipping or starting interop testing, use RFC 7120 to get code points allocated.

Best Regards

Fatai

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, September 18, 2014 10:43 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Pce] Preaching about code points in drafts

PCE working group,

Steps to be followed:

Current drafts

Recently-expired drafts

Thanks,
Adrian

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: Fatai Zhang <[email-masked]>
Date: Thu, 18 Sep 2014 08:53:43 +0000

Hi, 

Sorry, I should say (2b) and (4), :-)

Best Regards

Fatai

-----Original Message-----
From: Fatai Zhang 
Sent: Thursday, September 18, 2014 4:32 PM
To: [email-masked]'; [email-masked]
Cc: [email-masked]
Subject: RE: [Pce] Preaching about code points in drafts

Hi Adrian,

Best Regards

Fatai

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Thursday, September 18, 2014 10:43 AM
To: [email-masked]
Cc: [email-masked]
Subject: [Pce] Preaching about code points in drafts

PCE working group,

Steps to be followed:

Current drafts

Recently-expired drafts

Thanks,
Adrian

---

From: Loa Andersson <[email-masked]>
Date: Thu, 18 Sep 2014 13:06:00 +0200

Fatai,

I agree with you - I also don't think this is only for the PCE
working group but should be applicable to the entire rtg area.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: OSCAR GONZALEZ DE DIOS <[email-masked]>
Date: Thu, 18 Sep 2014 11:12:26 +0000

Hi all,

   I fully agree with the procedure suggested by Adrian.

   @Fatai. I guess all drafts (stable or not), except those that have an
early allocation, will need to have a TBD value. A suggested value is
usually (mis)interpreted as ³this is the specified value, though not
official yet²

   Best Regards,

        Óscar

El 18/09/14 13:06, "Loa Andersson" <[email-masked]> escribió:

>> I have one comment for clarification on step (2a) and (4), did you mean
>>that it only needs to use "TBD" rather than the suggested values?
>>
>> 2. In the future, when implementations of an I-D become advanced enough
>>to be close shipping or starting interop testing, use RFC 7120 to get
>>code points allocated.
>>
>>
>>
>>
>> Best Regards
>>
>> Fatai
>>
>>

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Loa Andersson <[email-masked]>
Date: Thu, 18 Sep 2014 13:26:41 +0200

Oscar,

yes - true, but there are also FCFS allocations, such a code point
allocation can be made for any document (also an individual draft).

/Loa

--

---

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 18 Sep 2014 18:25:52 +0100

Right to all of you.

FCFS is already allocated, so that is OK.

TBD is what we want otherwise. That is no "recommendation" and no
"specification".

I would say, however, that sometimes it *is* appropriate to recommend values for
IANA when there is a special reason for a particular value, but that reason is
not strong enough to do early allocation.

A

> From: Loa Andersson [mailto:[email-masked]]
> Sent: 18 September 2014 12:27
> To: OSCAR GONZALEZ DE DIOS; Fatai Zhang; [email-masked]; [email-masked]
> Subject: Re: [Pce] Preaching about code points in drafts
> 
> Oscar,
> 
> > Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
puede
> contener información privilegiada o confidencial y es para uso exclusivo de la
> persona o entidad de destino. Si no es usted. el destinatario indicado, queda
> notificado de que la lectura, utilización, divulgación y/o copia sin
autorización
> puede estar prohibida en virtud de la legislación vigente. Si ha recibido este
> mensaje por error, le rogamos que nos lo comunique inmediatamente por esta
> misma vía y proceda a su destrucción.
> >
> > The information contained in this transmission is privileged and
confidential
> information intended only for the use of the individual or entity named above.
If
> the reader of this message is not the intended recipient, you are hereby
notified
> that any dissemination, distribution or copying of this communication is
strictly
> prohibited. If you have received this transmission in error, do not read it.
Please
> immediately reply to the sender that you have received this communication in
> error and then delete it.
> >
> > Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário,
> pode conter informação privilegiada ou confidencial e é para uso exclusivo da
> pessoa ou entidade de destino. Se não é vossa senhoria o destinatário
indicado,
> fica notificado de que a leitura, utilização, divulgação e/ou cópia sem
autorização
> pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem
> por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via
> e proceda a sua destruição
> >
> 
> --
> 
>