Subject: [Pce] Ask for early allocation of code-points of draft-ietf-pce-gmpls-pcep-extensions

From: OSCAR GONZALEZ DE DIOS <[email-masked]>
Date: Thu, 18 Sep 2014 12:52:07 +0000

Dear PCE WG chairs, PCErs,

The document draft-ietf-pce-gmpls-pcep-extensions has been stable for a while and it is near LC completion (the document started in 2010). There are early implementations of the draft. In my opinion, it is of high value to have early allocated values to support such implementations.

 Authors of  draft-ietf-pce-gmpls-pcep-extensions would like to request IANA the early allocation of the code-points included in draft-ietf-pce-gmpls-pcep-extensions.

We would like to ask PCErs if they see necessary the early allocation of code points in draft-ietf-pce-gmpls-pcep-extensions.

Best Regards,

Óscar

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Leeyoung <[email-masked]>
Date: Thu, 18 Sep 2014 21:10:08 +0000

I support the early allocation of code points in the said draft.

Young

From: Pce [mailto:[email-masked]] On Behalf Of OSCAR GONZALEZ DE DIOS
Sent: Thursday, September 18, 2014 7:52 AM
To: [email-masked]; [email-masked]
Subject: [Pce] Ask for early allocation of code-points of draft-ietf-pce-gmpls-pcep-extensions

Best Regards,

Óscar

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 19 Sep 2014 09:08:22 +0100

The chairs might forgive me for jumping in since I am on a crusade...
 
I must ask, why are you asking for the code points that are in the draft
already, and how will you handle the clash between those codepoints and the ones
already allocated and present in the registry?
 
I must also ask whether there are any plans to refresh the draft which expired
over a month ago.
 
Adrian
 
From: Pce [mailto:[email-masked]] On Behalf Of OSCAR GONZALEZ DE DIOS
Sent: 18 September 2014 13:52
To: [email-masked]; [email-masked]
Subject: [Pce] Ask for early allocation of code-points of
draft-ietf-pce-gmpls-pcep-extensions

The document draft-ietf-pce-gmpls-pcep-extensions has been stable for a while
and it is near LC completion (the document started in 2010). There are early
implementations of the draft. In my opinion, it is of high value to have early
allocated values to support such implementations.  
 
 Authors of  draft-ietf-pce-gmpls-pcep-extensions would like to request IANA the
early allocation of the code-points included in
draft-ietf-pce-gmpls-pcep-extensions. 
 
We would like to ask PCErs if they see necessary the early allocation of code
points in draft-ietf-pce-gmpls-pcep-extensions. 
 
Best Regards,
 
Óscar

  _____  

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede
contener información privilegiada o confidencial y es para uso exclusivo de la
persona o entidad de destino. Si no es usted. el destinatario indicado, queda
notificado de que la lectura, utilización, divulgación y/o copia sin
autorización puede estar prohibida en virtud de la legislación vigente. Si ha
recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente
por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential
information intended only for the use of the individual or entity named above.
If the reader of this message is not the intended recipient, you are hereby
notified that any dissemination, distribution or copying of this communication
is strictly prohibited. If you have received this transmission in error, do not
read it. Please immediately reply to the sender that you have received this
communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode
conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa
ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica
notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização
pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem
por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e
proceda a sua destruição

---

From: OSCAR GONZALEZ DE DIOS <[email-masked]>
Date: Fri, 19 Sep 2014 10:02:02 +0000

Hi Adrian,

We are asking for early allocation of code-points for draft-ietf-pce-gmpls-pcep-extensions. In the draft there are several suggested values. Considerations:

1) At least one of the values clashes with existing RFC, so it is NOT valid.  As damage (a clash of one value) is already there, we want to solve it as soon as possible. It will imply a new code point for the clashed value. And it will impact existing implementations. But, better fix it NOW and get an stable code, rather than waiting.

2) There is NO GUARANTEE that the suggested values that do not have clash won't have a clash later. Some documents move faster than others, and then numbers are assigned and clash happens. Thus, in sake of stability, and given that there are early implementations that might get affected of such kind of code-points move, we ask IANA to provide us codes that do not have clashes with existing RFCs, and that when other documents get their codes, they do not clash with the ones of the draft (as it may still take a while to become RFC).

I hope I am clear enough with what we are asking and why we are asking it.

Óscar

De: 'Adrian Farrel' <[email-masked]<mailto:[email-masked]>>
Responder a: 'Adrian Farrel' <[email-masked]<mailto:[email-masked]>>
Fecha: viernes, 19 de septiembre de 2014 10:08
Para: Oscar Gonzalez de Dios <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: RE: [Pce] Ask for early allocation of code-points of draft-ietf-pce-gmpls-pcep-extensions

I must ask, why are you asking for the code points that are in the draft already, and how will you handle the clash between those codepoints and the ones already allocated and present in the registry?

I must also ask whether there are any plans to refresh the draft which expired over a month ago.

Adrian

From: Pce [mailto:[email-masked]] On Behalf Of OSCAR GONZALEZ DE DIOS
Sent: 18 September 2014 13:52
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: [Pce] Ask for early allocation of code-points of draft-ietf-pce-gmpls-pcep-extensions

Best Regards,

Óscar

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 23 Sep 2014 13:30:03 +0100

I completely understand why you are asking. And I support that given the
implementations and assuming that the I-D is sufficiently stable.
 
I do not understand what you asking :-(
 
draft-ietf-pce-gmpls-pcep-extensions has expired. The IANA cannot make early
allocations for it.
The old version of draft-ietf-pce-gmpls-pcep-extensions contains specific code
points that IANA cannot allocate (as you observe).
 
What you need to do is...
1. Update the IANA section of the draft so that it is clean
2. Refresh the draft
3. Confirm with the chairs that this version is stable and meets other
requirements of 7120
4. Ask the chairs for early allocation (and then they will confirm with me)
5. Update the I-D (again) once the code points have been assigned
6. Remove all explicit, unassigned code points from other I-Ds you co-author
7. Make a solemn vow never to put unassigned code points in an I-D
 
Cheers,
Adrian
 
From: OSCAR GONZALEZ DE DIOS [mailto:[email-masked]] 
Sent: 19 September 2014 11:02
To: Adrian Farrel; [email-masked]; [email-masked]
Subject: Re: [Pce] Ask for early allocation of code-points of
draft-ietf-pce-gmpls-pcep-extensions
 
Hi Adrian,
 
We are asking for early allocation of code-points for
draft-ietf-pce-gmpls-pcep-extensions. In the draft there are several suggested
values. Considerations:
 
1) At least one of the values clashes with existing RFC, so it is NOT valid.  As
damage (a clash of one value) is already there, we want to solve it as soon as
possible. It will imply a new code point for the clashed value. And it will
impact existing implementations. But, better fix it NOW and get an stable code,
rather than waiting.
 
2) There is NO GUARANTEE that the suggested values that do not have clash won’t
have a clash later. Some documents move faster than others, and then numbers are
assigned and clash happens. Thus, in sake of stability, and given that there are
early implementations that might get affected of such kind of code-points move,
we ask IANA to provide us codes that do not have clashes with existing RFCs, and
that when other documents get their codes, they do not clash with the ones of
the draft (as it may still take a while to become RFC).

Óscar 

De: 'Adrian Farrel' <[email-masked]>
Responder a: 'Adrian Farrel' <[email-masked]>
Fecha: viernes, 19 de septiembre de 2014 10:08
Para: Oscar Gonzalez de Dios <[email-masked]>,
"[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: RE: [Pce] Ask for early allocation of code-points of
draft-ietf-pce-gmpls-pcep-extensions

 
 
Adrian

 

 
Best Regards,
 
Óscar

  _____  

 
  _____

---

From: Julien Meuric <[email-masked]>
Date: Tue, 23 Sep 2014 15:06:15 +0200

Hi Adrian.

I believe that when Oscar mentions "early allocation", he implicitly 
includes a refresh of the I-D as part of the process. This should 
address steps 1 and 2.

Following a private discussion, 3-4-5 are being considered. Oscar's 
message below was a move to allow to judge the consensus as mentioned in 
RFC 7120.

6 and 7 are new requirements, I leave them to Oscar (and associated 
authors)...

Regards,

Julien

Sep. 23, 2014 - Adrian Farrel:
> draft-ietf-pce-gmpls-pcep-extensions has expired. The IANA cannot make
> early allocations for it.
>
> The old version of draft-ietf-pce-gmpls-pcep-extensions contains
> specific code points that IANA cannot allocate (as you observe).
>
> *From:*OSCAR GONZALEZ DE DIOS [mailto:[email-masked]]
> *Sent:* 19 September 2014 11:02
> *To:* Adrian Farrel; [email-masked]; [email-masked]
> *Subject:* Re: [Pce] Ask for early allocation of code-points of
> We are asking for early allocation of code-points
> for draft-ietf-pce-gmpls-pcep-extensions. In the draft there are several
> suggested values. Considerations:
>
> 1) At least one of the values clashes with existing RFC, so it is NOT
> valid.  As damage (a clash of one value) is already there, we want to
> solve it as soon as possible. It will imply a new code point for the
> clashed value. And it will impact existing implementations. But, better
> fix it NOW and get an stable code, rather than waiting.
>
> 2) There is NO GUARANTEE that the suggested values that do not have
> clash won’t have a clash later. Some documents move faster than others,
> and then numbers are assigned and clash happens. Thus, in sake of
> stability, and given that there are early implementations that might get
> affected of such kind of code-points move, we ask IANA to provide us
> codes that do not have clashes with existing RFCs, and that when other
> documents get their codes, they do not clash with the ones of the draft
> (as it may still take a while to become RFC).
>
> *De: *'Adrian Farrel' <[email-masked] <mailto:[email-masked]>>
> *Responder a: *'Adrian Farrel' <[email-masked]
> <mailto:[email-masked]>>
> *Fecha: *viernes, 19 de septiembre de 2014 10:08
> *Para: *Oscar Gonzalez de Dios <[email-masked]
> <mailto:[email-masked]>>, "[email-masked]
> <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>,
> "[email-masked] <mailto:[email-masked]>" <[email-masked]
> <mailto:[email-masked]>>
> *Asunto: *RE: [Pce] Ask for early allocation of code-points of
> already, and how will you handle the clash between those codepoints and
> the ones already allocated and present in the registry?
>
> *From:*Pce [mailto:[email-masked]] *On Behalf Of *OSCAR GONZALEZ
> DE DIOS
> *Sent:* 18 September 2014 13:52
> *To:* [email-masked] <mailto:[email-masked]>; [email-masked]
> <mailto:[email-masked]>
> *Subject:* [Pce] Ask for early allocation of code-points of
> The document draft-ietf-pce-gmpls-pcep-extensions has been stable for a
> while and it is near LC completion (the document started in 2010). There
> are early implementations of the draft. In my opinion, it is of high
> value to have early allocated values to support such implementations.
>
>   Authors of  draft-ietf-pce-gmpls-pcep-extensions would like to request
> IANA the early allocation of the code-points included
> in draft-ietf-pce-gmpls-pcep-extensions.
>
> We would like to ask PCErs if they see necessary the early allocation of
> code points in draft-ietf-pce-gmpls-pcep-extensions.
>
> Best Regards,
>
> Óscar
>
> ------------------------------------------------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud
> de la legislación vigente. Si ha recibido este mensaje por error, le
> rogamos que nos lo comunique inmediatamente por esta misma vía y proceda
> a su destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution
> or copying of this communication is strictly prohibited. If you have
> received this transmission in error, do not read it. Please immediately
> reply to the sender that you have received this communication in error
> and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu
> destinatário, pode conter informação privilegiada ou confidencial e é
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
> senhoria o destinatário indicado, fica notificado de que a leitura,
> utilização, divulgação e/ou cópia sem autorização pode estar proibida em
> virtude da legislação vigente. Se recebeu esta mensagem por erro,
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e
> proceda a sua destruição
>
> ------------------------------------------------------------------------
>
>
> Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario,
> puede contener información privilegiada o confidencial y es para uso
> exclusivo de la persona o entidad de destino. Si no es usted. el
> destinatario indicado, queda notificado de que la lectura, utilización,
> divulgación y/o copia sin autorización puede estar prohibida en virtud
> de la legislación vigente. Si ha recibido este mensaje por error, le
> rogamos que nos lo comunique inmediatamente por esta misma vía y proceda
> a su destrucción.
>
> The information contained in this transmission is privileged and
> confidential information intended only for the use of the individual or
> entity named above. If the reader of this message is not the intended
> recipient, you are hereby notified that any dissemination, distribution
> or copying of this communication is strictly prohibited. If you have
> received this transmission in error, do not read it. Please immediately
> reply to the sender that you have received this communication in error
> and then delete it.
>
> Esta mensagem e seus anexos se dirigem exclusivamente ao seu
> destinatário, pode conter informação privilegiada ou confidencial e é
> para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
> senhoria o destinatário indicado, fica notificado de que a leitura,
> utilização, divulgação e/ou cópia sem autorização pode estar proibida em
> virtude da legislação vigente. Se recebeu esta mensagem por erro,
> rogamos-lhe que nos o comunique imediatamente por esta mesma via e
> proceda a sua destruição
>
>
>
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>

---

From: OSCAR GONZALEZ DE DIOS <[email-masked]>
Date: Tue, 23 Sep 2014 13:18:14 +0000

Hi Adrian, all

I completely understand why you are asking. And I support that given the implementations and assuming that the I-D is sufficiently stable.

[Oscar] We asked the WG chairs advice on how to proceed with draft-ietf-pce-gmpls-pcep-extensions and if we could request early allocation of code-points. PCE WG chairs told us, regarding the early allocation, that there was not yet consensus on the matter.  I was trying to build that consensus by asking in the PCE WG list if people considered necessary requesting early allocation, as early allocation needs per 7120 sufficient interest in the community.

 draft-ietf-pce-gmpls-pcep-extensions has expired. The IANA cannot make early allocations for it.
The old version of draft-ietf-pce-gmpls-pcep-extensions contains specific code points that IANA cannot allocate (as you observe).

[Oscar] We have a new version of draft-ietf-pce-gmpls-pcep-extensions ready to submit addressing last call comments and all IANA values removed.

3. Confirm with the chairs that this version is stable and meets other requirements of 7120

[Oscar] We will start with 1 & 2 (without values in IANA section).

Cheers,
Adrian

Best Regards,

Oscar

From: OSCAR GONZALEZ DE DIOS [mailto:[email-masked]]
Sent: 19 September 2014 11:02
To: Adrian Farrel; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Pce] Ask for early allocation of code-points of draft-ietf-pce-gmpls-pcep-extensions

Hi Adrian,

2) There is NO GUARANTEE that the suggested values that do not have clash won’t have a clash later. Some documents move faster than others, and then numbers are assigned and clash happens. Thus, in sake of stability, and given that there are early implementations that might get affected of such kind of code-points move, we ask IANA to provide us codes that do not have clashes with existing RFCs, and that when other documents get their codes, they do not clash with the ones of the draft (as it may still take a while to become RFC).

Óscar

Adrian

Best Regards,

Óscar