Subject: [Pce] Request for early allocation of code points for draft-ietf-pce-inter-layer-ext & status of draft

From: OSCAR GONZALEZ DE DIOS <[email-masked]>
Date: Thu, 4 Sep 2014 09:59:47 +0000

Dear authors of draft-ietf-pce-inter-layer-ext,

The draft draft-ietf-pce-inter-layer-ext, in its version 8 right now, introduces a set of new PCEP objects, which require object-class values. Current recommended values clash with already allocated values.

As suggested in the last IETF meeting in Toronto, the use of the early allocation procedure is recommended to handle the code points (when the draft is stable). Would it be possible that authors of the draft ask for early allocation of code points for draft-ietf-pce-inter-layer-ext ?

On the other hand, I see that the draft has been stable for a while and even has expired. Who is taking care of the updates of the draft? Is the draft going to last call in the near future? Are you expecting a review?

Best Regards,

Óscar

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Fatai Zhang <[email-masked]>
Date: Fri, 5 Sep 2014 05:59:49 +0000

Hi Oscar,

I don't think we need to ask early allocation of code points, which is for the special case (ie., early allocation is not the normal procedure) and the right values will be allocated during RFC publication stage (ie., the clash will disappear) .

The authors of this draft including me are taking care of this draft and we always welcome any review comments from the WG.

Note that the WG chairs told in the previous meeting that they would like to move forward [draft-ietf-pce-gmpls-pcep-extensions<http://tools.ietf.org/wg/pce/draft-ietf-pce-gmpls-pcep-extensions/>] first, and then move forward this draft.

Any further comments are apprecicated.

Best Regards

Fatai

From: Pce [mailto:[email-masked]] On Behalf Of OSCAR GONZALEZ DE DIOS
Sent: Thursday, September 04, 2014 6:00 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Pce] Request for early allocation of code points for draft-ietf-pce-inter-layer-ext & status of draft

Best Regards,

Óscar

---

From: OSCAR GONZALEZ DE DIOS <[email-masked]>
Date: Fri, 5 Sep 2014 11:50:09 +0000

Hi Fatai,

It is crystal clear that when the document becomes an RFC, IANA will assign the correct number.

In my humble opinion, requesting for the early allocation is not "a special case", but the normal procedure that should be followed (obviously, it is not the traditional way to do things), approved by IANA, so early implementations of stable documents have a code point that has no clashes. Furthermore, early allocated code points are maintained in the IANA registry. Traditional way of adding the "suggested value" in the IANA section in the draft has led to many problems. We even have a very recent case where a value used in a draft with early implementations has forced a value in an RFC with less implementations to change.

    Summing up, I see absolutely no reason not to ask for the early allocation, in this particular draft, and in all stable drafts in the working group. I the particular case of this drafts, the suggested values of the new objects are the same ones are values used in existing RFCs, complicating the interoperability.

In any case, requesting the early allocation is a decision to be taken by the authors of the draft. However, I would like to know also the opinions of the chairs on wether the early allocation procedure is the "normal procedure" or the "special case" for stable working group documents.

Best Regards,

Óscar

De: Fatai Zhang <[email-masked]<mailto:[email-masked]>>
Fecha: viernes, 5 de septiembre de 2014 07:59
Para: Oscar Gonzalez de Dios <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
CC: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Asunto: RE: [Pce] Request for early allocation of code points for draft-ietf-pce-inter-layer-ext & status of draft

Hi Oscar,

Best Regards

Fatai

From: Pce [mailto:[email-masked]] On Behalf Of OSCAR GONZALEZ DE DIOS
Sent: Thursday, September 04, 2014 6:00 PM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: [Pce] Request for early allocation of code points for draft-ietf-pce-inter-layer-ext & status of draft

Best Regards,

Óscar

---

From: Leeyoung <[email-masked]>
Date: Fri, 5 Sep 2014 15:55:14 +0000

Hi Oscar and Fatai,

I think the special case would be determined if the drafts have implementations that have been shipped/deployed in production networks (which is above lab trials) prior to the standardization.

So any notes to the WG with implementations in production networks will justify the early IANA allocation.

Regards,
Young

From: Pce [mailto:[email-masked]] On Behalf Of OSCAR GONZALEZ DE DIOS
Sent: Friday, September 05, 2014 6:50 AM
To: Fatai Zhang; [email-masked]
Cc: [email-masked]
Subject: Re: [Pce] Request for early allocation of code points for draft-ietf-pce-inter-layer-ext & status of draft

Hi Fatai,

Best Regards,

Óscar

Hi Oscar,

Best Regards

Fatai

Best Regards,

Óscar

---

From: Julien Meuric <[email-masked]>
Date: Fri, 12 Sep 2014 17:18:56 +0200

Hi Oscar.

Sorry for the late response, I have overlooked the part directed to the 
chairs.

Even if suboptimal from the implementer's point of view, the usual 
procedure is codepoint allocation during RFC publication. Anyway, a 
process for early allocation is defined: as such, it is not a "special 
case" (a case without defined procedure would be), but not the 
mainstream procedure either.

To correct one of your statement below, a WG I-D is owned by a WG. 
Requesting early allocation, as taking strong decisions related to a WG 
I-D, needs WG consensus (i.e. more than authors' decision). So far, no 
consensus for early allocation has been reached...

Back to this particular I-D, suggested values are already out-dated and 
I am not sure a sudden "early" (or rather "late, but before RFC") 
allocation would bring much value at this stage. (But we may miss some 
information there.)

Regards,

Julien

Sep. 05, 2014 - OSCAR GONZALEZ DE DIOS:
 > In my humble opinion, requesting for the early allocation is not “a
 > special case”, but the normal procedure that should be followed
 > (obviously, it is not the traditional way to do things), approved by
 > IANA, so early implementations of stable documents have a code point
 > that has no clashes. Furthermore, early allocated code points are
 > maintained in the IANA registry. Traditional way of adding the
 > “suggested value” in the IANA section in the draft has led to many
 > problems. We even have a very recent case where a value used in a
 > draft with early implementations has forced a value in an RFC with
 > less implementations to change.
 >
 > Summing up, I see absolutely no reason not to ask for the early
 > allocation, in this particular draft, and in all stable drafts in the
 > working group. I the particular case of this drafts, the suggested
 > values of the new objects are the same ones are values used in
 > existing RFCs, complicating the interoperability.
 >
 > In any case, requesting the early allocation is a decision to be
 > taken by the authors of the draft. However, I would like to know also
 > the opinions of the chairs on wether the early allocation procedure
 > is the “normal procedure” or the “special case” for stable working
 > group documents.
 >
 > Best Regards,
 >
 > Óscar
 >
 >
 >
 > De: Fatai Zhang <[email-masked]
 > <mailto:[email-masked]>> Fecha: viernes, 5 de septiembre de
 > 2014 07:59
 >
 > Hi Oscar,
 >
 >
 >
 > I don’t think we need to ask early allocation of code points, which
 > is for the special case (ie., early allocation is not the normal
 > procedure) and the right values will be allocated during RFC
 > publication stage (ie., the clash will disappear) .
 >
 >
 >
 > The authors of this draft including me are taking care of this draft
 > and we always welcome any review comments from the WG.
 >
 >
 >
 > Note that the WG chairs told in the previous meeting that they would
 > like to move forward [draft-ietf-pce-gmpls-pcep-extensions
 > <http://tools.ietf.org/wg/pce/draft-ietf-pce-gmpls-pcep-extensions/>]
 > first, and then move forward this draft.
 >
 >
 >
 > *From:*Pce [mailto:[email-masked]] *On Behalf Of *OSCAR
 > GONZALEZ DE DIOS *Sent:* Thursday, September 04, 2014 6:00 PM
 >
 >
 >
 > The draft draft-ietf-pce-inter-layer-ext, in its version 8 right now,
 > introduces a set of new PCEP objects, which require object-class
 > values. Current recommended values clash with already allocated
 > values.
 >
 >
 >
 > As suggested in the last IETF meeting in Toronto, the use of the
 > early allocation procedure is recommended to handle the code points
 > (when the draft is stable). Would it be possible that authors of the
 > draft ask for early allocation of code points for
 > draft-ietf-pce-inter-layer-ext ?
 >
 >
 >
 > On the other hand, I see that the draft has been stable for a while
 > and even has expired. Who is taking care of the updates of the draft?
 > Is the draft going to last call in the near future? Are you expecting
 > a review?
 >
 >
 >
 > Best Regards,
 >
 >
 >
 > Óscar
 >
 >
 >
 >
 >
 >
 >
 > -------------------------
 >
 >
 > Este mensaje y sus adjuntos se dirigen exclusivamente a su
 > destinatario, puede contener información privilegiada o confidencial
 > y es para uso exclusivo de la persona o entidad de destino. Si no es
 > usted. el destinatario indicado, queda notificado de que la lectura,
 > utilización, divulgación y/o copia sin autorización puede estar
 > prohibida en virtud de la legislación vigente. Si ha recibido este
 > mensaje por error, le rogamos que nos lo comunique inmediatamente por
 > esta misma vía y proceda a su destrucción.
 >
 > The information contained in this transmission is privileged and
 > confidential information intended only for the use of the individual
 > or entity named above. If the reader of this message is not the
 > intended recipient, you are hereby notified that any dissemination,
 > distribution or copying of this communication is strictly prohibited.
 > If you have received this transmission in error, do not read it.
 > Please immediately reply to the sender that you have received this
 > communication in error and then delete it.
 >
 > Esta mensagem e seus anexos se dirigem exclusivamente ao seu
 > destinatário, pode conter informação privilegiada ou confidencial e é
 > para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
 > senhoria o destinatário indicado, fica notificado de que a leitura,
 > utilização, divulgação e/ou cópia sem autorização pode estar proibida
 > em virtude da legislação vigente. Se recebeu esta mensagem por erro,
 > rogamos-lhe que nos o comunique imediatamente por esta mesma via e
 > proceda a sua destruição
 >
 >
 > -------------------------
 >
 > Este mensaje y sus adjuntos se dirigen exclusivamente a su
 > destinatario, puede contener información privilegiada o confidencial
 > y es para uso exclusivo de la persona o entidad de destino. Si no es
 > usted. el destinatario indicado, queda notificado de que la lectura,
 > utilización, divulgación y/o copia sin autorización puede estar
 > prohibida en virtud de la legislación vigente. Si ha recibido este
 > mensaje por error, le rogamos que nos lo comunique inmediatamente por
 > esta misma vía y proceda a su destrucción.
 >
 > The information contained in this transmission is privileged and
 > confidential information intended only for the use of the individual
 > or entity named above. If the reader of this message is not the
 > intended recipient, you are hereby notified that any dissemination,
 > distribution or copying of this communication is strictly prohibited.
 > If you have received this transmission in error, do not read it.
 > Please immediately reply to the sender that you have received this
 > communication in error and then delete it.
 >
 > Esta mensagem e seus anexos se dirigem exclusivamente ao seu
 > destinatário, pode conter informação privilegiada ou confidencial e é
 > para uso exclusivo da pessoa ou entidade de destino. Se não é vossa
 > senhoria o destinatário indicado, fica notificado de que a leitura,
 > utilização, divulgação e/ou cópia sem autorização pode estar proibida
 > em virtude da legislação vigente. Se recebeu esta mensagem por erro,
 > rogamos-lhe que nos o comunique imediatamente por esta mesma via e
 > proceda a sua destruição
 >
 >
 > _______________________________________________ Pce mailing list
 > [email-masked] https://www.ietf.org/mailman/listinfo/pce

---

From: OSCAR GONZALEZ DE DIOS <[email-masked]>
Date: Fri, 12 Sep 2014 19:05:46 +0000

Hi Julien

   Thanks for the answer,

>mainstream procedure either.

RFC 7120 is the main source of information for the allocation procedure.
The problem that such RFC tries to solve is when implementation and/or
deployment experience are desired or required before the document becomes
an RFC. Thus, it seems the mechanism is there for cases when there are
early (pre-RFC) implementations, which are desired for feedback before the
document becomes and RFC and changes are more difficult. Rest of cases
when there are no pre-RFC implementations are OK with the usual procedure.

>I-D, needs WG consensus (i.e. more than authors' decision).

Going back to RFC 7120, one of main thing to look at the early allocation
in a draft is (again quoting) ³The Working Group chairs and Area Directors
(ADs) judge that there is sufficient interest in the community for early
(pre-RFC) implementation and deployment, or that failure to make an early
allocation might lead to contention for the code point in the field."

> So far, no

Well.. I just noticed that there was a contention for the code point in
the draftŠ so I just suggested the procedure to the authors, as a mean of
help. One of the authors believed it was not necessary and standard
procedure could be followed.

>allocation would bring much value at this stage. (But we may miss some

Well.. I think we were missing in previous email the spirit of RFC 7120.
The information needed is whether there are early implementations or not.
I guess that either the answer is no, or people are shy or not able to
disclose it.

Best Regards,

  Óscar

> > In my humble opinion, requesting for the early allocation is not ³a
> > special case², but the normal procedure that should be followed
> > ³suggested value² in the IANA section in the draft has led to many
> > is the ³normal procedure² or the ³special case² for stable working
> > group documents.
> >
> > Best Regards,
> >
> > Óscar
> >
> >
> >
> > I don¹t think we need to ask early allocation of code points, which
>[email-masked]
>https://www.ietf.org/mailman/listinfo/pce