Subject: Re: [Pce] New Version Notification for draft-wu-pce-traffic-steering-sfc-06.txt

From: Qin Wu <[email-masked]>
Date: Wed, 11 Mar 2015 02:24:54 +0000

Hi, folks:
Here is the update to draft-wu-pce-traffic-steering-sfc-06 based on relevant discussion regarding Support of SF Spirals on the SFC list.
http://www.ietf.org/internet-drafts/draft-wu-pce-traffic-steering-sfc-06.txt
We can see SFP Identifier is required by both SFF and Classifier.

In this update, we give the SFP Identifier format and 
define operation of SFP Identifier which is to get in line with 
draft-quinn-sfc-nsh and draft-ietf-sfc-architecture.
The diff is:
http://www.ietf.org/rfcdiff?url2=draft-wu-pce-traffic-steering-sfc-06

Your comments and suggestions are welcome!

Regards!
-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2015年3月5日 10:18
收件人: Qin Wu; Qin Wu; Jeff Tantsura; Dhruv Dhody; Christian Jacquenet; Dhruv Dhody; Mohamed Boucadair; Christian Jacquenet; Jeff Tantsura; Mohamed Boucadair
主题: New Version Notification for draft-wu-pce-traffic-steering-sfc-06.txt

A new version of I-D, draft-wu-pce-traffic-steering-sfc-06.txt
has been successfully submitted by Qin Wu and posted to the IETF repository.

Name:		draft-wu-pce-traffic-steering-sfc
Revision:	06
Title:		PCEP Extensions for traffic steering support in Service Function Chaining
Document date:	2015-03-04
Group:		Individual Submission
Pages:		10
URL:            http://www.ietf.org/internet-drafts/draft-wu-pce-traffic-steering-sfc-06.txt
Status:         https://datatracker.ietf.org/doc/draft-wu-pce-traffic-steering-sfc/
Htmlized:       http://tools.ietf.org/html/draft-wu-pce-traffic-steering-sfc-06
Diff:           http://www.ietf.org/rfcdiff?url2=draft-wu-pce-traffic-steering-sfc-06

Abstract:
   This document provides an overview of the usage of Path Computation
   Element (PCE) with Service Function Chaining (SFC); which is
   described as the definition and instantiation of an ordered set of
   such service functions (such as firewalls, load balancers), and the
   subsequent "steering" of traffic flows through those service
   functions.

   This document specifies extensions to the Path Computation Element
   Protocol (PCEP) that allow a stateful PCE to compute and instantiate
   Service Function Paths (SFP).

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Qin Wu <[email-masked]>
Date: Mon, 16 Mar 2015 02:36:56 +0000

Hi, Hao:
Thanks for your interests and valuable cmments. See my reply inline below.
-Qin
发件人: sfc [mailto:[email-masked]] 代表 Hao Wang
发送时间: 2015年3月13日 21:06
收件人: sfc
主题: Re: [sfc] New Version Notification for draft-wu-pce-traffic-steering-sfc-06.txt
Hi:
  I have read this draft and think it's useful for this PCEP extensions, which can allow stateful PCE to compute and instantiate SFP.
  Several commets below:

1.  How about multi-SFP instantiate maintainance, can this stateful PCE be handled？
[Qin]: Good question, the simply solution is to carry multiple SFP Identifier TLVs to indicate multi-SFP instantiate from stateful PCE server.
If we look for more generic way for multi-SFP handling, we may reference draft-dhody-pce-association-attr-01
http://tools.ietf.org/id/draft-dhody-pce-association-attr-01.txt
and define generic group id to do this.

2.  As figure 1 show, what's the relationship between SFC control plane and stateful PCE Policy？
[Qin]: SFC control plane is more about policy driven, In each interaction between SFC control plane and SFC data plane,
Policy will be installed or populated at data plane node. For example, each interaction between PCE server and SFC Classifier
Will lead to classification rules being installed which enable SFP selection for the traffic, each interaction between SFC controller and SFC data plane node(e.g., SFF) will lead to forwarding policy being populated at the corresponding nodes.

3.  Is there any way to manage or configue the process of instantiation of SFP?
[Qin]: This is what we try to solve in this draft and proposes a way to manage or configure of SFP instantiation process.
The basic idea is to use PCE initiated mechanism proposed in draft-ietf-pce-pce-initiated-lsp-02 and combine with SFP Identifier TLV proposed in this draft to provide SFP instantiation management.

Best Regards,
Hao

2015-03-13
________________________________
Hao