Subject: [Pce] Query on Usage of LSP Identifier TLV in SR

From: Dhruv Dhody <[email-masked]>
Date: Mon, 12 Oct 2015 05:58:32 +0000

Hi Authors,

In the stateful PCE draft [1], it says -
The LSP Identifiers TLV MUST be included in the LSP object in PCRpt
messages for RSVP-signaled LSPs.

The SR draft [2] did not mention anything about LSP Identifier TLV.
And in implementations that I am aware of, SR-TE LSP still uses the LSP-Identifier TLV. Is that correct? (I personally think so!!)

If yes, do you think there is a need to update -

-      [1] to say all LSPs (and not just RSVP-signaled).

-      Or [2] to say that LSP-Identifier TLV are also applicable to SR and MUST be included.

Thanks!
Dhruv

[1] https://tools.ietf.org/html/draft-ietf-pce-stateful-pce-11#section-7.3.1
[2] http://datatracker.ietf.org/doc/draft-ietf-pce-segment-routing/

---

From: Girish Birajdar <[email-masked]>
Date: Mon, 12 Oct 2015 12:03:07 -0700

piggy backing on Dhruv email ...

During PCUpdate for SR LSP -  MBB process mentioned in
draft-tanaka-pce-stateful-pce-mbb applicable? The MBB draft has expired,
will it be incorporated in stateful-pce draft?

Thanks,
Girish

On Sun, Oct 11, 2015 at 10:58 PM, Dhruv Dhody <[email-masked]>
wrote:

> Hi Authors,
>
>
>
> In the stateful PCE draft [1], it says –
>
> And in implementations that I am aware of, SR-TE LSP still uses the
> LSP-Identifier TLV. Is that correct? (I personally think so!!)
>
>
>
> If yes, do you think there is a need to update –
>
> [1]
> https://tools.ietf.org/html/draft-ietf-pce-stateful-pce-11#section-7.3.1
>
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>
>

---

From: Julien Meuric <[email-masked]>
Date: Tue, 13 Oct 2015 11:07:53 +0200

Hi Girish,

Due to the very different levels of maturity between stateful-pce and 
MBB I-Ds, we do not see them merging. MBB I-D was very briefly discussed 
on the list a while ago, we do not know what the plans of the authors are...

Regards,

Julien

Oct. 12, 2015 - [email-masked]:
> draft-tanaka-pce-stateful-pce-mbb applicable? The MBB draft has 
> expired, will it be incorporated in stateful-pce draft?
>
> Thanks,
> Girish
>
> On Sun, Oct 11, 2015 at 10:58 PM, Dhruv Dhody <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>     Hi Authors,
>
>     And in implementations that I am aware of, SR-TE LSP still uses
>     the LSP-Identifier TLV. Is that correct? (I personally think so!!)
>
>     -[1] to say all LSPs (and not just RSVP-signaled).
>
>     -Or [2] to say that LSP-Identifier TLV are also applicable to SR
>     and MUST be included.
>
>     Thanks!
>
>     Dhruv
>
>     [1]
>     [email-masked] <mailto:[email-masked]>

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 13 Oct 2015 17:55:13 +0530

Hi Julien, Girish,

Speaking as one of the authors of MBB draft[1], IMHO we need to re-spin the
draft based on the generic association draft [2] once it is adopted by the
WG.

And as Julien said, there won't be any "merging"!

BTW the original question in the thread still stands!

Regards,
Dhruv

[1] https://www.ietf.org/archive/id/draft-tanaka-pce-stateful-pce-mbb-03.txt
[2] https://tools.ietf.org/html/draft-minei-pce-association-group-03

On Tue, Oct 13, 2015 at 2:37 PM, Julien Meuric <[email-masked]>
wrote:

> Hi Girish,
>
> Due to the very different levels of maturity between stateful-pce and MBB
> I-Ds, we do not see them merging. MBB I-D was very briefly discussed on the
> list a while ago, we do not know what the plans of the authors are...
>
> Regards,
>
> Julien
>
>

---

From: Robert Varga <[email-masked]>
Date: Thu, 22 Oct 2015 13:29:31 +0200

On 10/12/2015 07:58 AM, Dhruv Dhody wrote:
> -Or [2] to say that LSP-Identifier TLV are also applicable to SR and 
> MUST be included.
>

The wording in stateful draft is meant to proscribe behavior for RSVP 
(as that is what RFC5440 assumes), while allowing different setup 
mechanisms 
(https://datatracker.ietf.org/doc/draft-ietf-pce-lsp-setup-type/) 
specify their own LSP identifier format.

In this spirit I think the SR draft should be updated to explicitly 
state that SR reuses the same identifier format as RSVP (or whatever is 
appropriate).

Bye,
Robert

---

From: Dhruv Dhody <[email-masked]>
Date: Sun, 25 Oct 2015 18:38:02 +0530

Hi Robert,

I agree, can the SR draft authors confirm (and make an update in the next
revision)?

Regards,
Dhruv

On Thu, Oct 22, 2015 at 4:59 PM, Robert Varga <[email-masked]> wrote:

> The wording in stateful draft is meant to proscribe behavior for RSVP (as
> that is what RFC5440 assumes), while allowing different setup mechanisms (
> https://datatracker.ietf.org/doc/draft-ietf-pce-lsp-setup-type/) specify
> their own LSP identifier format.
>
> In this spirit I think the SR draft should be updated to explicitly state
> that SR reuses the same identifier format as RSVP (or whatever is
> appropriate).
>
> Bye,
> Robert
>
>