Subject: Re: [Pce] comments on draft-ietf-pce-pce-initiated-lsp

From: Jonathan Hardwick <[email-masked]>
Date: Fri, 9 Oct 2015 15:59:37 +0000

Hi Girish

Thanks for the comment.  I think your points are valid.  We will add a clarifying passage to the next version of draft-ietf-pce-segment-routing to address this.

Best regards
Jon (as co-author of draft-ietf-pce-segment-routing)

From: Girish Birajdar [mailto:[email-masked]]
Sent: 01 October 2015 18:15
To: [email-masked]
Cc: [email-masked]
Subject: comments on draft-ietf-pce-pce-initiated-lsp

Authors,
This comment is specific to LSP initiate message and MSD value specified in draft-ietf-pce-segment-routing.

draft-ietf-pce-segment-routing "5.1.1.1.  Exchanging SR Capability ...
An MSD value of zero means that a PCC does
   not impose any default limitation on the number of SIDs included in
   any SR-TE path coming from PCE"

draft-ietf-pce-pce-initiated-lsp does not mention MSD. Is it possible to cover few error cases that might have when PCEP session has MSD=0 and LSP Initiate message sends unacceptable label-stack size?
IMO, when PCC receives a LSP Initiate Message that exceeds its stack-size limit, an error message that specifies acceptable MSD value would be useful.

Regards,
Girish

---

From: Girish Birajdar <[email-masked]>
Date: Mon, 12 Oct 2015 10:04:40 -0700

Hi Jon,

I am back tracking a bit to elaborate the issue.

A PCC at PE device advertises MSD based on its data plane capability.
Network service instances can use PCReq to create a LSP. Since PE will add
labels to identify the service instance, LSP with maximum stack-size is not
acceptable. In such cases the PCRequest should specify the MSD metric
values less than the MSD in Open message. Current draft says PCE should
error if MSD metric is received for session that has non-zero MSD value.
This should be addressed in pce-segment-routing draft.
Example:
PE device send MSD=10 in Open message.
While setting up LSP For a service instance that uses 2 inner labels, the
PCReq should specify MSD=8 (hop-count can not be used for stack-size
constraint in seg-routing).

Second issue (original email):
My understanding is a management tool action will make the (Controller) PCE
to send PCInit message to PCC at PE device. The draft does not preclude
processing of PCInit message by (management) PCC. The (management) PCC will
advertise pce-initiate-lsp support and MSD=0? The pce-intiated-lsp draft
should clarify how MSD value are specified by (management)PCC.

Thanks,
Girish

On Fri, Oct 9, 2015 at 8:59 AM, Jonathan Hardwick <
[email-masked]> wrote:

> Hi Girish
>
>
>
> Thanks for the comment.  I think your points are valid.  We will add a
> clarifying passage to the next version of draft-ietf-pce-segment-routing to
> address this.
>
>
>
> Best regards
>
> *From:* Girish Birajdar [mailto:[email-masked]]
> *Sent:* 01 October 2015 18:15
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* comments on draft-ietf-pce-pce-initiated-lsp
>
>
>
> Authors,
>