Subject: [Pce] Few queries regarding draft-dhody-pce-stateful-pce-auto-bandwidth-06 draft

From: Venugopal Reddy K <[email-masked]>
Date: Mon, 26 Oct 2015 09:09:03 +0000

Dear Authors,

I have few queries regarding draft-dhody-pce-stateful-pce-auto-bandwidth-06.

1.       We have Overflow-Count, Overflow-Threshold and Underflow-Count, Underflow-Threshold to expedite the process of PCC adjusting the bandwidth instead of waiting for Adjustment-Interval when an abrupt change in bandwidth usage occurs. Similarly, we have Report-Flow-Threshold value for a PCC to report for PCE adjusting bandwidth model instead of waiting for Report-Interval. Can we know if there is rationale behind having different method for PCC controlling bandwidth adjustment and PCE controlling bandwidth adjustment for this case? Why not have the similar mechanism for it ?

2.       Once auto-bandwidth adjustment is enabled for an LSP, Couldn't find any way to disable auto adjustment feature for an LSP. It would be good to have a means to disable adjustment without bringing the LSP down.  Also, changing auto-bandwidth adjustment mode from PCC to PCE or vice versa without LSP down.

Could you please clarify.

Thanks :)

Regards,
Venu

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 27 Oct 2015 07:23:04 +0000

Hi Venu,

Thanks for reading the draft and posting queries.

See inline...

From: Pce [mailto:[email-masked]] On Behalf Of Venugopal Reddy K
Sent: 26 October 2015 14:39
To: [email-masked]; pce
Subject: [Pce] Few queries regarding draft-dhody-pce-stateful-pce-auto-bandwidth-06 draft

Dear Authors,

[Dhruv]: Are you asking why we don't have a "Report-Flow-Count" (similar to Underflow and overflow-count)? Hmm, I guess "Report-Flow-Count" can be added, it is a good suggestion.
This would indicate how many times consecutively, the percentage or absolute difference between the current bandwidth sample and the current bandwidth reservation should be greater than or equal to the report-flow-threshold value, for all the bandwidth samples collected so far to be reported to the PCE immediately.

[Dhruv]: I think this could be useful, will discuss with my co-authors and add mechanism for this in future revision.

Regards,
Dhruv

Thanks :)

Regards,
Venu