Subject: [Pce] [Errata Verified] RFC6006 (4868)

From: RFC Errata System <[email-masked]>
Date: Tue, 15 Nov 2016 21:59:10 -0800 (PST)

The following errata report has been verified for RFC6006,
"Extensions to the Path Computation Element Communication Protocol (PCEP) for Point-to-Multipoint Traffic Engineering Label Switched Paths". 

--------------------------------------
You may review the report below and at:
http://www.rfc-editor.org/errata_search.php?rfc=6006&eid=4868

--------------------------------------
Status: Verified
Type: Technical

Reported by: DHRUV DHODY <[email-masked]>
Date Reported: 2016-11-16
Verified by: Deborah Brungard (IESG)

Section: 3.5

Original Text
-------------
          <PCRep Message>::= <Common Header>
                                <response>
          <response>::=<RP>
                          [<end-point-path-pair-list>]
                          [<NO-PATH>]
                          [<attribute-list>]

        where:

           <end-point-path-pair-list>::=
                   [<END-POINTS>]<path>[<end-point-path-pair-list>]

          <path> ::= (<ERO>|<SERO>) [<path>]

          <attribute-list>::=[<OF>]
                               [<LSPA>]
                               [<BANDWIDTH>]
                               [<metric-list>]
                               [<IRO>]

Corrected Text
--------------
          <PCRep Message>::= <Common Header>
                             <response-list>

          where:

              <response-list>::=<response>[<response-list>]

              <response>::=<RP>
                         [<end-point-path-pair-list>]
                        [<NO-PATH>]
                        [<UNREACH-DESTINATION>]
                        [<attribute-list>]

              <end-point-path-pair-list>::=
                      [<END-POINTS>]<path>[<end-point-path-pair-list>]

              <path> ::= (<ERO>|<SERO>) [<path>]

          where:

              <attribute-list>::=[<OF>]
                                 [<LSPA>]
                                 [<BANDWIDTH>]
                                 [<metric-list>]
                                 [<IRO>]

Notes
-----
o Update the RBNF for Reply message format:

      * Update PCEP allows for the bundling of multiple path computation
      responses within a single Path Computation Reply (PCRep) message.

      * Update UNREACH-DESTINATION in PCRep message. This object was 
      missed in [RFC6006].

Refer: https://datatracker.ietf.org/doc/draft-palleti-pce-rfc6006bis/?include_text=1

--------------------------------------
RFC6006 (draft-ietf-pce-pcep-p2mp-extensions-11)
--------------------------------------
Title               : Extensions to the Path Computation Element Communication Protocol (PCEP) for Point-to-Multipoint Traffic Engineering Label Switched Paths
Publication Date    : September 2010
Author(s)           : Q. Zhao, Ed., D. King, Ed., F. Verhaeghe, T. Takeda, Z. Ali, J. Meuric
Category            : PROPOSED STANDARD
Source              : Path Computation Element
Area                : Routing
Stream              : IETF
Verifying Party     : IESG

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 16 Nov 2016 09:46:38 -0000

Good job getting this done quickly. Thanks.

Adrian
--
Support an author and your imagination.
Tales from the Wood - Eighteen new fairy tales.
More Tales from the Wood - Eighteen MORE new fairy tales.
https://www.feedaread.com/profiles/8604/
http://www.amazon.co.uk/Tales-Wood-Adrian-Farrel/dp/1786100924
Or buy from me direct.

> -----Original Message-----
> From: Pce [mailto:[email-masked]] On Behalf Of RFC Errata System
> Sent: 16 November 2016 05:59
> To: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [Pce] [Errata Verified] RFC6006 (4868)
> 
> "Extensions to the Path Computation Element Communication Protocol (PCEP)
> for Point-to-Multipoint Traffic Engineering Label Switched Paths".
> 
> Title               : Extensions to the Path Computation Element Communication
> Protocol (PCEP) for Point-to-Multipoint Traffic Engineering Label Switched
Paths
> Author(s)           : Q. Zhao, Ed., D. King, Ed., F. Verhaeghe, T. Takeda, Z.
Ali, J.
> Meuric
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce