Subject: Re: [Pce] A question about RFC8281 PCE-initiated LSPs.

From: [email-masked]
Date: Tue, 23 Jan 2018 15:37:24 +0800

Hi Dhruv,

Thank you for the reply!O(∩_∩)O~

I agree two created PCE-initiated LSPs may be associated by ASSOCIATION 
object as discussed in draft-barth-pce-association-bidir.

But if there is no LSP existed, how to request a bi-directional TE LSP 
from PCE in PCE initiated operation?

Quan Xiong

--------------------------------------------------------------------------------
[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index] 

Re: [Pce] A question about RFC8281 PCE-initiated LSPs.

--------------------------------------------------------------------------------

To: "xiong.quan at zte.com.cn" <xiong.quan at zte.com.cn>, "edward.crabbe 
at gmail.com" <edward.crabbe at gmail.com>, "inaminei at google.com" 
<inaminei at google.com>, "msiva at cisco.com" <msiva at cisco.com>, 
"robert.varga at pantheon.tech" <robert.varga at pantheon.tech> 
Subject: Re: [Pce] A question about RFC8281 PCE-initiated LSPs. 
From: Dhruv Dhody <dhruv.dhody at huawei.com> 
Date: Tue, 23 Jan 2018 03:28:27 +0000 
Accept-language: en-GB, en-US 
Archived-at: <
https://mailarchive.ietf.org/arch/msg/pce/ryZRIHK4zGoqSAsxMFQetTWDjbY> 
Cc: "hu.fangwei at relay.zte.com.cn" <hu.fangwei at relay.zte.com.cn>, 
"pce at ietf.org" <pce at ietf.org>, "draft-barth-pce-association-bidir at 
ietf.org" <draft-barth-pce-association-bidir at ietf.org> 
Delivered-to: pce at ietfa.amsl.com 
In-reply-to: 
<[email-masked]> 
List-archive: <https://mailarchive.ietf.org/arch/browse/pce/> 
List-help: <mailto:[email-masked]?subject=help> 
List-id: Path Computation Element <pce.ietf.org> 
List-post: <mailto:[email-masked]> 
List-subscribe: <https://www.ietf.org/mailman/listinfo/pce>, <
mailto:[email-masked]?subject=subscribe> 
List-unsubscribe: <https://www.ietf.org/mailman/options/pce>, <
mailto:[email-masked]?subject=unsubscribe> 
References: 
<[email-masked]> 
Thread-index: AQHTk+76gKqVuxcwbkmqwLTk/0dyLaOAy0lA 
Thread-topic: [Pce] A question about RFC8281 PCE-initiated LSPs. 

--------------------------------------------------------------------------------
Hi Quan, 

Check out -  
https://datatracker.ietf.org/doc/draft-barth-pce-association-bidir/

Authors are in cc, if you need to have further discussion! 

Thanks! 

Dhruv 

From: Pce [mailto:pce-bounces at ietf.org] On Behalf Of xiong.quan at 
zte.com.cn
Sent: 23 January 2018 07:37
To: edward.crabbe at gmail.com; inaminei at google.com; msiva at 
cisco.com; robert.varga at pantheon.tech
Cc: hu.fangwei at relay.zte.com.cn; pce at ietf.org
Subject: [Pce] A question about RFC8281 PCE-initiated LSPs.

Hi all, 

I encountered a problem as following shown.O(∩_∩)O~ 

As defined in RFC5440,the PCC-initiated LSPs creation uses the B bit in RP 
object of PCReq message to indicate the direction of the TE LSP. 
When set, the PCC requests a bi-directional TE LSP and when cleared, the 
TE LSP is unidirectional. 

And in stateful PCE, RFC8281 proposed the PCE-initiated LSPs and the PCE 
could send a PCInitiate message to the PCC to request the creation of an 
LSP. 
The PCInitiate message carry the Objects including SRP, LSP ,END-POINTS 
and ERO. But no B bit in SRP object. 

How to configure the direction of the TE LSP in PCE-initiated operation? 

Best Regards, 

Quan Xiong 

--------------------------------------------------------------------------------

References: 
[Pce] A question about RFC8281 PCE-initiated LSPs. 
From: xiong . quan
Prev by Date: Re: [Pce] Adoption Poll for 
draft-raghu-pce-lsp-control-request 
Previous by thread: [Pce] A question about RFC8281 PCE-initiated LSPs. 
Index(es): 
Date 
Thread 
Note: Messages sent to this list are the opinions of the senders and do 
not imply endorsement by the IETF.

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 23 Jan 2018 11:21:15 +0000

Hi Quan,

As per [1]:

       A PCE initiating a new LSP, can include the association group
   information.  This is done by including the ASSOCIATION Object in a
   PCInitiate message.

So when a new LSP is created by PCE, you could still indicate the association. The association is not limited to existing LSPs.

Hope this helps! Let me know if I understood your question correctly!

Regards,
Dhruv

[1] https://tools.ietf.org/html/draft-ietf-pce-association-group-04#section-5.2.1

From: [email-masked] [mailto:[email-masked]]
Sent: 23 January 2018 13:07
To: Dhruv Dhody <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Pce] A question about RFC8281 PCE-initiated LSPs.

Hi Dhruv,

I agree two created PCE-initiated LSPs may be associated by ASSOCIATION object as discussed in draft-barth-pce-association-bidir.

But if there is no LSP existed, how to request a bi-directional TE LSP from PCE in PCE initiated operation?

Quan Xiong

To: "xiong.quan at zte.com.cn" <xiong.quan at zte.com.cn>, "edward.crabbe at gmail.com" <edward.crabbe at gmail.com>, "inaminei at google.com" <inaminei at google.com>, "msiva at cisco.com" <msiva at cisco.com>, "robert.varga at pantheon.tech" <robert.varga at pantheon.tech>
Subject: Re: [Pce] A question about RFC8281 PCE-initiated LSPs.
From: Dhruv Dhody <dhruv.dhody at huawei.com>
Date: Tue, 23 Jan 2018 03:28:27 +0000
Accept-language: en-GB, en-US
Archived-at: <https://mailarchive.ietf.org/arch/msg/pce/ryZRIHK4zGoqSAsxMFQetTWDjbY>
Cc: "hu.fangwei at relay.zte.com.cn" <hu.fangwei at relay.zte.com.cn>, "pce at ietf.org" <pce at ietf.org>, "draft-barth-pce-association-bidir at ietf.org" <draft-barth-pce-association-bidir at ietf.org>

Check out -  https://datatracker.ietf.org/doc/draft-barth-pce-association-bidir/

Thanks!

Dhruv

From: Pce [mailto:pce-bounces at ietf.org] On Behalf Of xiong.quan at zte.com.cn
Sent: 23 January 2018 07:37
To: edward.crabbe at gmail.com; inaminei at google.com; msiva at cisco.com; robert.varga at pantheon.tech
Cc: hu.fangwei at relay.zte.com.cn; pce at ietf.org
Subject: [Pce] A question about RFC8281 PCE-initiated LSPs.

Hi all,

As defined in RFC5440,the PCC-initiated LSPs creation uses the B bit in RP object of PCReq message to indicate the direction of the TE LSP.
When set, the PCC requests a bi-directional TE LSP and when cleared, the TE LSP is unidirectional.

And in stateful PCE, RFC8281 proposed the PCE-initiated LSPs and the PCE could send a PCInitiate message to the PCC to request the creation of an LSP.
The PCInitiate message carry the Objects including SRP, LSP ,END-POINTS and ERO. But no B bit in SRP object.

Best Regards,

Quan Xiong

References:
[Pce] A question about RFC8281 PCE-initiated LSPs.
From: xiong . quan
Prev by Date: Re: [Pce] Adoption Poll for draft-raghu-pce-lsp-control-request
Previous by thread: [Pce] A question about RFC8281 PCE-initiated LSPs.
Index(es):
Date
Thread
Note: Messages sent to this list are the opinions of the senders and do not imply endorsement by the IETF.