Subject: [Pce] A question about RFC8281 PCE-initiated LSPs.

From: [email-masked]
Date: Tue, 23 Jan 2018 10:07:12 +0800

Hi all,

I encountered a problem as following shown.O(∩_∩)O~

As defined in RFC5440,the PCC-initiated LSPs creation uses the B bit in RP 
object of PCReq message to indicate the direction of the TE LSP.
When set, the PCC requests a bi-directional TE LSP and when cleared, the 
TE LSP is unidirectional.

And in stateful PCE, RFC8281 proposed the PCE-initiated LSPs and the PCE 
could send a PCInitiate message to the PCC to request the creation of an 
LSP.
The PCInitiate message carry the Objects including SRP, LSP ,END-POINTS 
and ERO. But no B bit in SRP object.

How to configure the direction of the TE LSP in PCE-initiated operation?

Best Regards,
Quan Xiong

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 23 Jan 2018 03:28:27 +0000

Hi Quan,

Check out -  https://datatracker.ietf.org/doc/draft-barth-pce-association-bidir/
Authors are in cc, if you need to have further discussion!

Thanks!
Dhruv

From: Pce [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 23 January 2018 07:37
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: [Pce] A question about RFC8281 PCE-initiated LSPs.

Hi all,

As defined in RFC5440,the PCC-initiated LSPs creation uses the B bit in RP object of PCReq message to indicate the direction of the TE LSP.
When set, the PCC requests a bi-directional TE LSP and when cleared, the TE LSP is unidirectional.

And in stateful PCE, RFC8281 proposed the PCE-initiated LSPs and the PCE could send a PCInitiate message to the PCC to request the creation of an LSP.
The PCInitiate message carry the Objects including SRP, LSP ,END-POINTS and ERO. But no B bit in SRP object.

Best Regards,

Quan Xiong