Subject: [Pce] Query regarding RFC7420

From: "M.Sowmya ." <[email-masked]>
Date: Sat, 12 May 2018 13:57:55 +0000

Hi,

This query is regarding the current PCEP standard MIB.

In the current MIB implementation, neither pcePcepPeerAddr nor pcePcepEntityIndex is part of the standard notification object.

With this implementation, how do we indicate active and standby PCEP sessions in the notifications or in other words how to uniquely identify the PCEP session that sends the notification?

We would like to propose a modification to the existing draft to include the unique session identifier as part of the notification object.
Please let me know your thoughts.

Thanks,
Sowmya

---

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 12 May 2018 19:05:38 +0100

Hey Sowmya,
 
I think you may misunderstand the nature of SNMP notifications. The objects they
contain are not abstract fields, they are objects in entries in tables. Thus,
the notification is supplying specific fields in specific entries in the tables,
and so automatically indicate the context.
 
Cheers,
Adrian
 
From: Pce [mailto:[email-masked]] On Behalf Of M.Sowmya .
Sent: 12 May 2018 14:58
To: [email-masked]
Subject: [Pce] Query regarding RFC7420
 
Hi,
 
This query is regarding the current PCEP standard MIB.
In the current MIB implementation, neither pcePcepPeerAddr nor
pcePcepEntityIndex is part of the standard notification object.
 
With this implementation, how do we indicate active and standby PCEP sessions in
the notifications or in other words how to uniquely identify the PCEP session
that sends the notification?
 
We would like to propose a modification to the existing draft to include the
unique session identifier as part of the notification object.
Please let me know your thoughts.
 
Thanks,
Sowmya

---

From: Anush Mohan <[email-masked]>
Date: Mon, 14 May 2018 08:54:08 +0530

hi Adrian,

   Could you please clarify it bit more. Does this mean that we pass
pointer to {pcepSessState, pcePcepSessStateLastChange} in pcePcepSessEntry
table (maybe via OID-ref)
rather than actual {session-state, timestamp} value for this notification.

Regards
Anush

On Sat, May 12, 2018 at 11:35 PM, Adrian Farrel <[email-masked]> wrote:

> Hey Sowmya,
>
>
>
> I think you may misunderstand the nature of SNMP notifications. The
> objects they contain are not abstract fields, they are objects in entries
> in tables. Thus, the notification is supplying specific fields in specific
> entries in the tables, and so automatically indicate the context.
>
>
>
> Cheers,
>
> Adrian
>
>
>
> *From:* Pce [mailto:[email-masked]] *On Behalf Of *M.Sowmya ..
> *Sent:* 12 May 2018 14:58
> *To:* [email-masked]
> *Subject:* [Pce] Query regarding RFC7420
>
>
>
> Hi,
>
>
>
> In the current MIB implementation, neither *pcePcepPeerAddr *nor *pcePcepEntityIndex* is part of the standard notification object.
>
>
>
> With this implementation, how do we indicate active and standby PCEP
> sessions in the notifications or in other words how to uniquely identify
> the PCEP session that sends the notification?
>
>
>
> We would like to propose a modification to the existing draft to include
> the unique session identifier as part of the notification object.
>
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce
>
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 14 May 2018 13:16:15 +0100

Hej,
 
pcepSessState and pcePcepSessStateLastChange are objects not values. The Notification does not copy values from storage and pass them - to do that the Notification would need to define new objects in a new table, etc. 
 
But the definition is 
   pcePcepSessUp NOTIFICATION-TYPE
       OBJECTS     {
                      pcePcepSessState,
                      pcePcepSessStateLastChange
                   }
 
So go and look up the meaning of the "OBJECTS" clause (maybe the whole definition of the "NOTIFICATION-TYPE" macro) in RFC 2578 or a good book on SMI. This will show you that the Notification emits the objects and they are, of course, parameterised so that you can determine to which table entry they apply.
 
Adrian
 
From: Anush Mohan [mailto:[email-masked]] 
Sent: 14 May 2018 04:24
To: [email-masked]; [email-masked]
Cc: M.Sowmya .
Subject: Re: [Pce] Query regarding RFC7420
 
hi Adrian,
   Could you please clarify it bit more. Does this mean that we pass pointer to {pcepSessState, pcePcepSessStateLastChange} in pcePcepSessEntry table (maybe via OID-ref)
rather than actual {session-state, timestamp} value for this notification.

Regards
Anush

I think you may misunderstand the nature of SNMP notifications. The objects they contain are not abstract fields, they are objects in entries in tables. Thus, the notification is supplying specific fields in specific entries in the tables, and so automatically indicate the context.
 
Cheers,
Adrian
 
From: Pce [mailto:[email-masked]] On Behalf Of M.Sowmya ..
Sent: 12 May 2018 14:58
To: [email-masked]
Subject: [Pce] Query regarding RFC7420
 
Hi,

 
 
Thanks,
Sowmya