Subject: [Pce] Chair's pre-adoption review of draft-sivabalan-pce-binding-label-sid-06

From: Dhruv Dhody <[email-masked]>
Date: Mon, 24 Jun 2019 15:56:56 +0530

Hi Authors,

In preparation for the upcoming WG adoption call, I did a quick review of your
I-D to tidy things up. At this stage we need to make sure that I-D is in good
enough state as a base of further work by the WG if adopted.

(1) 6 authors on the front page, better to handle this now itself, rather than
much later in the process.

(2) Add Implementation Status as per the WG policy. I assume there are
implementations of this work?

(3) Start work on the 'Manageability Considerations' section. Currently it is
marked TBD.

(4) This document includes details about reporting BSID for a path. What
happens when PCE creates a SR path (SR-ERO) that includes a BSID. This detail
is currently missing, we need to a clarity on how to encode a BSID in SR-ERO
and the best place is this document.

My guess would be to say no NAI in case of BSID in SR-ERO and confirm how the
flags should be set for both SR-MPLS and SRv6.

(5) Add reference to Section 6.4 of [I-D.ietf-spring-segment-routing-policy]
for non-SR use of BSID.

(6) Why use 'label/SID' in this I-D? Please check in spring what would be the
best practice can it just be SID?

(7) Security Consideration is bit week. You have a way for PCE to assign BSID
and this needs to be analysed for potential exploitation.

(8) Update Section 6.1.1 to include SRv6

(9) Remove this sentence from section 1 - "However, use of this TLV for
carrying non-MPLS binding SID will be described in separate document(s)."; as
you support SRv6. Similarly, reword section 3, 2nd paragraph.

Note that these are non-blocking comments for WG adoption but it would be
great, if the authors publish a revision handling these.

Thanks!
Dhruv

---

From: "Siva Sivabalan (msiva)" <[email-masked]>
Date: Mon, 24 Jun 2019 12:19:06 +0000

Hi Dhruv,

We will address your comments and post a new rev.

Thanks,
Siva

Siva Sivabalan
PRINCIPAL ENGINEER.ENGINEERING
[email-masked]
Tel: +1 613 254 3782
Cisco Systems, Inc.
2000 Innovation Drive
KANATA
K2K 3E8
Canada
cisco.com

Think before you print.
This email may contain confidential and privileged material for the sole use of the intended recipient. Any review, use, distribution or disclosure by others is strictly prohibited. If you are not the intended recipient (or authorized to receive for the recipient), please contact the sender by reply email and delete all copies of this message.
Please click here for Company Registration Information.

-----Original Message-----
From: Dhruv Dhody <[email-masked]> 
Sent: Monday, June 24, 2019 6:27 AM
To: [email-masked]
Cc: [email-masked]; pce-chairs <[email-masked]>
Subject: Chair's pre-adoption review of draft-sivabalan-pce-binding-label-sid-06

Hi Authors,

In preparation for the upcoming WG adoption call, I did a quick review of your I-D to tidy things up. At this stage we need to make sure that I-D is in good enough state as a base of further work by the WG if adopted.

(1) 6 authors on the front page, better to handle this now itself, rather than much later in the process.

(2) Add Implementation Status as per the WG policy. I assume there are implementations of this work?

(3) Start work on the 'Manageability Considerations' section. Currently it is marked TBD.

(4) This document includes details about reporting BSID for a path. What happens when PCE creates a SR path (SR-ERO) that includes a BSID. This detail is currently missing, we need to a clarity on how to encode a BSID in SR-ERO and the best place is this document.

My guess would be to say no NAI in case of BSID in SR-ERO and confirm how the flags should be set for both SR-MPLS and SRv6.

(6) Why use 'label/SID' in this I-D? Please check in spring what would be the best practice can it just be SID?

(7) Security Consideration is bit week. You have a way for PCE to assign BSID and this needs to be analysed for potential exploitation.

(9) Remove this sentence from section 1 - "However, use of this TLV for carrying non-MPLS binding SID will be described in separate document(s)."; as you support SRv6. Similarly, reword section 3, 2nd paragraph.

Note that these are non-blocking comments for WG adoption but it would be great, if the authors publish a revision handling these.

Thanks!
Dhruv