Subject: [Pce] Shepherd Review of draft-ietf-pce-lsp-control-request-05

From: Hariharan Ananthakrishnan <[email-masked]>
Date: Mon, 24 Jun 2019 18:31:56 -0700

-------
Header:
In general should we use "Stateful PCE" or "stateful PCE" ? I see in RFC
8231 we use "Stateful PCE"

OLD:
Ability for a stateful Path Computation Element (PCE)

NEW:
Ability for a Stateful Path Computation Element (PCE)

--------
Abstract:
OLD:
A stateful Path Computation Element (PCE)

NEW:
A Stateful Path Computation Element (PCE)

-------------
Section 4:
To make it more clear, it would be good to state that C and D flags are
mutually exclusive in PCUpd message.

OLD:

The PCE SHOULD NOT send control request for LSP which is already
delegated to the
PCE, i.e. if the D flag is set in the PCUpd message, then C flag
SHOULD NOT be set.

NEW:

The D Flag and C Flag are mutually exclusive in PCUpd message. The PCE
SHOULD NOT

send control request for LSP which is already delegated to thePCE, i.e. if

the D flag is set in the PCUpd message, then C flag SHOULD NOT be set.

--------------

I dont see Adrian's suggestion being implemented in Section 8 in the
latest draft. It would be good to have this apart from the Security
Considerations.

SUGGESTED:

Not sure whether it belongs in 8.1 or 8.3 or 7...
The Security considerations section suggests dropping delegation
requests if the PCC is swamped. I think you need to configure the
threshold for swamping, and to recommend that the issue be logged.

IMPLEMENTED:

-----------------

Thanks,
Hari

---

From: Hariharan Ananthakrishnan <[email-masked]>
Date: Mon, 24 Jun 2019 18:39:02 -0700

+ Authors.

On Mon, Jun 24, 2019 at 6:31 PM Hariharan Ananthakrishnan <[email-masked]>
wrote:

> The PCE SHOULD NOT send control request for LSP which is already delegated to the
> PCE, i.e. if the D flag is set in the PCUpd message, then C flag SHOULD NOT be set.
>
>
> NEW:
>
> The D Flag and C Flag are mutually exclusive in PCUpd message. The PCE SHOULD NOT
>
> I dont see Adrian's suggestion being implemented in Section 8 in the latest draft. It would be good to have this apart from the Security Considerations.
>
>
> SUGGESTED:
>

---

From: Mahendra Singh Negi <[email-masked]>
Date: Tue, 25 Jun 2019 07:28:48 +0000

Hi Hari,

Thanks for the review, comments are fixed and new version is uploaded.

Htmlized:      https://tools.ietf.org/html/draft-ietf-pce-lsp-control-request-06

Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-pce-lsp-control-request-06

Regards,
Mahendra

From: Hariharan Ananthakrishnan [mailto:[email-masked]]
Sent: Tuesday, June 25, 2019 7:09 AM
To: [email-masked]; [email-masked]; [email-masked]; [email-masked]; Siva Sivabalan (msiva) <[email-masked]>; Mahendra Singh Negi <[email-masked]>
Subject: Re: Shepherd Review of draft-ietf-pce-lsp-control-request-05

+ Authors.

On Mon, Jun 24, 2019 at 6:31 PM Hariharan Ananthakrishnan <[email-masked]<mailto:[email-masked]>> wrote:
-------
Header:
In general should we use "Stateful PCE" or "stateful PCE" ? I see in RFC 8231 we use "Stateful PCE"

OLD:

NEW:

--------
Abstract:
OLD:

NEW:

-------------
Section 4:
To make it more clear, it would be good to state that C and D flags are mutually exclusive in PCUpd message.

OLD:

NEW:

--------------

SUGGESTED:

IMPLEMENTED:

-----------------

Thanks,

Hari