Subject: [Pce] 答复: PCEP Enhanced Errors

From: "Zhenghaomian (Zhenghaomian, Optical Technology Research Dept)" <[email-masked]>
Date: Mon, 3 Jun 2019 01:50:31 +0000

Hi, Adrian, WGs, 

Thank you for bringing the issue to the list, I think we agreed the direction you mentioned 'no haste but keep moving' in Prague. We would definitely like to provide some text as guideline for other documents, either in the draft or on the wiki page, or both. Personally I need to understand the context in the wiki page before doing that. Do the chairs want to see a separate paragraph talking about the error handling? Or we put the text together with other sections like 'implement policy'? 

We can move on providing text once we can agree on how to manage, thank you. 

Best wishes,
Haomian (as one of the co-authors)

-----邮件原件-----
发件人: Pce [mailto:[email-masked]] 代表 Adrian Farrel
发送时间: 2019年5月31日 23:25
收件人: [email-masked]
主题: [Pce] PCEP Enhanced Errors

Hi,

In Prague we had a discussion of draft-ietf-pce-enhanced-errors.  

My recollection is that we decided that there was no great hurry to push this document to completion, but that we didn't want to abandon it.

Checking back with the minutes, there was an objective that we encourage authors of other documents to adhere to the error behaviours described in this document. We do this possibly by putting text on a wiki page, but first by discussing the guidelines on the mailing list. Looks like we were particularly interested in the behaviours when there are multiple PCEs present.

We also discussed the possibilities for encouraging an "Error Handling"
section in all our drafts, or at least for a section on "Error Handling in Multi-PCE Scenarios" when applicable.

Would the authors of draft-ietf-pce-enhanced-errors like to take the lead on this?

Thanks,
Adrian

_______________________________________________
Pce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pce

---

From: Dhruv Dhody <[email-masked]>
Date: Mon, 3 Jun 2019 10:57:50 +0530

Hi Haomian,

Lets come up with the guidelines (and get the agreement on the mailing
list) first!
Then, lets take one of the I-D as example and work with the authors to
incorporate the guidelines.

We can worry about how to add guidelines to the wiki later. We can
also add the guidelines in your draft itself.

Thanks!
Dhruv

On Mon, Jun 3, 2019 at 7:20 AM Zhenghaomian (Zhenghaomian, Optical

---

From: "Zhenghaomian (Zhenghaomian, Optical Technology Research Dept)" <[email-masked]>
Date: Thu, 6 Jun 2019 10:07:58 +0000

Hi, Dhruv, WG, 

I think the following text would be helpful as the guideline. 

------ guideline text starts ---------
Error handling should be considered in any multi-PCE drafts. A requirement for the editors of these drafts is to evaluate what error types between PCE may occur in the specified scenarios in the draft and whether new error types need to be extended. It is also requested to check the applicability of the procedures specified in draft-ietf-pce-enhanced-errors to both the existing and the extending error types. For PCE protocol extension who gives new error types, it is requested to provide description on the applicability of "Propagation" TLV and "Error-criticality" TLV. 
------ guideline text ends ---------

Any comments or rephrasing would be more than welcome, thank you. 

Best wishes,
Haomian
-----邮件原件-----
发件人: Dhruv Dhody [mailto:[email-masked]] 
发送时间: 2019年6月3日 13:28
收件人: Zhenghaomian (Zhenghaomian, Optical Technology Research Dept) <[email-masked]>
抄送: [email-masked]; [email-masked]
主题: Re: [Pce] 答复: PCEP Enhanced Errors

Hi Haomian,

Lets come up with the guidelines (and get the agreement on the mailing
list) first!
Then, lets take one of the I-D as example and work with the authors to incorporate the guidelines.

We can worry about how to add guidelines to the wiki later. We can also add the guidelines in your draft itself.

Thanks!
Dhruv

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 7 Jun 2019 16:45:43 +0530

Hi Haomian, WG,

Note that, this guideline should be for any 'future' draft, since this update
would have to use [I-D.ietf-pce-enhanced-errors] as a normative reference (as
they will be providing details of Error-criticality and Propagation etc).
For any 'mature' draft it is better to use [I-D.ietf-pce-enhanced-errors]
as informative reference with details of error handling added into
[I-D.ietf-pce-enhanced-errors] itself (as already done for some drafts).

Thus my suggestion would be to say -

Error and Notification handling as per [I-D.ietf-pce-enhanced-errors] should
be considered in PCE documents that include multi-PCE interactions. A
requirement for the editors of these drafts is to evaluate the applicability
of the procedure in [I-D.ietf-pce-enhanced-errors] and provide details about
the "Error-criticality" TLV and "Propagation" TLV for errors and notifications
defined in the draft. Examples of this can be found in section 5.4.3 of
[I-D.ietf-pce-enhanced-errors].

Thoughts?

Thanks!
Dhruv

On Thu, Jun 6, 2019 at 3:38 PM Zhenghaomian (Zhenghaomian, Optical

---

From: "Zhenghaomian (Zhenghaomian, Optical Technology Research Dept)" <[email-masked]>
Date: Sat, 8 Jun 2019 13:55:57 +0000

Hi, Dhruv, WG, 

Thank you for the updating, please find my slight 'addition' as follow: 

Error and Notification handling as per [I-D.ietf-pce-enhanced-errors] should be considered in PCE documents that include multi-PCE interactions. A requirement for the editors of these drafts is to evaluate the applicability of the procedure in [I-D.ietf-pce-enhanced-errors] and make a statement on whether new error types need to be extended. If yes, it is also requested to provide details about the "Error-criticality" TLV and "Propagation" TLV for errors and notifications defined in the draft. Examples of this can be found in section 5.4.3 of [I-D.ietf-pce-enhanced-errors].

BTW, I have no problem on the criteria on whether to put the [I-D.ietf-pce-enhanced-errors] as a normative reference or information reference, as the error handling in 'Mature' drafts has already been included in the latest version of  [I-D.ietf-pce-enhanced-errors]. 

Best wishes,
Haomian

-----邮件原件-----
发件人: Dhruv Dhody [mailto:[email-masked]] 
发送时间: 2019年6月7日 19:16
收件人: Zhenghaomian (Zhenghaomian, Optical Technology Research Dept) <[email-masked]>
抄送: [email-masked]; [email-masked]
主题: Re: [Pce] 答复: PCEP Enhanced Errors

Hi Haomian, WG,

Note that, this guideline should be for any 'future' draft, since this update would have to use [I-D.ietf-pce-enhanced-errors] as a normative reference (as they will be providing details of Error-criticality and Propagation etc).
For any 'mature' draft it is better to use [I-D.ietf-pce-enhanced-errors] as informative reference with details of error handling added into [I-D.ietf-pce-enhanced-errors] itself (as already done for some drafts).

Error and Notification handling as per [I-D.ietf-pce-enhanced-errors] should be considered in PCE documents that include multi-PCE interactions. A requirement for the editors of these drafts is to evaluate the applicability of the procedure in [I-D.ietf-pce-enhanced-errors] and provide details about the "Error-criticality" TLV and "Propagation" TLV for errors and notifications defined in the draft. Examples of this can be found in section 5.4.3 of [I-D.ietf-pce-enhanced-errors].

Thoughts?

Thanks!
Dhruv

On Thu, Jun 6, 2019 at 3:38 PM Zhenghaomian (Zhenghaomian, Optical Technology Research Dept) <[email-masked]> wrote:
> ------ guideline text starts --------- Error handling should be 
> considered in any multi-PCE drafts. A requirement for the editors of these drafts is to evaluate what error types between PCE may occur in the specified scenarios in the draft and whether new error types need to be extended. It is also requested to check the applicability of the procedures specified in draft-ietf-pce-enhanced-errors to both the existing and the extending error types. For PCE protocol extension who gives new error types, it is requested to provide description on the applicability of "Propagation" TLV and "Error-criticality" TLV.

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 12 Jun 2019 16:42:54 +0530

Hi WG,

Haomian and I discussed this offline and came up with this guideline,
that should covers all the cases -

Error and Notification handling as per [I-D.ietf-pce-enhanced-errors] should
be considered in PCE documents that include new errors and notifications. A
requirement for the authors of these drafts is to evaluate the applicability
of the procedure in [I-D.ietf-pce-enhanced-errors] and provide details about
the "Error-criticality" TLV and "Propagation" TLV for errors and notifications
defined in the draft. Examples of this can be found in section 5.4.3 of
[I-D.ietf-pce-enhanced-errors].

Thoughts?

Dhruv

On Sat, Jun 8, 2019 at 7:26 PM Zhenghaomian (Zhenghaomian, Optical
Technology Research Dept) <[email-masked]> wrote:
> Error and Notification handling as per [I-D.ietf-pce-enhanced-errors] should be considered in PCE documents that include multi-PCE interactions.

[Dhruv]: Any new error / notifications definition should include the
recommended values for "Error-criticality" TLV and "Propagation" TLV.
So instead of "multi-PCE" interaction, better to say "new errors and
notifications".

> A requirement for the editors of these drafts is to evaluate the applicability of the procedure in [I-D.ietf-pce-enhanced-errors] and make a statement on whether new error types need to be extended.

[Dhruv]:removed 'make a statement....'

>If yes, it is also requested to provide details about the "Error-criticality" TLV and "Propagation" TLV for errors and notifications defined in the draft. Examples of this can be found in section 5.4.3 of [I-D.ietf-pce-enhanced-errors].
>