Subject: [Pce] WG adoption poll for draft-sivabalan-pce-binding-label-sid-07

From: Dhruv Dhody <[email-masked]>
Date: Tue, 20 Aug 2019 23:14:36 +0530

Hi WG,

This email begins the WG adoption poll for
draft-sivabalan-pce-binding-label-sid-07 [1].

Should this draft be adopted by the PCE WG? Please state your reasons - Why /
Why not? What needs to be fixed before or after adoption? Are you willing to
work on this draft? Review comments should be posted to the list.

One of the chairs did a pre-adoption review [2] and authors posted a new
revision. Note that there are known implementations.

This adoption poll will end on 6th September 2019.

Thanks!
Dhruv (for the chairs)

[1] https://tools.ietf.org/html/draft-sivabalan-pce-binding-label-sid-07
[2] https://mailarchive.ietf.org/arch/msg/pce/oaBIRA9FnNsV6-JrKKRCdwtLysk

---

From: Jeff Tantsura <[email-masked]>
Date: Tue, 20 Aug 2019 16:08:11 -0400

As co-author support adoption.
Preemptively - not aware of any IPR

Cheers,
Jeff
On Aug 20, 2019, 1:45 PM -0400, Dhruv Dhody <[email-masked]>, wrote:
> _______________________________________________
> Pce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pce

---

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Wed, 21 Aug 2019 02:08:04 +0000

Yes, support. Binding SID is very useful in many use cases, such as inter-domain/Multi-domain routing, SR policy, tunnel stitching, etc.  

Also, as descripted in this document, Huawei has implemented the mechanism. Since the text is mature, I support this WG adoption.

Best regards,
Cheng as a co-author.

-----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Wednesday, August 21, 2019 1:45 AM
To: [email-masked]
Cc: pce-chairs <[email-masked]>
Subject: [Pce] WG adoption poll for draft-sivabalan-pce-binding-label-sid-07

Hi WG,

Should this draft be adopted by the PCE WG? Please state your reasons - Why / Why not? What needs to be fixed before or after adoption? Are you willing to work on this draft? Review comments should be posted to the list.

One of the chairs did a pre-adoption review [2] and authors posted a new revision. Note that there are known implementations.

Thanks!
Dhruv (for the chairs)

---

From: Khasanov Boris <[email-masked]>
Date: Wed, 21 Aug 2019 07:09:52 +0000

Hi Dhruv and all,

Yes, I personally support the adoption of this draft.

Additionally to a pre-adoption review, few questions to authors for a thinking during next version preparation (sorry if I missed earlier discussion about this).

The draft says:
" A PCC could report the binding label/SID allocated by it to the
   stateful PCE via Path Computation State Report (PCRpt) message.  It
   is also possible for a stateful PCE to request a PCC to allocate a
   specific binding label/SID by sending an Path Computation Update
   Request (PCUpd) message.
...
Additionally, to support the PCE based central controller [RFC8283]
   operation where the PCE would take responsibility for managing some
   part of the MPLS label space for each of the routers that it
   controls, the PCE could directly make the binding label/SID
   allocation and inform the PCC."

In case of PCE based central controller {RFC8283] when PCECC is responsible for label allocation it is quite clear - how we could optimally use a Binding SID, PCE knows everything and knows where to use Binding SID so it can 'force' needed PCCs to allocate it via PCUpd  as it is mentioned in the draft. or provision a  Binding SID in centralized mode.

But what about our traditional distributed case, for example, how Gateway Node 1 (Fig.1 in the draft) would understand that he should allocate a Binding SID towards PCE?
What will trigger that ? 
Should Gateway Node 1 analyze capabilities of Access node (Maximum SID depth) and make an assumption that it could need a Binding SID?

IMO, we should think and try to propose some mechanism (besides relying on PCE central controller)  for distributed case to let PCC know that he should create Binding SID and report it to PCE.

Thank you.

SY,
Boris

 -----Original Message-----
From: Pce [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Tuesday, August 20, 2019 8:45 PM
To: [email-masked]
Cc: pce-chairs <[email-masked]>
Subject: [Pce] WG adoption poll for draft-sivabalan-pce-binding-label-sid-07

Hi WG,

Thanks!
Dhruv (for the chairs)

---

From: Dhruv Dhody <[email-masked]>
Date: Wed, 21 Aug 2019 14:25:41 +0530

Hi Boris,

[As a WG participant]

> But what about our traditional distributed case, for example, how Gateway Node 1 (Fig.1 in the draft) would understand that he should allocate a Binding SID towards PCE?

Currently, the draft says -

   A local policy or configuration at the PCC
   SHOULD dictate if the binding label/SID needs to be assigned.

Otherwise, PCE can trigger the allocation by sending a PCUpd message
with empty TLV as well. Note that this does not require PCECC
capability.

   In some cases, a stateful PCE can request the PCC to allocate a
   binding value.  It may do so by sending a PCUpd message containing an
   empty TE-PATH-BINDING TLV, i.e., no binding value is specified
   (making the length field of the TLV as 2).

> Should Gateway Node 1 analyze capabilities of Access node (Maximum SID depth) and make an assumption that it could need a Binding SID?

I doubt this could be automated without the help of PCE.

> IMO, we should think and try to propose some mechanism (besides relying on PCE central controller)  for distributed case to let PCC know that he should create Binding SID and report it to PCE.

So the question is if anything beyond local policy or configuration at
PCC needs to be done. I am not sure...

Thanks!
Dhruv

---

From: "Dongjie (Jimmy)" <[email-masked]>
Date: Tue, 27 Aug 2019 08:44:10 +0000

Yes, support the adoption. It provides an useful mechanism for the allocation and negotiation of binding SID.

Best regards,
Jie

---

From: "RAGHURAM, ASWATNARAYAN" <[email-masked]>
Date: Tue, 27 Aug 2019 20:28:27 +0000

Support this draft as it is very useful for service provider in bridging  between SR and RSVP-TE.

A.Raghuram
Lead Member of Technical Staff
Network Infrastructure and Services
AT&T Services, Inc.
200 S. Laurel Av, Room C5-2Z01, Middletown, NJ 07748
O 732.420.2471 | [email-masked]

This communication may contain information that is privileged, or confidential. If you are not the intended recipient, please note  FYI that any dissemination, distribution or copying of this communication is strictly prohibited.  Anyone who receives this message in error should notify the sender immediately by telephone or by return e-mail and delete it from his or her computer. 

> Should this draft be adopted by the PCE WG? Please state your reasons 
> - Why / Why not? What needs to be fixed before or after adoption? Are 
> you willing to work on this draft? Review comments should be posted to the list.
> 
> One of the chairs did a pre-adoption review [2] and authors posted a 
> new revision. Note that there are known implementations.
> 
> [1] 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__tools.ietf.org_ht
> ml_draft-2Dsivabalan-2Dpce-2Dbinding-2Dlabel-2Dsid-2D07&d=DwICAg&c=LFY
> Z-o9_HUMeMTSQicvjIg&r=QNToJ4byfiy_4vy6H7dTgAPqN3XciMGI3LRm7GcpRS0&m=Kq
> Mn1wqwY7Eaxx1ZB__8kR_NIFB-YPF_J6_fVBX8sKM&s=lInvKFODz7p3_viVv1E4OrtifH
> tEIqrtJoPX0I9LLzE&e= [2] 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__mailarchive.ietf.
> org_arch_msg_pce_oaBIRA9FnNsV6-2DJrKKRCdwtLysk&d=DwICAg&c=LFYZ-o9_HUMe
> MTSQicvjIg&r=QNToJ4byfiy_4vy6H7dTgAPqN3XciMGI3LRm7GcpRS0&m=KqMn1wqwY7E
> axx1ZB__8kR_NIFB-YPF_J6_fVBX8sKM&s=_4rAfNEGOgyC-0OePoS6C2GxtnwZPl_9ukV
> TvNXwfhs&e=
> 
> https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mail
> man_listinfo_pce&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=QNToJ4byfiy_4vy6H
> 7dTgAPqN3XciMGI3LRm7GcpRS0&m=KqMn1wqwY7Eaxx1ZB__8kR_NIFB-YPF_J6_fVBX8s
> KM&s=XMBuZE-BfoBu0lZz595FO3mQr8evE9hAu0SwvBZY9bQ&e=

_______________________________________________
Pce mailing list
[email-masked]
https://urldefense.proofpoint.com/v2/url?u=https-3A__www.ietf.org_mailman_listinfo_pce&d=DwICAg&c=LFYZ-o9_HUMeMTSQicvjIg&r=QNToJ4byfiy_4vy6H7dTgAPqN3XciMGI3LRm7GcpRS0&m=KqMn1wqwY7Eaxx1ZB__8kR_NIFB-YPF_J6_fVBX8sKM&s=XMBuZE-BfoBu0lZz595FO3mQr8evE9hAu0SwvBZY9bQ&e=

---

From: stefano previdi <[email-masked]>
Date: Sat, 31 Aug 2019 17:31:13 +0200

Hi,

as co-author, I do support the adoption of this draft for which we already have multiple implementations.

Thanks.
s.

> From: Dhruv Dhody <[email-masked]>
> Date: Tue, Aug 20, 2019 at 11:14 PM
> Subject: WG adoption poll for draft-sivabalan-pce-binding-label-sid-07
> To: <[email-masked]>