Subject: [Pce] Request for WG adoption of draft-li-pce-sr-path-segment-08

From: "Chengli (Cheng Li)" <[email-masked]>
Date: Mon, 19 Aug 2019 14:04:55 +0000

Hi WG and Chairs,

We just updated the draft-li-pce-sr-path-segment. Major modifications:

    * add Implementation Status
    * move SRv6 related text to appendix
    * add Security Considerations
    * add Manageability Considerations

Since the text is mature in this draft, we would like to ask for WG adoption for this draft (Though it has been waiting in WG adoption queue for a while.^-^)

If possible, we would like to request IANA early allocation for helping implementation. 

Comments are welcome! 

Many thanks,
Cheng

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Monday, August 19, 2019 9:54 PM
To: Rakesh Gandhi <[email-masked]>; Quan Xiong <[email-masked]>; Weiqiang Cheng <[email-masked]>; Mach Chen <[email-masked]>; Dongjie (Jimmy) <[email-masked]>; Mach Chen <[email-masked]>; Chengli (Cheng Li) <[email-masked]>; Lizhenbin <[email-masked]>
Subject: New Version Notification for draft-li-pce-sr-path-segment-08.txt

A new version of I-D, draft-li-pce-sr-path-segment-08.txt
has been successfully submitted by Cheng Li and posted to the IETF repository.

Name:		draft-li-pce-sr-path-segment
Revision:	08
Title:		Path Computation Element Communication Protocol (PCEP) Extension for Path Segment in Segment Routing (SR)
Document date:	2019-08-19
Group:		Individual Submission
Pages:		26
URL:            https://www.ietf.org/internet-drafts/draft-li-pce-sr-path-segment-08.txt
Status:         https://datatracker.ietf.org/doc/draft-li-pce-sr-path-segment/
Htmlized:       https://tools.ietf.org/html/draft-li-pce-sr-path-segment-08
Htmlized:       https://datatracker.ietf.org/doc/html/draft-li-pce-sr-path-segment
Diff:           https://www.ietf.org/rfcdiff?url2=draft-li-pce-sr-path-segment-08

Abstract:
   The Path Computation Element (PCE) provides path computation
   functions in support of traffic engineering in Multiprotocol Label
   Switching (MPLS) and Generalized MPLS (GMPLS) networks.

   The Source Packet Routing in Networking (SPRING) architecture
   describes how Segment Routing (SR) can be used to steer packets
   through an IPv6 or MPLS network using the source routing paradigm.  A
   Segment Routed Path can be derived from a variety of mechanisms,
   including an IGP Shortest Path Tree (SPT), explicit configuration, or
   a Path Computation Element (PCE).

   Path identification is needed for several use cases such as
   performance measurement in Segment Routing (SR) network.  This
   document specifies extensions to the Path Computation Element
   Communication Protocol (PCEP) to support requesting, replying,
   reporting and updating the Path Segment ID (Path SID) between PCEP
   speakers.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Dhruv Dhody <[email-masked]>
Date: Tue, 20 Aug 2019 10:42:31 +0530

Hi Cheng,

Same response as the other draft :)

Thanks for the update and including the implementation status. Your
request for early code point is noted (and will be handled post
adoption). We will take this into consideration as we process the
adoption queue.

WG,

Please do not wait for the adoption call to review drafts, provide
comments to the authors early.

Check wiki for latest status - https://trac.ietf.org/trac/pce/wiki/WikiStart

Thanks!
Dhruv