Subject: Re: [PCN] PCN updated charter

From: Lars Eggert <[email-masked]>
Date: Fri, 1 Dec 2006 15:24:46 -0800

On Nov 30, 2006, at 1:34, <[email-masked]>  
<[email-masked]> wrote:
> Perhaps stressing in the charter that the WG will consider the
> implications of the lower levels of ingress-egress aggregation on the
> marking mechanisms may address this issue?
>
> <Anna end>
>
> [phil start]
> either like this or as a separate deployment model would work for  
> me. I
> think the most important thing is the impact on the aggregation
> assumption, as anna mentions
> [phil end]

Could you provide a paragraph to add to the charter that would  
outline this a bit?

Lars

_______________________________________________
PCN mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/pcn

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Mon, 4 Dec 2006 10:49:35 +0100

Hi Lars

A cleaner way of identifying what are 
the goals and requirements on the PCN functionalities 
is to work on the following deployment models:
* Intserv of diffserv deployment model
* Application based deployment model 

Note that interests were expressed on the PCN mailing list on 
willing to work on the application based deployment model.

Best regards,
Georgios

> -----Original Message-----
> From: Lars Eggert [mailto:[email-masked]] 
> Sent: zaterdag 2 december 2006 0:25
> To: [email-masked]
> Subject: Re: [PCN] PCN updated charter
> 
> > either like this or as a separate deployment model would 
> work for me. 
> > I think the most important thing is the impact on the aggregation 
> > assumption, as anna mentions [phil end]
> 
> Could you provide a paragraph to add to the charter that 
> would outline this a bit?
> 
> Lars
> 
>

---

From: Xiaoming Fu <[email-masked]>
Date: Tue, 05 Dec 2006 19:04:57 +0100

Georgios,

Quick comments (sorry if I miscatch):
> * Application based deployment model 

IntServ/DiffServ is clear, but what do you mean by app-based deployment 
model?
Do you want to know how the application utilizes the PCN services/func, 
i.e., an API issue?

Xiaoming

---

From: "Kwok-Ho Chan" <[email-masked]>
Date: Tue, 05 Dec 2006 13:50:42 -0500

Xiaoming:
Yes to the first part of what you are indicating:
By "Application Deployment Model", we mean (as you indicated),
a deployment model on how applications may use the information provided
by the PCN mechanism.
This is in parallel to the "IntServ over DiffServ Deployment Model", which is
a deployment model on how IntServ over DiffServ mechanisms may use the
information provided by the PCN mechanism.

But we are not trying to specify (standardize) an API by the document 
we are creating.
We are seeing both the Application Control and the IntServ over 
DiffServ Deployment
Models as Informational Track documents.

Hope this answers your questions.
Thanks!
-- Kwok --

At 01:04 PM 12/5/2006, Xiaoming Fu wrote:
>>A cleaner way of identifying what are the goals and requirements on 
>>the PCN functionalities is to work on the following deployment models:
>IntServ/DiffServ is clear, but what do you mean by app-based deployment model?
>Do you want to know how the application utilizes the PCN 
>services/func, i.e., an API issue?
>
>Xiaoming
>

---

From: "Jozef Babiarz" <[email-masked]>
Date: Tue, 5 Dec 2006 15:28:54 -0500

Xiaoming: 

I would like to add to what Kwok wrote that: 
1./ The PCN WG needs to agree on a router marking behavior and encoding
that can be used if different deployment models.
2./ The two proposed deployment models would be used to test through
simulations and analysis that infect the selected marking behavior in
routers does work satisfactory for both.
  
Application-Controlled Admission and Preemption deployment model
addresses situations where pre-congestion information is conveyed via
ECN bits or possibility DSCP to the application and the application
controls admission of a new flow or should existing admitted flow be
terminated (preempted). In the first phase the WG will assume that the
application, routers and hosts (IP phones/gateways) are trusted but
later after rechartering the group would look at if that is not the
case. A SIP example of the Application-Controlled Admission deployment
model can be found in
http://www.ietf.org/internet-drafts/draft-babiarz-pcn-sip-cap-00.txt.
>From the PCN BOF, the suggestion that most agreed with was that the
SIP-Controlled Admission and Preemption deployment model be made more
generic with SIP as an example so that it could be applied to other
signalling protocols and not just SIP.

Hope this helps.

-----Original Message-----
From: Chan, Kwok-Ho (BL60:470) 
Sent: Tuesday, December 05, 2006 1:51 PM
To: Xiaoming Fu
Cc: 'Lars Eggert'; [email-masked]
Subject: Re: [PCN] Regarding application based deployment model

Xiaoming:
This is in parallel to the "IntServ over DiffServ Deployment Model",
which is

model?

---

From: Xiaoming Fu <[email-masked]>
Date: Wed, 06 Dec 2006 10:47:21 +0100

Jozef and Kwok,

This sounds reasonable to me. I think this is useful work.

Cheers,
Xiaoming