Subject: [PCN] Admission control for SM/CL

From: Michael Menth <[email-masked]>
Date: Thu, 03 Mar 2011 16:23:13 +0100

Hi all,

if IEAs do not carry any traffic, there is no appropriate PCN feedback. In
such a case admission requests must be admitted. This makes SM/CL
prone to overadmission when the average number of flows per IEA is low.
I feel that we should do something against that. There is a rather simple
solution.

Let DMI be the duration of a measurement interval. An ingress node should
send a probe/hello packet towards an egress node if it has not sent another
packet to that node for DMI/n time (n>=1).

This modification avoids that measured PCN rates are zero and so the 
decision
point always gets a meaningful indication about the pre-congestion state of
an IEA-specific path. For CL, n=1 is sufficient while SM requires about 
n=10 or
n=20 to work well. Let DMI=200 ms, then the additional traffic rate per 
IEA is
at most 1.3 kbit/s for CL and 26 kbit/s for SM. This seems to be a 
lightweight
improvement for CL, while the overhead is larger for SM.

SM does not only work well in case of empty IEAs but also for IEAs with only
one or two flows. There is a probability that SM admits new flows even 
in the
presence of pre-congestion as only a small fraction of PCN traffic is
re-marked. The presented mechanism also helps SM to work better also in 
these
cases at the expense of some more overhead.

I'd like to hear opinions about this feature and whether we should 
include it
in the current drafts.

Best wishes,

     Michael

-- 
Prof. Dr. habil. Michael Menth
University of Tuebingen
Faculty of Science
Department of Computer Science
Chair of Communication Networks
Sand 13, 72076 Tuebingen, Germany
phone: (+49)-7071/29-70505
fax: (+49)-7071/29-5220
mailto:[email-masked]
http://www-kn.informatik.uni-tuebingen.de

---

From: Tom Taylor <[email-masked]>
Date: Thu, 3 Mar 2011 10:55:55 -0500

I would prefer that these changes be documented in new drafts that 
update the existing ones.

---

From: Michael Menth <[email-masked]>
Date: Thu, 03 Mar 2011 20:26:08 +0100

The first question is actually whether what I have proposed is desired 
and useful to be standardized?

---

From: <[email-masked]>
Date: Fri, 4 Mar 2011 09:11:40 +0000

I agree with Tom. At this stage the WG objective is surely to finish the current set of docs - it is proving hard to get enough effort to do this anyway. We shouldn't add a new feature to the current docs (as, apart from anything else, we have to consider it against alternatives, such as Daisuke's suggestion, and against AD concerns whenever probing has been mentioned in the past)/ (technically i think both your & Daisuke's suggestions are reasonable)

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Tom Taylor
Sent: 03 March 2011 15:56
To: Michael Menth
Cc: [email-masked]
Subject: Re: [PCN] Admission control for SM/CL

> I'd like to hear opinions about this feature and whether we should
_______________________________________________
PCN mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/pcn

---

From: "Georgios Karagiannis" <[email-masked]>
Date: Fri, 4 Mar 2011 10:26:24 +0100

Hi all

I also agree with Phil and Tom on this issue!

Best regards,
Georgios 

> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: vrijdag 4 maart 2011 10:12
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> I agree with Tom. At this stage the WG objective is surely to 
> finish the current set of docs - it is proving hard to get 
> enough effort to do this anyway. We shouldn't add a new 
> feature to the current docs (as, apart from anything else, we 
> have to consider it against alternatives, such as Daisuke's 
> suggestion, and against AD concerns whenever probing has been 
> mentioned in the past)/ (technically i think both your & 
> Daisuke's suggestions are reasonable)
> 
> I would prefer that these changes be documented in new drafts 
> that update the existing ones.
> 
> > if IEAs do not carry any traffic, there is no appropriate PCN 
> > feedback. In such a case admission requests must be admitted. This 
> > makes SM/CL prone to overadmission when the average number 
> of flows per IEA is low.
> > I feel that we should do something against that. There is a rather 
> > simple solution.
> >
> > Let DMI be the duration of a measurement interval. An ingress node 
> > should send a probe/hello packet towards an egress node if 
> it has not 
> > sent another packet to that node for DMI/n time (n>=1).
> >
> > decision point always gets a meaningful indication about the 
> > pre-congestion state of an IEA-specific path. For CL, n=1 is 
> > sufficient while SM requires about n=10 or n=20 to work well. Let 
> > DMI=200 ms, then the additional traffic rate per IEA is at most 1.3 
> > kbit/s for CL and 26 kbit/s for SM. This seems to be a lightweight 
> > SM does not only work well in case of empty IEAs but also for IEAs 
> > with only one or two flows. There is a probability that SM 
> admits new 
> > flows even in the presence of pre-congestion as only a 
> small fraction 
> > of PCN traffic is re-marked. The presented mechanism also 
> helps SM to 
> > work better also in these cases at the expense of some more 
> overhead.
> >
> > include it in the current drafts.
> >
> > Best wishes,
> >
> > Michael
> >

---

From: "Toby Moncaster" <[email-masked]>
Date: Fri, 4 Mar 2011 09:37:21 -0000

Michael,

I think we definitely need to focus all our energy on completing the work we
already have in progress. Longer term and iff there is good evidence that
the scenario you describe is likely to happen, we can then try and create an
extension document.

My personal preference for a solution would be something like Daisuke
describes where you strictly limit how much traffic is allowed to enter an
empty IEA until you have received useful PCN feedback. That would be in
keeping with the approach adopted by most TCPs and avoids the need to create
extra traffic...

Toby

> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> [email-masked]
> Sent: 04 March 2011 09:12
> I agree with Tom. At this stage the WG objective is surely to finish
> the current set of docs - it is proving hard to get enough effort to do
> this anyway. We shouldn't add a new feature to the current docs (as,
> apart from anything else, we have to consider it against alternatives,
> such as Daisuke's suggestion, and against AD concerns whenever probing
> has been mentioned in the past)/ (technically i think both your &
> feedback. In
> simple
> should
> with
> > only

---

From: Michael Menth <[email-masked]>
Date: Tue, 29 Mar 2011 14:27:43 +0200

Hi all,

I would like to bring that email to your attention again. A simple 
addition to CL/SM can significantly improve its performance:
See Fig. 11b in 
https://atlas2.informatik.uni-tuebingen.de/menth/Menth08-Sub-8.pdf

Best wishes,

     Michael

Am 03.03.2011 16:23, schrieb Michael Menth:
> an IEA-specific path. For CL, n=1 is sufficient while SM requires 
> about n=10 or
> n=20 to work well. Let DMI=200 ms, then the additional traffic rate 
> per IEA is
> with only
> re-marked. The presented mechanism also helps SM to work better also 
> in these