Subject: [pcp] #55: MAP support mandatory or optional

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 07 Jun 2011 01:06:58 -0000

#55: MAP support mandatory or optional

 Paul:
 > - There is no discussion about levels of conformance.  There's some
 > discussion about particular options being optional (e.g. THIRD_PARTY
 > not supported in certain deployment scenarios), but no overall
 > statement of what features must be supported by all conformant
 > implementations.  e.g. If I had a small embedded server that supported
 > MAP opcodes but not PEER, would it be conformant?

 Dan:
 > Nobody has initiated discussion or provided a straw-man on conformance
 > levels.  What do we want?  Myself, if there is any chance of a wireless
 > devices (which is approximately 100% chance), PEER needs to be supported
 > because it allows the wireless device to optimize its NAT keepalive
 > traffic.  But, to me, MAP doesn't need to necessarily be supported.

 Alain:
 > I think we should stay away from conformance levels. This gets
 > very complex, very quickly, and does not help interoperability.
 > The argument that MAP or PEER are only useful in a wireline or
 > wireless scenario seams a bit weak to me.
 > We are now seeing fixed wireless environment... Which profile
 > should they have?
 >
 > I believe that unless there is a very strong reason against,
 > we should keep MAP & PEER functionality.

 Dave (from issue #52):
 > Should probably note [the hole created by MAP] is wider than
 > what can be done with a TCP SYN and hence in some environments
 > may be considered a security issue. It should probably be legal
 > for such deployments to have a PCP server accept PEER but not
 > MAP. This allows some uses (Reducing NAT Keepalive Messages,
 > Restoring Lost Implicit TCP Dynamic Mapping State) but not
 > others (Operating a Server).

 (Dave's comment was about configuration, whereas Paul's comment was
 specifically about implementation support.)

-- 
----------------------------------------------+-----------------------------
 Reporter:  Paul Selkirk <pselkirk@…          |       Owner:  draft-ietf-pcp-base@…             
     Type:  defect                            |      Status:  new                               
 Priority:  major                             |   Milestone:                                    
Component:  base                              |     Version:                                    
 Severity:  -                                 |    Keywords:                                    
----------------------------------------------+-----------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/55>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 07 Jun 2011 13:51:51 -0000

Comment(by dthaler@…):

 Stuart:
 > 14. Is FILTER Option mandatory to implement? How many filters per
 mapping?

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/55#comment:1>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 07 Jun 2011 14:22:52 -0000

Comment(by dthaler@…):

 6/7/2011: Alain, Stuart - MAP should be mandatory to implement, but
 optional to configure/enable.
 Francis, Paul - ok if PEER is mandatory.

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/55#comment:2>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 07 Jun 2011 14:31:14 -0000

Comment(by dthaler@…):

 FILTER support:
 Francis - mandatory to implement, with unspecified # required to support
 Stuart - no preference, since app has to do checks anyway but beneficial
 to avoid BW usage.  Mandatory to implement & support at least 1 filter.
 Alain - maybe a "few"?
 Francis - "not zero"
 Francis - FTP ALG would want 1 address, any port, in filter
 Paul - 1 is something we can justify

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/55#comment:3>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Wed, 22 Jun 2011 15:33:56 -0000

Changes (by cheshire@…):

  * status:  new => closed
  * resolution:  => fixed

Comment:

 Added text saying that support of both MAP and PEER is mandatory.

-- 
----------------------------------------------+-----------------------------
 Reporter:  Paul Selkirk <pselkirk@…          |        Owner:  draft-ietf-pcp-base@…             
     Type:  defect                            |       Status:  closed                            
 Priority:  major                             |    Milestone:                                    
Component:  base                              |      Version:                                    
 Severity:  -                                 |   Resolution:  fixed                             
 Keywords:                                    |  
----------------------------------------------+-----------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/55#comment:4>
pcp <http://tools.ietf.org/pcp/>