Subject: [pcp] #50: 128 bit PCP Client's IP Address and Suggested External IP Address fields

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 07 Jun 2011 00:06:32 -0000

#50: 128 bit PCP Client's IP Address and Suggested External IP Address fields

 Section 5.1:
 > PCP Client's IP Address:  The IP address of the PCP client, from the
 >     PCP client's perspective.  If IPv4, only the first 32 bits are
 >     used, the other bits MUST be set to 0.

 Section 5.2:
 > PCP Client's IP Address:  The IP address of the PCP client,
 >    PCP server's perspective.  If IPv4, only the first 32 bits are
 >    used, the other bits MUST be set to 0.

 > Suggested External IP Address:  always 128 reserved bits.  If an IPv4
 >    address, it is placed into the first 32 bits and the other 96 >
 MUST be 0.

 Why not use IPv4-mapped format?  That might make some code easier (e.g.,
 in a tcpdump parser) since the field interpretation is then independent of
 other things, and you can never confuse IPv4 with IPv6.

-- 
-----------------------------------+----------------------------------------
 Reporter:  dthaler@…              |       Owner:  draft-ietf-pcp-base@…             
     Type:  enhancement            |      Status:  new                               
 Priority:  minor                  |   Milestone:                                    
Component:  base                   |     Version:                                    
 Severity:  Active WG Document     |    Keywords:                                    
-----------------------------------+----------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/50>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 07 Jun 2011 13:50:05 -0000

Changes (by dthaler@…):

  * priority:  minor => major

Comment:

 Stuart Cheshire wrote:
 > 2. Why are some IP address fields "always 128 bits", and others are "32
 or 128
 > bits"? Can we make this consistent?
 >
 > 3. Where a 128-bit IP address field contains an IPv4 address, we need to
 ensure
 > that it can't inadvertently look like a valid IPv6 address as well as
 being a
 > zero-padded IPv4 address.

 Priority:  major                  |   Milestone:                                    

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/50#comment:1>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 07 Jun 2011 16:01:13 -0000

Changes (by dthaler@…):

  * type:  enhancement => defect

Comment:

 Dan - make all address fields 128 bits, rather than mixing variable length
 & fixed length
 Alain - 6PE also uses IPv4 mapped addresses to denote IPv4.

 Strawman: remove address family field, just use IPv4 mapped prefix to
 denote it's an IPv4 address.  Consistent with 6PE precedent.

     Type:  defect                 |      Status:  new                               

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/50#comment:2>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Wed, 22 Jun 2011 15:24:25 -0000

Changes (by cheshire@…):

  * status:  new => closed
  * resolution:  => fixed

Comment:

 Made all address fields fixed-size 128-bit IP fields

-- 
-----------------------------------+----------------------------------------
 Reporter:  dthaler@…              |        Owner:  draft-ietf-pcp-base@…             
     Type:  defect                 |       Status:  closed                            
 Priority:  major                  |    Milestone:                                    
Component:  base                   |      Version:                                    
 Severity:  Active WG Document     |   Resolution:  fixed                             
 Keywords:                         |  
-----------------------------------+----------------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/50#comment:3>
pcp <http://tools.ietf.org/pcp/>