Subject: [pcp] #54: PEER creating mappings

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 07 Jun 2011 00:54:50 -0000

#54: PEER creating mappings

 I'm not happy with the way PEER has evolved, to where it can create
 mappings.  It's heading in the direction of making MAP a special case
 of PEER (with remote port=0, remote peer=0 as wildcards).  I also
 don't think the 7.3 use case is compelling enough to justify the added
 complexity in the protocol (or even the suggested added complexity in
 the client).

-- 
---------------------------------------------+------------------------------
 Reporter:  Paul Selkirk <pselkirk@…>        |       Owner:  draft-ietf-pcp-base@…             
     Type:  defect                           |      Status:  new                               
 Priority:  major                            |   Milestone:                                    
Component:  base                             |     Version:                                    
 Severity:  Active WG Document               |    Keywords:                                    
---------------------------------------------+------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/54>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 07 Jun 2011 00:55:21 -0000

Comment(by dthaler@…):

 This seems closely related to issue #51.

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/54#comment:1>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Tue, 07 Jun 2011 14:59:25 -0000

Comment(by dthaler@…):

 See also Q3 in issue #51.

 7 June 2011:
 Stuart - allow PEER to recreate lost state.  Just does what a SYN would
 do.
 Francis - would be ok not allowing PEER to create state.
 Dan, Dave - allow PEER to recreate lost state.   PCP client state is its
 TCP state.
 Alain - this little feature gives us a lot, in favor of it.
 Francis - how do you get suggested external port?
 Stuart - not in TCP state, PCP client has to remember it from the previous
 PEER request, and store it.   Need to make pseudocode show this.

 Consensus to retain use, update pseudocode, and update sentence quoted in
 Q3 of #51.

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/54#comment:2>
pcp <http://tools.ietf.org/pcp/>

---

From: "pcp issue tracker" <[email-masked]>
Date: Wed, 22 Jun 2011 16:38:09 -0000

Changes (by cheshire@…):

  * status:  new => closed
  * resolution:  => fixed

Comment:

 Added text explaining how to set the External IP Address and Port fields
 in a PEER request

-- 
---------------------------------------------+------------------------------
 Reporter:  Paul Selkirk <pselkirk@…>        |        Owner:  draft-ietf-pcp-base@…             
     Type:  defect                           |       Status:  closed                            
 Priority:  major                            |    Milestone:                                    
Component:  base                             |      Version:                                    
 Severity:  Active WG Document               |   Resolution:  fixed                             
 Keywords:                                   |  
---------------------------------------------+------------------------------

Ticket URL: <http://trac.tools.ietf.org/wg/pcp/trac/ticket/54#comment:3>
pcp <http://tools.ietf.org/pcp/>