Subject: [pcp] Mandatory OPTIONS

From: <[email-masked]>
Date: Wed, 21 Sep 2011 16:27:11 +0000

Dear all,

In Chapter "5.3. Options" of the PCP I-D, it says:

Option Code: 8 bits. Its highest bit is the "O" bit and indicates
if this Option is mandatory (0) or optional (1) to process.

What does it mean:

1.        E.g. if I want to send a THIRD_PARTY option, which "Number" is 4 and I want it to be optional, should I send 132 (128 + 4) at the Option code? or

2.       Any Option which "Number" is higher than 128 is, by definition, optional, while those which "Number" is smaller than 128 is, by definition, mandatory?

If the correct case is the number "2", then, I think one way of making it clearer is using the term "Option Code" instead of "Number" at the Option descriptions.

Best Regards,

----
Felipe Miranda Costa
INdT - Nokia Institute of Technology
Network Technologies
+55-92-2126-1045

---

From: Francis Dupont <[email-masked]>
Date: Wed, 21 Sep 2011 19:37:39 +0200

In your previous mail you wrote:

   2.  Any Option which "Number" is higher than 128 is, by definition,
   optional, while those which "Number" is smaller than 128 is, by
   definition, mandatory?
   
=> this one with "Code" in place of "Number" even it makes "opcode"
a bit ambiguous...

Regards

[email-masked]