Subject: [pcp] Deleting mappings

From: <[email-masked]>
Date: Tue, 6 Sep 2011 21:27:46 +0000

Dear all,

I was reading the I-D v13 and saw at the last paragraph of page 36 that:

"If the PCP client attempts to delete an implicit dynamic
mapping, the PCP server deletes the mapping and filtering and
responds with the SUCCESS result code."

There was an e-mail by Francis Dupont on the 27th of July summarizing the notes from the July 26th webex meeting (that happened after the publication of the I-D v13), where he stated that:

"- there was a discuss about implicit deletes, so current proposal is:

   * if we decide to provide implicit dynamic mapping deletion, it will be

    by a PEER with lifetime zero
"

So, my question is: does a MAP with lifetime = 0 delete any kind of dynamic mappings (implicit and explicit) or just explicit dynamic mappings?

Best Regards,

----
Felipe Miranda Costa

---

From: "Thomas Zhang(Zhongjian)" <[email-masked]>
Date: Wed, 07 Sep 2011 02:53:09 +0000

Dear Felipe

In the older vesion of PCP-base, implicit dynamic mappings will only be refreshed or created( when freshed mapping is not exist).
So a MAP with lifetime = 0 will only delete explicit dynamic mappings

Best regards

Yours Thomas

________________________________
发件人: [email-masked] [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2011年9月7日 5:28
收件人: [email-masked]
主题: [pcp] Deleting mappings

Dear all,

“If the PCP client attempts to delete an implicit dynamic
mapping, the PCP server deletes the mapping and filtering and
responds with the SUCCESS result code.”

“- there was a discuss about implicit deletes, so current proposal is:

”

Best Regards,

----
Felipe Miranda Costa

---

From: Francis Dupont <[email-masked]>
Date: Wed, 07 Sep 2011 08:25:32 +0200

In your previous mail you wrote:

   
=> and at the last IETF we decided to not provide a way to delete
dynamic mapping as no use of this was found.

   So, my question is: does a MAP with lifetime = 0 delete any kind of
   dynamic mappings (implicit and explicit) or just explicit dynamic
   mappings?
   
=> just explicit dynamic mappings and in particular *not* static mappings.

Thanks

[email-masked]

PS: as far as I know there is no text about the detailed
behavior of a lifetime 0 PEER request...