Subject: Re: [pcp] PANA implementatinos to consider

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 13 Sep 2012 18:26:11 +0300

Hi Sam, 

I wonder why you care about PCP at all. You are neither someone who ships operating systems nor someone who provides network equipment (like a NAT or a firewall). 

You seem to be willing to spend a lot of time on that topic and I am curious where this interest comes from. 

Ciao
Hannes

On Sep 13, 2012, at 5:57 PM, Sam Hartman wrote:

> 
> 
> hi.
> So, as I mentioned  earlier I'm either in the camp of strongly
> preferring PCP-specific authentication or in the camp of not caring much
> at all.
> 
> I'd kind of like to find out which camp I'm in by the 21st.
> 
> My nervousness is about implementation complexity. I would like to see
> PCP authentication be something that can easily be implemented with
> open-source libraries. I know how to do that if we use an EAP library
> directly. I've managed projects doing something quite similar and I
> understand the implementation complexity.
> 
> Would people familiar with PANA implementation be willing to suggest
> which implementation I should look at? I'd prefer to look at one, but if
> there's disagreement I'd be happy to look at two.
> I'm sure you've done your analysis on this point but I'll feel more
> comfortable if I do my own.
> 
> I'll be happy to share my conclusions as I suspect that there are other
> WG participants who care about implementation complexity.
> 
> If there are open-source PCP servers I'd be happy to glance at those
> just to see how things like memory management, event loop and state
> management line up.
> 
> --Sam
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: Sam Hartman <[email-masked]>
Date: Thu, 13 Sep 2012 11:47:35 -0400

>>>>> "Hannes" == Hannes Tschofenig <[email-masked]> writes:
Hi Hannes.
At one level, I'm confused why it matters. In general within the IETF we
accept help where we can find it.
However your question is easy to answer so I'm happy to do so.

    Hannes> Hi Sam, I wonder why you care about PCP at all. You are
    Hannes> neither someone who ships operating systems nor someone who
    Hannes> provides network equipment (like a NAT or a firewall).

Hi.
draft-ietf-pcp-authentication-00 is missing a funding acknowledgment.
Unfortunately, for silly contractual reasons, we'll need to wait until
the next version of the draft to add that.
It should be obvious from the  author list of
draft-ietf-pcp-authentication who Painless Security's client is in this
instance.

More generally, Painless Security has worked on NAT and firewall
implementations and has worked with OS vendors such as Debian and Ubuntu
to maintain software in their operating systems.

We tend to be quite interested in areas where  we are funded by a client
or where we are doing ongoing product development ourselves.

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 13 Sep 2012 18:53:54 +0300

Thanks, Sam. Makes sense.

---

From: "Dan Wing" <[email-masked]>
Date: Thu, 13 Sep 2012 09:42:37 -0700

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Hannes Tschofenig
> Sent: Thursday, September 13, 2012 8:26 AM
> To: Sam Hartman
> Cc: [email-masked]
> Subject: Re: [pcp] PANA implementatinos to consider
> 
> Hi Sam,
> 
> I wonder why you care about PCP at all. You are neither someone who
> ships operating systems nor someone who provides network equipment
> (like a NAT or a firewall).
>

Curiosity is fine, and it was nice of Sam to answer.  However, I hope
the IETF continues to welcome technical input, even if the person has
no "skin in the game" or cannot publicly explain their funding source.

-d

---

From: Hannes Tschofenig <[email-masked]>
Date: Thu, 13 Sep 2012 21:03:17 +0300

Hey Dan, 

On Sep 13, 2012, at 7:42 PM, Dan Wing wrote:

> However, I hope

Definitely. I would love to see more persons involved who are purely driven by their desire to make the Internet work better. 

(I fear we get a bit off topic but I had to respond to avoid creating a wrong impression.)

Ciao
Hannes

PS: Just in case that this statement above gets misinterpreted; I am not saying that those who deploy technology are not welcome either...