Subject: [pcp] WG Call for Adoption: draft-maglione-pcp-radius-ext-07

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Fri, 26 Apr 2013 14:12:10 +0000

Hello,

This email starts a 2-week consensus call on adopting "RADIUS Extensions
for Port Control Protocol (PCP)" as a WG item.

     Title     : RADIUS Extensions for Port Control Protocol (PCP)
     Author(s) : R. Maglione et al
     Filename  : draft-maglione-pcp-radius-ext-07
     URL       : 
http://tools.ietf.org/html/draft-maglione-pcp-radius-ext-07

Please read the current revision and state you opinion either for or
against adoption (and with reasoning why) in the mailing list.

The call for adoption ends 10th May 2013.

Thanks,

---

From: Dean cheng <[email-masked]>
Date: Fri, 26 Apr 2013 15:20:45 +0000

For (as a co-author)

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Reinaldo Penno (repenno)
> Sent: Friday, April 26, 2013 7:12 AM
> To: [email-masked]
> Subject: [pcp] WG Call for Adoption: draft-maglione-pcp-radius-ext-07
> 
> Hello,
> 
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: <[email-masked]>
Date: Tue, 30 Apr 2013 11:27:19 +0200

Support

>-----Message d'origine-----
>De : [email-masked] [mailto:[email-masked]] De la part de
>Reinaldo Penno (repenno)
>Envoyé : vendredi 26 avril 2013 16:12
>À : [email-masked]
>Objet : [pcp] WG Call for Adoption: draft-maglione-pcp-radius-ext-07
>
>Hello,
>

---

From: Tassos Chatzithomaoglou <[email-masked]>
Date: Tue, 30 Apr 2013 13:30:02 +0300

just had a quick look and i have a question:

If i understand correctly the packet format, you can't have a PCP server for IPv4 and a different PCP server for IPv6, unless the same DNS name is used; am i right?
Generally, how do you differentiate between v4 and v6 ones when the Dual-Stack context is used?
Is this left to the NAS to decide (based on what?) which one to pass to the co-located DHCPv4/v6 servers, or does the NAS pass everything to both DHCP servers?

...and some minor ones...
>    In such environment, PCP server's name can be configured on a RADIUS
>    server, which then passes the information to a NAS that co-locates
>    with the DHCPv4/DHCPv6 server, which in turn populates the location
>    of the PCP server.

Shouldn't this be the opposite? DHCP server that co-locates with the NAS.

> When the co-located DHCPv6 server receives a DHCPv6 message
>    containing the PCP Server Option, it SHALL use the name returned in
>    the RADIUS attribute as defined in this memo to populate the DHCPv6
>    PCP Server option defined in [I-D.ietf-pcp-dhcp <http://tools.ietf.org/html/draft-maglione-pcp-radius-ext-07#ref-I-D.ietf-pcp-dhcp>].

When the co-located DHCPv6 server receives a DHCPv6 message from a client containing the PCP Server Option...

> The scenario with PPP Session and IPv4 only connectivity does not
>    require DHCPv4: the whole configuration of the client is performed by
>    PPP.  This case is out of scope of this document because in order to
>    complete the configuration of the PCP client a new PPP IPC option
>    would be required.

...a new PPP IPCP option..

--
Tassos