Subject: [pcp] WG Call for Adoption: The Port Control Protocol in Dual-Stack Lite environments

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Fri, 10 May 2013 11:03:42 +0000

Hello,

This email starts a 2-week consensus call on adopting

     Title     : The Port Control Protocol in Dual-Stack Lite environments
     Author(s) : F. Dupont t al.
     URL       : http://tools.ietf.org/html/draft-dupont-pcp-dslite-05

Please read the current revision and state you opinion either for or
against adoption (and with reasoning why) in the mailing list.

The call for adoption ends 24th May 2013.

Thanks,

Reinaldo

---

From: "Zhouqian (Cathy)" <[email-masked]>
Date: Wed, 15 May 2013 00:41:23 +0000

Support adoption of this document.

Best Regards,
Cathy

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Reinaldo Penno (repenno)
> Sent: Friday, May 10, 2013 7:04 PM
> To: [email-masked]
> Subject: [pcp] WG Call for Adoption: The Port Control Protocol in Dual-Stack
> Lite environments
> 
> Hello,
> 
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: "Will Liu (Shucheng)" <[email-masked]>
Date: Wed, 15 May 2013 01:45:13 +0000

Folks,

I have read draft-dupont-pcp-dslite-05 and also believe the plain mode is a good choice for both design and security considerations, though actually each mode has its advantages respectively. I support the adoption of this document as a WG document.

Cheers,
Will

---

From: Tassos Chatzithomaoglou <[email-masked]>
Date: Wed, 15 May 2013 14:09:18 +0300

Support, although it's not very clear to me why PCP proxy is the only option examined/described.
Do we assume that all applications and end systems will support PCP?
Can't B4 be just a PCP client, taking instructions for mappings through cli or gui?

--
Tassos

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Thu, 16 May 2013 11:31:12 +0000

>Can't B4 be just a PCP client, taking instructions for mappings through

Good point, this is not covered in the document. It might also need tweaks
in the security section.

---

From: Qiong <[email-masked]>
Date: Tue, 21 May 2013 16:54:19 +0800

Hi all,

I support the adoption.

This draft is good start, just have one comment:
I think the encapsulation mode is also very important when AFTR is deployed
using anycast address and PCP server is co-located in AFTR. In
encapsulation mode, it would be easy to guarantee that the same AFTR will
be picked for both PCP traffic and subsequent data traffic. So I prefer to
move encapsulation mode in the main body.

Best wishes
Qiong

On Fri, May 10, 2013 at 7:03 PM, Reinaldo Penno (repenno) <[email-masked]

-- 
==============================================
Qiong Sun
China Telecom Beijing Research Institude

Open source code:
lightweight 4over6: *http://sourceforge.net/projects/laft6/*
PCP-natcoord:* http://sourceforge.net/projects/pcpportsetdemo/ *
===============================================

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Tue, 21 May 2013 08:59:06 +0000

For those supporting this draft, are you thinking (or supporting) DS-Lite or actually Lw4o6?  I would like to make that distinction.

Because if you want this draft to work LW4o6 we need to understand changes and implications if any. I know, for example, the PORT SEt draft was originally targeted at Lw4o6, not DS-Lite.

From: Qiong <[email-masked]<mailto:[email-masked]>>
Date: Tue, 21 May 2013 16:54:19 +0800
To: Reinaldo Penno <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [pcp] WG Call for Adoption: The Port Control Protocol in Dual-Stack Lite environments

Hi all,

I support the adoption.

This draft is good start, just have one comment:
I think the encapsulation mode is also very important when AFTR is deployed using anycast address and PCP server is co-located in AFTR. In encapsulation mode, it would be easy to guarantee that the same AFTR will be picked for both PCP traffic and subsequent data traffic. So I prefer to move encapsulation mode in the main body.

Best wishes
Qiong

On Fri, May 10, 2013 at 7:03 PM, Reinaldo Penno (repenno) <[email-masked]<mailto:[email-masked]>> wrote:
Hello,

Thanks,

Reinaldo

_______________________________________________
pcp mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/pcp

Open source code:
lightweight 4over6: http://sourceforge.net/projects/laft6/
PCP-natcoord: http://sourceforge.net/projects/pcpportsetdemo/
===============================================

---

From: "[email-masked]" <[email-masked]>
Date: Tue, 21 May 2013 20:49:46 +0800

Dear Reinaldo，

My intention here is to support DS-Lite as we are also deploying dslite right now and I think this draft is also quite useful.

Best wishes
Qiong

Sent from my iPad

On 2013-5-21, at 16:59, "Reinaldo Penno (repenno)" <[email-masked]> wrote:

> From: Qiong <[email-masked]>
> To: Reinaldo Penno <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> On Fri, May 10, 2013 at 7:03 PM, Reinaldo Penno (repenno) <[email-masked]> wrote:
>> Hello,
>>