Subject: [pcp] I-D Action: draft-ietf-pcp-optimize-keepalives-03.txt

From: [email-masked]
Date: Thu, 14 Aug 2014 20:27:21 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the Port Control Protocol Working Group of the IETF.

        Title           : Optimizing NAT and Firewall Keepalives Using Port Control Protocol (PCP)
        Authors         : Tirumaleswar Reddy
                          Markus Isomaki
                          Dan Wing
                          Prashanth Patil
	Filename        : draft-ietf-pcp-optimize-keepalives-03.txt
	Pages           : 15
	Date            : 2014-08-14

Abstract:
   This document describes how Port Control Protocol is useful in
   reducing NAT and firewall keepalive messages for a variety of
   applications.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pcp-optimize-keepalives/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-pcp-optimize-keepalives-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-pcp-optimize-keepalives-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Reinaldo Penno <[email-masked]>
Date: Thu, 14 Aug 2014 22:21:23 -0700

At some point we worked on an alpha implementation of this draft so I 
would like to provide some comments...

Section 3.4

"

    If the application determines that all NATs and firewalls on its path
    to the Internet support PCP, it can start using PCP instead of its
    default keepalives to maintain the NAT/FW state"

What we found in practice is that even if all FW/NATs support PCP, they might give you different lifetime responses.

So, you might have, say, 3 mappings with lifetimes 3600s, 86000s and 240s. So, it would be good to show that even in this scenario the savings are significant.

So, let's suppose normally an application would need to send a single packet every 120s. So, in 24hrs 86400/120 = 720 packets. But in the case of
PCP you would need to refresh 3 mappings = 360 + 24 + 1 = 385 packets.

But one issue I see is that it seems to me you would also have to create mappings for the PCP traffic itself so that it can
traverse intermediate NAT so PCP Client can talk to 2nd, 3rd, PCP Servers. So, those mappings also need to be refreshed or recreated adding to the load.

How would the savings be if PCP Servers support PCP Proxy?

thanks,

Reinaldo

On 8/14/14 8:27 PM, [email-masked] wrote:
> _______________________________________________
> pcp mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/pcp

---

From: "Prashanth Patil (praspati)" <[email-masked]>
Date: Tue, 19 Aug 2014 09:50:50 +0000

Hi Reinaldo,
Please see inline <PRA>

From: "Reinaldo Penno (repenno)" <[email-masked]<mailto:[email-masked]>>
Organization: Cisco Systems, Inc.
Date: Friday, August 15, 2014 10:51 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [pcp] I-D Action: draft-ietf-pcp-optimize-keepalives-03.txt

At some point we worked on an alpha implementation of this draft so I would like to provide some comments...

Section 3.4

"

PRA: We'll include an example to illustrate savings with PCP.

PRA: In context of your example, savings with a PCP proxy should be considerable. A client will only communicate with the PCP proxy and receive a single mapping lifetime.

-Prashanth

thanks,

Reinaldo

On 8/14/14 8:27 PM, [email-masked]<mailto:[email-masked]> wrote:

Abstract:

_______________________________________________
pcp mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/pcp