Subject: Re: [pcp] Fwd: New Version Notification for draft-chen-pcp-authentication-sim-00.txt

From: GangChen <[email-masked]>
Date: Fri, 8 Aug 2014 15:02:25 +0800

2014-08-01 1:32 GMT+08:00, Tirumaleswar Reddy (tireddy) <[email-masked]>:
>> -----Original Message-----
>> From: GangChen [mailto:[email-masked]]
>> Sent: Wednesday, July 23, 2014 5:17 PM
>> To: Tirumaleswar Reddy (tireddy)
>> Cc: [email-masked]
>> Subject: Re: [pcp] Fwd: New Version Notification for draft-chen-pcp-
>> authentication-sim-00.txt
>>
>> 2014-07-21 22:17 GMT+08:00, Tirumaleswar Reddy (tireddy)
>> <[email-masked]>:
>> >> -----Original Message-----
>> >> From: GangChen [mailto:[email-masked]]
>> >> Sent: Friday, July 04, 2014 3:41 PM
>> >> To: [email-masked]
>> >> Subject: [pcp] Fwd: New Version Notification for
>> >> draft-chen-pcp-authentication-
>> >> sim-00.txt
>> >>
>> >> WG,
>> >>
>> >> I have submitted a draft to describe the consideration of PCP
>> >> authentication with (U)SIM support. The process is detailed in EAP
>> >> and GBA framework.
>> >
>> > Interesting draft. This solves the problem that for PCP authentication
>> > to work in Mobile networks, PCP client does not have use username and
>> > password but only use SIM credentials (EAP-SIM).  Other operators like
>> > Deutsche-Telekom are already using SIM authentication for ISP offered
>> > services (Slide 11
>> > http://www.gsma.com/personaldata/wp-content/uploads/2014/03/OpenID-
>> Con
>> > nect-at-Deutsche-Telekom-Torsten-Lodderstedt.pdf)
>>
>> Thank you for the comments. I would like to further highlight the
>> technical
>> advantage using GBA to PCP. The thought is to leverage the deployed GBA
>> infrastructure. AFAIK, GBA is indispensable to the mobile operators, who
>> like to
>> offer voice service in the LTE age. It's low-cost and lightweight
>> implementation
>> to the PCP server.(only one simply message extension makes it work, as
>> draft
>> proposed at Section 3).
>
> The other technique mentioned in the draft is using HTTP authentication and
> not EAP.
>
> 1. what is the need for this mechanism when EAP-SIM can be used ?

EAP requires layer 2 support. However, if a user directly use 3GPP
radio link, it can't support the EAP framework.

Gang

> 2. It deviates from REQ-6 of fate sharing
> http://tools.ietf.org/html/draft-reddy-pcp-auth-req-04 that was discussed in
> the WG sometime back.
>
> -Tiru
>
>>
>> BRs
>>
>> Gang
>>
>>
>> >
>> > -Tiru
>> >
>> >> Thank you for the comments in advance.
>> >>
>> >> Best Regards
>> >>
>> >> Gang
>> >>
>> >> ---------- Forwarded message ----------
>> >> From: [email-masked]
>> >> Date: Fri, 04 Jul 2014 03:03:05 -0700
>> >> Subject: New Version Notification for
>> >> draft-chen-pcp-authentication-sim-00.txt
>> >> To: Gang Chen <[email-masked]>
>> >>
>> >>
>> >> A new version of I-D, draft-chen-pcp-authentication-sim-00.txt
>> >> has been successfully submitted by Gang Chen and posted to the IETF
>> >> repository.
>> >>
>> >> Name:		draft-chen-pcp-authentication-sim
>> >> Revision:	00
>> >> Title:		(U)SIM based PCP Authentication
>> >> Document date:	2014-07-03
>> >> Group:		Individual Submission
>> >> Pages:		8
>> >> URL:
>> >> http://www.ietf.org/internet-drafts/draft-chen-pcp-authentication-sim
>> >> -00.txt
>> >> Status:
>> >> https://datatracker.ietf.org/doc/draft-chen-pcp-authentication-sim/
>> >> Htmlized:
>> >> http://tools.ietf.org/html/draft-chen-pcp-authentication-sim-00
>> >>
>> >>
>> >> Abstract:
>> >>    With (U)SIM support, PCP authentication could leverage the
>> >>    credentials stored in (U)SIM.  The document details PCP
>> >>    authentication considerations based on (U)SIM support.  The
>> >>    authentication procedures in EAP and GBA framework have been
>> >>    specifically elaborated.  In order to complete the process, new
>> >> code
>> >>    and option are also proposed.
>> >>
>> >>
>> >>
>> >>
>> >> Please note that it may take a couple of minutes from the time of
>> >> submission until the htmlized version and diff are available at
>> >> tools.ietf.org.
>> >>
>> >> The IETF Secretariat
>> >>
>> >
>> >
>

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Tue, 12 Aug 2014 08:22:16 +0000

> Sent: Tuesday, August 12, 2014 11:43 AM
> Hi Tiru,
> 2014-08-08 19:00 GMT+08:00, Tirumaleswar Reddy (tireddy)
> <[email-masked]>:
> >> Sent: Friday, August 08, 2014 12:32 PM
> >> >> Subject: Re: [pcp] Fwd: New Version Notification for
> >> >> draft-chen-pcp- authentication-sim-00.txt
> >> >>
> >> >> >> authentication with (U)SIM support. The process is detailed in
> >> >> >> EAP and GBA framework.
> >> >> >
> >> >> > Interesting draft. This solves the problem that for PCP
> >> >> > authentication to work in Mobile networks, PCP client does not
> >> >> > have use username and password but only use SIM credentials
> >> >> > (EAP-SIM).  Other operators like Deutsche-Telekom are already
> >> >> > using SIM authentication for ISP offered services (Slide 11
> >> >> technical advantage using GBA to PCP. The thought is to leverage
> >> >> the deployed GBA infrastructure. AFAIK, GBA is indispensable to
> >> >> the mobile operators, who like to offer voice service in the LTE
> >> >> age. It's low-cost and lightweight implementation to the PCP
> >> >> server.(only one simply message extension makes it work, as draft
> >> >> proposed at Section 3).
> >> >
> >> > The other technique mentioned in the draft is using HTTP
> >> > authentication
> >> and
> >> > not EAP.
> >> >
> > I don't see a problem. EAP-SIM will be exchanged over PCP i.e. EAP
> > messages will be sent in the EAP Payload option defined in PCP
> authentication draft.
> 
> The issue is EAP is out of 3GPP-access security architecture. Please refer to
> 33.401 which describes the security framework of 3GPP access, e.g. 3G, 4G.
> 
> EAP is normally used at non-3GPP access, you could refer to 33.402.
> It's applied to WLAN access.

The mechanism used for 3GPP-access could be quite different to the one used to authenticate to PCP server, it need not be the same. Can you please provide more technical details why mobile devices and PCP server cannot use EAP-SIM or some other EAP method over PCP to authenticate to the PCP server in the Mobile network ?

-Tiru

> >> > http://tools.ietf.org/html/draft-reddy-pcp-auth-req-04 that was
> >> > discussed
> >> in
> >> > the WG sometime back.
> >> >
> >> > -Tiru
> >> >
> >> >>
> >> >> BRs
> >> >>
> >> >> Gang
> >> >>
> >> >>
> >> >> >
> >> >> > -Tiru
> >> >> >
> >> >> >> has been successfully submitted by Gang Chen and posted to the
> >> >> >> IETF repository.
> >> >> >>
> >> >> >>    specifically elaborated.  In order to complete the process,
> >> >> >> new code
> >> >> >> Please note that it may take a couple of minutes from the time
> >> >> >> of submission until the htmlized version and diff are available
> >> >> >> at tools.ietf.org.
> >> >> >>
> >> >> >> The IETF Secretariat
> >> >> >>
> >> >> >
> >> >> >
> >> >
> >