Subject: [pcp] TR: I-D Action: draft-vinapamula-flow-ha-03.txt

From: <[email-masked]>
Date: Fri, 5 Sep 2014 06:05:40 +0000

Dear all,

This updated version takes into account the comments received during the interim meeting, particularly:

* the comment from Tiru about the mis-use of the option to help an attacker identify critical flows. 
* the comment raised by Stuart about PREFER_FAILURE. 

We do think this version is stable enough to consider wg adoption.

Cheers,
Med

-----Message d'origine-----
De : I-D-Announce [mailto:[email-masked]] De la part de [email-masked]
Envoyé : vendredi 5 septembre 2014 07:58
À : [email-masked]
Objet : I-D Action: draft-vinapamula-flow-ha-03.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.

        Title           : Application-Initiated Flow High Availability Awareness through PCP
        Authors         : Suresh Vinapamula
                          Senthil Sivakumar
                          Mohamed Boucadair
	Filename        : draft-vinapamula-flow-ha-03.txt
	Pages           : 9
	Date            : 2014-09-04

Abstract:
   This document specifies a mechanism for a host to signal via PCP
   which connections should be protected against network failures.
   These connections will be elected to be subject to high availability
   mechanisms enabled at the network side.

   This approach assumes that aplications/users have more visibility
   about sensitive connections rather than any heuristic that can be
   enabled at the network side to guess which connections should be
   secured.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-vinapamula-flow-ha/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-vinapamula-flow-ha-03

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-vinapamula-flow-ha-03

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
I-D-Announce mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i-d-announce
Internet-Draft directories: http://www.ietf.org/shadow.html
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "Tirumaleswar Reddy (tireddy)" <[email-masked]>
Date: Thu, 18 Sep 2014 04:39:48 +0000

Hi Med,

I think adding priority level will be useful to this draft. For example ISP can use priority level to identify and penalize low-priority flows during congestion. Conex WG in http://tools.ietf.org/html/draft-ietf-conex-mobile-04 explains that Mobile Networks are using DPI to identify dispensable flows for management of congestion. 

This enhancement will help solve the above problem without DPI (which will anyways not work with HTTP/2.0, Opportunistic security etc.)

-Tiru

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Friday, September 05, 2014 11:36 AM
> To: [email-masked]; [email-masked]; Tirumaleswar Reddy (tireddy)
> Subject: TR: I-D Action: draft-vinapamula-flow-ha-03.txt
> 
> Dear all,
> 
> De : I-D-Announce [mailto:[email-masked]] De la part de
> [email-masked] Envoyé : vendredi 5 septembre 2014 07:58 À : i-d-
> [email-masked] Objet : I-D Action: draft-vinapamula-flow-ha-03.txt
> 
> 
> Internet-Draft directories: http://www.ietf.org/shadow.html or
> ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: <[email-masked]>
Date: Thu, 18 Sep 2014 06:27:22 +0000

Hi Tiru,

There are two approaches to address this issue:
(1) consider a unified priority level: that is all flows associated with the option in the draft should be "processed" equally.
(2) add another level of granularity among flows that are associated with the option in this draft.

The current version of the I-D argues that adding another level of granularity to signal a priority level (i.e., approach (2)) may not be that helpful because applications will be tempted to systematically set the priority level to the highest value in order to increase the chance to have the corresponding flow check-pointed/protected. 

Wouldn't (1) be sufficient to address the case you mentioned in your message? 

BTW, do you think the draft should be updated to call out explicitly the case you are mentioning (use of the CHECKPOINT option as a trigger to other traffic management blocks than the HA module)?

Thank you.
Cheers,
Med

>De : Tirumaleswar Reddy (tireddy) [mailto:[email-masked]]
>Envoyé : jeudi 18 septembre 2014 06:40
>À : BOUCADAIR Mohamed IMT/OLN; [email-masked]; [email-masked]
>Objet : RE: I-D Action: draft-vinapamula-flow-ha-03.txt
>
>Hi Med,
>
>I think adding priority level will be useful to this draft. For example ISP
>can use priority level to identify and penalize low-priority flows during
>congestion. Conex WG in http://tools.ietf.org/html/draft-ietf-conex-mobile-
>04 explains that Mobile Networks are using DPI to identify dispensable
>flows for management of congestion.
>
>This enhancement will help solve the above problem without DPI (which will
>anyways not work with HTTP/2.0, Opportunistic security etc.)
>
>-Tiru
>
>> * the comment from Tiru about the mis-use of the option to help an
>attacker
>> identify critical flows.
>>         Title           : Application-Initiated Flow High Availability
>Awareness
>> through PCP