Subject: [PEPPERMINT] 2nd pass on PEPPERMINT charter.

From: "Richard Shockey" <[email-masked]>
Date: Thu, 7 Feb 2008 15:10:16 -0500

PROPOSED CHARTER FOR PEPPERMINT

The IETF has been working on various aspects of session-based Multimedia
Interconnection among administrative domains. In addition, the IETF has done
significant work on data exchanges among various network elements. 

ENUM is specifically chartered to develop protocols that involve the
translation of E.164 numbers to URI's.
 
SPEERMINT has been chartered to develop best current practices among
real-time application service providers and how such services interconnect
across administrative boundaries.

The PEPPERMINT work group is charted to define what data needs to be
exchanged among Multimedia administrative domains and how that data should
be structured provisioned and propagated. These protocols would be outside
the normal scope of establishing various forms of a SIP session. 

Data exchanges to facilitate session-based Multimedia Interconnection are
typically between various Client User Agents and Registries containing
mappings of phone numbers to URIs, policies surrounding admission to various
points of network interconnection and various types of trunk data.  In
addition, there is a specific need for redistribution of such Registry data
to various types of network databases.  

The working group will draw upon expert advice and ongoing consultation from
the ENUM, SPEERMINT and PROVREG working groups. The working group may also
reuse elements of RFC 4114, if possible.

The final work product(s) from this working group will utilize and be based
on XML documents and XML document exchanges.

PROPOSED GOALS AND MILESTONES

Requirements for Interconnection data exchanges.         Sept 08 

Provisioning of Interconnection data registries.         Nov 08

Provisioning of Interconnection data caches.             Feb 09 

Richard Shockey
Director, Member of the Technical Staff
NeuStar
46000 Center Oak Plaza - Sterling, VA 20166
PSTN Office +1 571.434.5651 
PSTN Mobile: +1 703.593.2683
<mailto:richard(at)shockey.us> 
<mailto:richard.shockey(at)neustar.biz>

_______________________________________________
PEPPERMINT mailing list
[email-masked]
http://www.ietf.org/mailman/listinfo/peppermint

---

From: David Schwartz <[email-masked]>
Date: Fri, 8 Feb 2008 03:35:42 +0200

comments inline...

> The PEPPERMINT work group is charted to define what data needs to be

Chartered not Charted
> to various types of network databases.

How about registry - registry (i.e registry data exchange/query)
> ______________________________________________________________________
> This email has been scanned by the MessageLabs Email Security System.
> For more information please visit http://www.messagelabs.com/email
> ______________________________________________________________________

---

From: "DRAGE, Keith \(Keith\)" <[email-masked]>
Date: Fri, 8 Feb 2008 12:02:42 +0100

Question: Is this work meant to cover all "administrative domains" or
only those above a certain size?

For example, will the results of this group be applicable to an
enterprise operator with a single IP-PBX with less than a 100 lines (or
equivalent functionality) and their relationship with a service
provider?

Regards

Keith 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Richard Shockey
> Sent: Thursday, February 07, 2008 8:10 PM
> To: [email-masked]
> Cc: 'Peterson, Jon'
> Subject: [PEPPERMINT] 2nd pass on PEPPERMINT charter.
> 
> The IETF has been working on various aspects of session-based 
> Multimedia Interconnection among administrative domains. In 
> addition, the IETF has done significant work on data 
> exchanges among various network elements. 
> 
> ENUM is specifically chartered to develop protocols that 
> involve the translation of E.164 numbers to URI's.
>  
> SPEERMINT has been chartered to develop best current 
> practices among real-time application service providers and 
> how such services interconnect across administrative boundaries.
> 
> The PEPPERMINT work group is charted to define what data 
> needs to be exchanged among Multimedia administrative domains 
> and how that data should be structured provisioned and 
> propagated. These protocols would be outside the normal scope 
> of establishing various forms of a SIP session. 
> 
> Data exchanges to facilitate session-based Multimedia 
> Interconnection are typically between various Client User 
> Agents and Registries containing mappings of phone numbers to 
> URIs, policies surrounding admission to various points of 
> network interconnection and various types of trunk data.  In 
> addition, there is a specific need for redistribution of such 
> Registry data to various types of network databases.  
> 
> The working group will draw upon expert advice and ongoing 
> consultation from the ENUM, SPEERMINT and PROVREG working 
> groups. The working group may also reuse elements of RFC 
> 4114, if possible.
> 
> The final work product(s) from this working group will 
> utilize and be based on XML documents and XML document exchanges.
>    
> 
> 46000 Center Oak Plaza - Sterling, VA 20166 PSTN Office +1 
> 571.434.5651 PSTN Mobile: +1 703.593.2683 
> <mailto:richard(at)shockey.us> <mailto:richard.shockey(at)neustar.biz>
> 
> 
> 
>

---

From: "Richard Shockey" <[email-masked]>
Date: Fri, 8 Feb 2008 09:24:20 -0500

Short answer YES... administrative domains are assumed to be of any
practical size ( which certainly include PBX systems ) so this provisioning
protocol could be used by PBX systems to provision ENUM systems with TN to
URI mappings, for instance either inter or intra domain or a service
provider or TN to URI peering relationships between service providers.

This is a excellent point and we can certainly clarify this in subsequent
charter iterations. 

>  From: DRAGE, Keith (Keith) [mailto:[email-masked]]
>  Sent: Friday, February 08, 2008 6:03 AM
>  To: Richard Shockey; [email-masked]
>  Cc: Peterson, Jon
>  Subject: RE: [PEPPERMINT] 2nd pass on PEPPERMINT charter.
>

---

From: Paul Erkkila <[email-masked]>
Date: Tue, 12 Feb 2008 15:03:47 -0500

> to various types of network databases.  

2 questions..

1. Would a service provider be considered a registry in this case? 
Making inter-provider data exchanges registry <=> registry as David 
commented?

2. Would the timing aspects of the exchange be important for the 
charter? (I'm new to this). Many of the exchanges done today for 
instance are "batch" mode file exchanges. Are we looking to cover that 
scenario or more real time efforts (or both...)?

For example in the PSTN world I might be able to instantly tell you that 
a block of numbers you are trying to claim was refused for some reason 
(it's mine for instance), that would be real time feedback. However not 
refusing a block of numbers would not be the same as me telling you that 
I've accepted it, and it is in fact now live and usable on my network.

-pee

---

From: "Richard Shockey" <[email-masked]>
Date: Fri, 15 Feb 2008 13:26:56 -0500

Apologies for the tardy reply .. in line ..

>  From: Paul Erkkila [mailto:[email-masked]]
>  Sent: Tuesday, February 12, 2008 3:04 PM
>  To: Richard Shockey
>  Cc: [email-masked]; 'Peterson, Jon'
>  Subject: Re: [PEPPERMINT] 2nd pass on PEPPERMINT charter.
>  
>  Richard Shockey wrote:
>  Interconnection are

Yes .. data exchanges could be either bilateral or multilateral between administrative domains as well as centralized registries.. 

>  scenario or more real time efforts (or both...)?

That is a well known issue and there will be more on this issue forthcoming. Bulk upload and realtime updates are presumed to be in scope. I have noted this in the next iteration of the charter.

>  
>  For example in the PSTN world I might be able to instantly tell you
>  that  a block of numbers you are trying to claim was refused for some reason
>  (it's mine for instance), that would be real time feedback. However
>  not  refusing a block of numbers would not be the same as me telling you
>  that  I've accepted it, and it is in fact now live and usable on my network.

Exactly ..