Subject: RE: Link Layer designers draft...

From: "Brooker, Ralph" <[email-masked]>
Date: Fri, 23 Jul 1999 12:44:36 -0500

"Other ways" in my mind includes both analytical and empirical methods for
relating packet loss probability to raw link quality (e.g. Eb/No or SNR).
I'm not sure the math exists yet to eliminate the need to base link design
rules on baseline measurements.  In fact, it is possible in general that two
different FEC schemes could have different packet loss probabilities, yet
have the same BER (by virtue of error bit clustering, etc.).  

It would be good to encourage link designers to consider and optimize for
packet loss probability, not just BER.  If you agree perhaps you can add
some words to that effect.

Ralph Brooker
Andrew Corp

-----Original Message-----
From: Jamshid Mahdavi [mailto:[email-masked]]
Sent: Friday, July 23, 1999 12:50 PM
To: Brooker, Ralph
Cc: [email-masked]
Subject: Re: Link Layer designers draft...

"Brooker, Ralph" <[email-masked]> writes:

> Jamshid, this is an excellently written summary.  A few suggestions:
> 
> In note 2, add "Note that links with Forward Error Correction (FEC)
> generally have very non-uniform bit error distributions.  The distribution
> is a strong function of the types and combinations of FEC algorithms used.
> In such cases these equations cannnot be used to apply BER to the
> performance equations above and packet loss rate must be determined in
other
> ways." 

I'll go ahead and add this...  My take is that "other ways" means
understanding what the distribution of bit errors is, and applying
this in the same way I applied a uniform distribution in the example.
Or did you have something else in mind?

---

From: "Brooker, Ralph" <[email-masked]>
Date: Fri, 23 Jul 1999 12:44:34 -0500

You're correct, I omitted GEO by mistake.  However, also to be accurate at
the risk of igniting passions, one should also say that latency with LEO and
MEO satellite links MAY be significantly less.  (Some have argued that a
connection around the world through multiple LEO's and gateways may see more
delay than a single GEO hop depending on the LEO system architecture.)

Ralph Brooker
Andrew Corp

-----Original Message-----
From: John Border [mailto:[email-masked]]
Sent: Friday, July 23, 1999 1:11 PM
To: Brooker, Ralph; [email-masked]
Cc: [email-masked]
Subject: Re: Link Layer designers draft...

    To be accurate, you need to indicate that this latency is associated
with
geosynchronous (GEO) satellite links.  The latency with LEO and MEO
satellite
links is significantly less...
<snip>
John Border
Hughes Network Systems

---

From: Ken Miller <[email-masked]>
Date: Fri, 23 Jul 1999 14:35:03 -0400

>>Reply to your message of 7/23/99 2:09 PM
	>>
	>>
	>>> performance equations above and packet loss rate must be determined in other
	>>> ways." 
	>>
	>>> In note 4, the sentence "Satellite links have one-way times of about 500
	>>> msec (250 msec up and down)" is not correct.  I suggest this wording
	>>> instead:  "Satellite links have RTT's of about 500 msec (125 msec up and
	>>> down, one-way)."  Also, at the end of this paragraph, add: "Short sessions
	>>> with low BW on long-delay links are more sensitive to packet loss rate than
	>>> are long sessions.  Acceptable performance in this case might be defined as
	>>> a high probability that a session is not subjected to congestion-avoidance
	>>> slow-down during its lifetime due to an errored packet."
	>>
	>>Aha, already some interesting discussion point :-)
	>>
	>>Regarding the satellite links, do most people expect them to be used
	>>in both directions?  I thought that many people were trying to deploy
	>>asymmetric things like sending via satellite and replies via modem or
	>>landline.  That's why I tried to use the one-way time in the comment.
My experience is that both is true. Satellite links are most often asymmetric, sometimes with reverse channels from remotes to the uplink site and sometimes using terrestrial links for a reverse channel. This experience is based on using satellite to deploy multicast applications. I might add that the reverse channel in many 2-way VSAT systems is also contention based, so appears to an application to be highly congested at times.

Satellite also has offerings for two way symmetric high speed links designed to be Internet extensions into developing countries. The purpose of this is to provide connectivity where there is no terrestrial link or only very low capacity terrestrial.
Ken Miller

-----------------------------------------------------------------------------------------------------
Ken Miller
Chairman & CTO
StarBurst Software                Phone: (978) 287-5560 x223
150 Baker Avenue                FAX: (978) 287-5561
Concord, MA 01742              Web: http://www.starburstsoftware.com
------------------------------------------------------------------------------------------------------