Subject: RE: Assert mechanism

From: Sanjay Wadhwa <[email-masked]>
Date: Wed, 26 May 1999 15:12:35 -0400

I think it is ok to wait till 210 secs (or maybe less)
and not re-assert if metric at the winner or loser changes. 
There is no data loss there..
But in case of a loss of route to the source it seems like
a resonable optimization to re-assert on all non-pruned OIFs
in all (S,G) entries for that source. And since this is done
for only non-pruned OIFs, loss of route to source will
trigger an assert only at the current assert-winner.

Thanks
Sanjay

> -----Original Message-----
> From: Desikan Saravanan [mailto:[email-masked]]
> Sent: Wednesday, May 26, 1999 2:40 PM
> To: 'Sanjay Wadhwa'; Gerhard Gessler; PIM Mailing List
> Subject: FW: Assert mechanism
> 
> 
> Sanjay,
> 
> Sometime back, I also proposed the very same idea.
> Here is Ahmed's reply to that.
> 
> It is still not convincing to me.
> 
> What we can do is.
> 
> Whenever the route changes, all the affected forwarding 
> entries's assert
> state shall be cleared.
> So this would allow again asserting by both the previuos 
> winner and loser
> and 
> they could elect the new one.
> 
> Des
> 
> -----Original Message-----
> From: Ahmed A-G Helmy [mailto:[email-masked]] 
> Sent: Tuesday, September 01, 1998 2:26 AM
> To: Desikan Saravanan
> Cc: 'pim_ml'
> Subject: Re: Assert mechanism
> 
> 
> > Hi 
> > 
> > I have got a doubt in how assert mechanism works.
> > Say Router A and B are upstream routers and C is downstream.
> > And during the assert process, router A wins.
> > 
> > say after some time, router A looses the route to the 
> source concerned.
> > what happens after that?
> > 
> 
> The downstream router would set a timer after which it would 
> consult with 
> its unicast routing tables, and if the routes have changed 
> such that B is 
> the new favored upstream router, a join would be sent to B.
> 
> The problem with your suggestion is that A's metric may stay 
> the same, 
> while B's metric may become less (i.e. becomes more 
> favorable), and this 
> condition is not dealt with below,
> 
> Regards,
> -A
> 
> > what it should do is: router B should become the forwarder 
> in the LAN.
> > but how router B knows that it should do that?
> > 
> > I propose:
> > "When the Assert winner changes/looses the unicast route to 
> the source,
> > it should send an assert packet in the LAN with the new 
> metric. If it
> > looses
> > the route, the metric should be 0xfffffff and preference should be
> > 0x7fffffff"
> > 
> > This would immediately trigger another assert election and 
> the router
> > deserved
> > to be the winner, would win and start forwarding the multicast data
> > properly.
> > 
> > Am I right?
> > 
> > Rgds
> > Desikan
> > 
>

---

From: Desikan Saravanan <[email-masked]>
Date: Wed, 26 May 1999 11:39:57 -0700

Sanjay,

What we can do is.

Whenever the route changes, all the affected forwarding entries's assert
state shall be cleared.
So this would allow again asserting by both the previuos winner and loser
and 
they could elect the new one.

Des

-----Original Message-----
From: Ahmed A-G Helmy [mailto:[email-masked]] 
Sent: Tuesday, September 01, 1998 2:26 AM
To: Desikan Saravanan
Cc: 'pim_ml'
Subject: Re: Assert mechanism

> say after some time, router A looses the route to the source concerned.
> what happens after that?
> 

The downstream router would set a timer after which it would consult with 
its unicast routing tables, and if the routes have changed such that B is 
the new favored upstream router, a join would be sent to B.

The problem with your suggestion is that A's metric may stay the same, 
while B's metric may become less (i.e. becomes more favorable), and this 
condition is not dealt with below,

Regards,
-A

> what it should do is: router B should become the forwarder in the LAN.
> "When the Assert winner changes/looses the unicast route to the source,
> it should send an assert packet in the LAN with the new metric. If it
> looses
> This would immediately trigger another assert election and the router
> deserved

---

From: Bill Fenner <[email-masked]>
Date: Wed, 26 May 1999 13:20:32 -0700

The loser's route didn't necessarily change, which is what I think Ahmed
was saying.

  Bill

---

From: Desikan Saravanan <[email-masked]>
Date: Wed, 26 May 1999 11:39:57 -0700

Sanjay,

What we can do is.

Des

-----Original Message-----
From: Ahmed A-G Helmy [mailto:[email-masked]] 
Sent: Tuesday, September 01, 1998 2:26 AM
To: Desikan Saravanan
Cc: 'pim_ml'
Subject: Re: Assert mechanism

Regards,
-A

---

From: Desikan Saravanan <[email-masked]>
Date: Wed, 26 May 1999 11:39:57 -0700

Sanjay,

What we can do is.

Des

-----Original Message-----
From: Ahmed A-G Helmy [mailto:[email-masked]] 
Sent: Tuesday, September 01, 1998 2:26 AM
To: Desikan Saravanan
Cc: 'pim_ml'
Subject: Re: Assert mechanism

Regards,
-A