Subject: Pim-dm assert..

From: Sanjay Wadhwa <[email-masked]>
Date: Tue, 25 May 1999 13:29:10 -0400

Hi
I have a question on pim-dm assert mechanism.
Consider the following scenario :

                          S
                       
                   |                |
                  A-L           A-W
                   |                |
              -------------------------------
                          |
                          D

Lets say the assert-winner gets established at time t.
The assert-loser will prune the interface to the lan till time t+210.
Now if at time t+1 assert-winner loses route to the source.
The downstream router potentially may not get any data till t+209.

Does it make sense for the assert-winner in case it's route to source is
lost,
to trigger an Assert with metric infinity, on (non-pruned) OIFs 
in all (S,G) entries for this source. The assert loser will receive an
Assert on the
pruned interface, and  since it's metric is better, can respond with an
Assert, 
and remove prune state on that interface. 

Thanks
Sanjay

---

From: Gerhard Gessler <[email-masked]>
Date: Wed, 26 May 1999 09:23:02 +0200

> Consider the following scenario :

Thats right. 

> and remove prune state on that interface.

The assert looser will not respond to this Assert Msg, because it
arrives at a pruned interface. This is not in the spec but you can find
some statements about this in the mailing list archive (e.g. "Assert on
outgoing interface"  Mon, 09 Nov 98 19:27:00 PST from vishwas)

Hope this helps,

   Gerhard

-- 
---------------------------------------------------
Gerhard Geßler

IABG mbH, Abteilung CS31
Einsteinstr. 20
85521 Ottobrunn

Tel. (089) 6088 3954
Fax: (089) 6088 2845

E-Mail: [email-masked]