Subject: doubt in PIM-REFRESH draft

From: "bhavesh pathak" <[email-masked]>
Date: Fri, 22 Oct 1999 03:28:06 PDT

Dear everyone
I have following doubts in pim-refresh draft.

1. In section-3 first point,

  o Whenever a (S,G) State-Refresh message is received on the
    interface for RPF(S) by a router with no existing (S,G) entry,
                  ^^^^^^
    an (S,G) entry should be created.

Question : does this mean that there can be more than one
           interfaces to reach RPF-neighbor? How?

2. With respect to section-4, it seems that in follwoing
   case two router will go in the forwarding state.

      R1            R2        R3    (upstream routes)
      |             |         |
      |             |         |
----------------------------------

Say, R1 had won assert and was forwarding data to LAN.

If R1 goes down :
- R2 and R3,(when holdtime passes) both will send State-Refresh
  message with assert-override flag set and make
  interface connected to LAN in the forwarding state.

Is this expected behavior?

thanks,
bhavesh

______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com

---

From: Isidor Kouvelas <[email-masked]>
Date: Fri, 22 Oct 1999 08:57:52 -0700

>           interfaces to reach RPF-neighbor? How?

No. The point above means that you create state if the SR message is
received on the expected incomming interface for the (S,G) entry. There
is still only one incomming interface determined by unicast routing.

>      R1            R2        R3    (upstream routes)

This will not happen. R2 and R3 will keep on forwarding refresh messages
on the LAN after R1 goes down. Lets say that R2 has the best metric and
should become forwarder. In this case R3 will hear the refresh messages
from R2 and since they contain a better metric will not attempt to take
over using the AO flag.

I have a slightly revised version of the draft which I will try to
submit today to make the deadline.

thanks
Isidor