Subject: (PIM-SM)when source and receiver are on same LAN

From: "bhavesh pathak" <[email-masked]>
Date: Tue, 12 Oct 1999 00:02:34 PDT

Dear everybody,
I am trying to understand draft-ietf-pim-v2-sm-00.txt. I am not
able to understand how following situation will be handled.

  --------  |
  |Source|  |  1-----2 1-----2 1----2  1------2    |   ----------
  |Host  |--+---| A |---| B |---|RP|----| C  |-----+---| Receiver|
  --------  |   -----   -----   ----    ------     |   | Host2   |
  ------->  |      ---------->  <------------>         -----------
Data packet|      Register      forward
            |                     decapsulated
            |                     data packet
----------  |
|Receiver|  |
|  Host1 |--+
----------  |

NOTE: 1, 2 represents the interface number for router.
1. Say initially, Receiver-Host1 has not up. IN this case,

   A will have (S,G) entry with iif = A1, oif = A2
   A will have (*,G) entry with iif = A2, oif = NULL

2. IF the receiver-Host1 comes up and wants to receive multicast data,
   will the entries in A be modified as follows?

   A will have (S,G) entry with iif = A1, oif = A2,A1
   A will have (*,G) entry with iif = A2, oif = A1

How this situation will be handled?

bhavesh

______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com

---

From: helmy <[email-masked]>
Date: Tue, 12 Oct 1999 10:28:30 -0700 (PDT)

> able to understand how following situation will be handled.
If the receiver is not up yet (i.e. has not joined the group), then A will
only have a S,G with the register bit set, iif A1 and oif is the register
vif (virtual interface), which is whatever the unicast says is the way to
RP (remember that registers are unicast).
	If there are no receivers downstream of A then A will not have *,G

>    A will have (*,G) entry with iif = A2, oif = A1

when the receiver joins the group, A will create *,G with iif pointing
towards RP (i.e. A2) and oif pointing towards the LAN (i.e. A1). However
since it has S,G and *,G with different iifs, it sends a prune for S,G
towards the RP.

So in the end the receiver gets the packets from the LAN directly and the
decapsulated registers don't flow back towards the LAN.

Regs,
-A

---

From: Ravi Kiran Puvvala <[email-masked]>
Date: Tue, 12 Oct 1999 10:50:13 -0700

helmy writes:

| when the receiver joins the group, A will create *,G with iif pointing
| towards RP (i.e. A2) and oif pointing towards the LAN (i.e. A1). However
| since it has S,G and *,G with different iifs, it sends a prune for S,G
| towards the RP.

When does A detect that it has both <*,G> and <S,G> with different IIF's.

I think ...

- Receiver1 joins G
- A creates <*,G>
- A propogates the <*,G> join towards the RP
- Source sends traffic to A
- A encapsulates data in a register and sends it to RP
- RP decapsulates the packet and sends it to A
- A detects that it is receiving packets on the <S,G> OIF,
  then it sends a <S,G>prune towards the RP.

Ravi

---

From: helmy <[email-masked]>
Date: Wed, 13 Oct 1999 16:55:01 -0700 (PDT)

>   then it sends a <S,G>prune towards the RP.

actually, the fact that A has 2 entries (S,G) for registers and (*,G), is
what triggers the prunes.
Another scenario is when the receiver joins first then the sender starts
sending, same rules apply,

Regards,
-Ahmed

---

From: helmy <[email-masked]>
Date: Wed, 13 Oct 1999 16:55:01 -0700 (PDT)

Regards,
-Ahmed

---

From: helmy <[email-masked]>
Date: Wed, 13 Oct 1999 16:55:01 -0700 (PDT)

Regards,
-Ahmed

---

From: helmy <[email-masked]>
Date: Wed, 13 Oct 1999 16:55:01 -0700 (PDT)

Regards,
-Ahmed

---

From: helmy <[email-masked]>
Date: Wed, 13 Oct 1999 16:55:01 -0700 (PDT)

Regards,
-Ahmed

---

From: helmy <[email-masked]>
Date: Wed, 13 Oct 1999 16:55:01 -0700 (PDT)

Regards,
-Ahmed

---

From: helmy <[email-masked]>
Date: Wed, 13 Oct 1999 16:55:01 -0700 (PDT)

Regards,
-Ahmed