Subject: clarification

From: sabarivel s <[email-masked]>
Date: Mon, 27 Mar 2000 14:02:18 +0530

Hi,
                     Can multiple Multicast Routing Protocols run on an Interface? if yes, is there any such implementation?
         
  - sabari

---

From: Wilbert de Graaf <[email-masked]>
Date: Mon, 27 Mar 2000 07:50:52 -0800

>                      Can multiple Multicast Routing Protocols run on an Interface? if yes, is there any such implementation?

Sabari,

Althugh I haven't it running myself, I cannot tell what could be wrong with it. The routing protocols use different protocol
types / numbers, so that part is safe. And each of the implementations (pimd, mrouted, ...) just manipulates the multicast
routing tables. The kernel just forwards / routes using this very same table so there shouldn't be a problem too.

- Wilbert

---

From: "Hal Sandick" <[email-masked]>
Date: Tue, 28 Mar 2000 01:03:18 -0500

Sabari,

I have worked withed a code base  (used by two different router vendors)
that supported this feature. As others have noted "stuff" was done so
that :

	- only one input interface was chosen for an entry
	- output interfaces only transmitted one copy of a packet.

Regards,

Hal