Subject: RE: Question on PIM-SM

From: Mohit Talwar <[email-masked]>
Date: Wed, 1 Mar 2000 13:41:14 -0800

>			h1
>			|
>		--------r1------
>		|		|
>		r2		r3
>		|		|
>		|		|
>		|		r4
>		|		|
>		|		|
>		|		r5 (RP)
>		|		|
>		-------------------
>			|
>			r6
>			|
>			h2
>
>r5 is the RP for 235.1.1.1. 
>h1 is the source, h2 is the receiver.
>The shortest path from r6 to h1 is through r2. The following sequence 
>of events occur:
>a. h2 joins a group (235.1.1.1)
>b. h1 sends to 235.1.1.1
>c. After sometime, r6 realizes that the data rate has exceeded 
>and switches to SPT (h2->r6->r2->r1->h1).
>
>So finally, r6 has a (*,g) entry and a (s,g)SPT entry.

in this scenario, an assert election will take place 
on the LAN between r2 and r5.  r2 will win since it 
has an (S,G) entry while r5 has (*,G).  r5 will create
an (S,G)RPT bit entry.
(section 3.5.2, "Receiving Assert on OIF", 1)

note that r6 will not set the SPT bit for its (s,g)
entry!!!  so its JoinPrune message to r5 has only

> join list: (*,235.1.1.1)

hope i haven't overlooked anything.
mohit.

>
>My question is: what does r6 put in the j/p message that it sends
>to r5? My guess is:
>
>	join list: (*,235.1.1.1)
>	prune list: (h1,235.1.1.1) with RPT bit set and WC bit cleared
>		    (an (S,G)RPT prune).
>
>But I couldn't find the section which describes this scenario.
>It would help if someone could point out which rule applies here.
>
>Thanks.
>Chirayu.
>
>

---

From: Isidor Kouvelas <[email-masked]>
Date: Wed, 01 Mar 2000 14:33:15 -0800

This is addressed in issue 11 on the web page at:
http://www.aciri.org/fenner/mcast/pim/sm/issues.html

thanks
Isidor