Subject: Re: pimd.conf

From: "Jonathan Day" <[email-masked]>
Date: Tue, 09 May 2000 10:30:13 -0700

Hi,

I'm by no means an expert on pimd, but here are a few things to check. They're all ludicrously simple - so much so, that they're easy to forget to do.

First, check that the kernel has been configured with multicasting, multicast routing, pim-2 support and packet forwarding enabled.

Second, check that /proc/sys/net/ipv4/ip_forward is set to 1.

Third, check /etc/pimd.conf to see that both interfaces are defined. (IIRC, it won't even start, if it can't find two interfaces.)

Fourth, check that the interfaces are multicast-enabled.

Last, but by no means least, if you've got security set up, check that you're not blocking all multicast traffic, by mistake.

On Tue, 9 May 2000 12:39:07    Daniel Firac wrote:
>How should look like the pimd.conf file for a simple multicast router
>which has to connect 2 LAN's??
>That means the router has to forward the multicast trafic from one LAN to
>the other.
>
>I have slackware 7.0 with kernel 2.2.13 and pimd-2.1.0-alpha28. 
>The 'pimd -d' command works, but a simple multicast ping doesn't work.

--== Sent via Deja.com http://www.deja.com/ ==--
Before you buy.

---

From: Hitoshi Asaeda <[email-masked]>
Date: Wed, 10 May 2000 11:12:18 +0900 (JST)

Actually, I couldn't understand original question, though,

> Third, check /etc/pimd.conf to see that both interfaces are defined. (IIRC, it won't even start, if it can't find two interfaces.)

when you start pimd, pimd does try to look for all multicast available 
interfaces on the box, except not a loopback interface, not a
multicast disabled interface.
Only when there is an entry, "phyint if_name disable", in pimd.conf,
pimd doesn't use that specified if_name as its iif/oif.

The way of this, in pimd.conf, it would be said you don't need to
specify the interfaces which you want to use.

And, yes, more than two interfaces are prerequisite to make pimd work, 
as you know.
--
Hitoshi Asaeda