Subject: RPF calculation

From: [email-masked]
Date: 1 Jun 2001 18:12:03 -0700

Hi,
 I have a basic question regarding RPF calculation in PIM-SM.
I have only Unicast Routing Table to calculate RPF as we don't support any  multicast protocols. PIM-SM is enabled on few interfaces.
If  the interface used by the unicast routing table to forward unicast packets to the RP/Source is a non PIM enabled interface; should I send the join/prune message on the lower cost interface among the PIM enabled interfaces to the RP/Source. Please,  someone give advice even if  this is not bound to Protocol Specification.

Thanks
satya

______________________________________________________
123India.com - India's Premier Portal 
Get your Free Email Account at http://www.123india.com

---

From: krishna bellamkonda <[email-masked]>
Date: Fri, 1 Jun 2001 20:11:14 -0700 (PDT)

Hi,
 I think we should skip the Join message at this
instance and you should not send Join on other
interface. 

I could able to locate this in the RFC 2362 section
3.2.1 
"Join/Prune messages are only sent if the RPF neighbor
is a PIM neighbor". This means you should calculate
the RPF neighbor and then check for a PIM nehbor on
that interface and we should not do in the reverse
order.

  But, i haven't found this in the new PIM-SM draft
and i am not sure whether any new changes made in the
new draft regarding this. 

 Krishna.
 
--- [email-masked] wrote:
> I have only Unicast Routing Table to calculate RPF
> as we don't support any  multicast protocols. PIM-SM
> is enabled on few interfaces.
> If  the interface used by the unicast routing table
> to forward unicast packets to the RP/Source is a non
> PIM enabled interface; should I send the join/prune
> message on the lower cost interface among the PIM
> enabled interfaces to the RP/Source. Please, 
> someone give advice even if  this is not bound to
> Protocol Specification.
> 
> Thanks
> satya
> 
> 
>
> Get your Free Email Account at

__________________________________________________
Do You Yahoo!?
Get personalized email addresses from Yahoo! Mail - only $35 
a year!  http://personal.mail.yahoo.com/

---

From: Mark Handley <[email-masked]>
Date: Fri, 01 Jun 2001 22:15:30 -0700

>I have only Unicast Routing Table to calculate RPF as we don't support any mu
>lticast protocols. PIM-SM is enabled on few interfaces.
>If  the interface used by the unicast routing table to forward unicast packets
> to the RP/Source is a non PIM enabled interface; should I send the join/prune
> message on the lower cost interface among the PIM enabled interfaces to the R
>P/Source. Please,  someone give advice even if  this is not bound to Protocol 
>Specification.

I think that would be considered a misconfiguration - a PIM domain
must be convex with respect to the underlying routing protocol in
order to work, and the situation you describe is not convex as far as
PIM enabled paths are concerned.

There are a number of problems with the solution you describe:

 - the unicast routing table usually will only have one route to the RP 
   or source, so to get an alternate route you'd need to change your
   unicast routing implementation.

 - in some circumstances the only PIM-enabled interface may be the one
   the packet arrived on.

 - in general, you rely on unicast routing to avoid join-loops.  If
   some routers use the unicast routes and some use different routes,
   you risk creating a loop.

So I think the correct situation is to not send the join upstream, and
to report this as a configuration error.

Cheers,
	Mark

---

From: Mark Handley <[email-masked]>
Date: Fri, 01 Jun 2001 22:15:30 -0700

Cheers,
	Mark