Subject: RE: Dr and Non -DR

From: Billy Ng <[email-masked]>
Date: Thu, 7 Jun 2001 13:34:23 -0400

Jyotheesh,

when the RP received the native multicast data packet, 
it will send a Register-Stop to the DR.

--Billy

> -----Original Message-----
> From: Jyotheeswara Rao Kurma [mailto:[email-masked]]
> Sent: Thursday, June 07, 2001 8:10 AM
> To: [email-masked]; [email-masked]
> Subject: Dr and Non -DR
> 
> 
> Hi :
> 
>  I need a small clarification. Consider the following scenario.
> 
>   
>             |
>             |---- DR ---------PIM-ROUTER---PIMROUTER------|    
>     Host--- |                                             |-----RP
>             |---- NON-DR------PIM-ROUTER------------------|
>             |
> 
> Now , DR will send initial register packets to RP, but RP will send
> (S,G) Joins towards NON-DR (assuming better path), and this 
> NON-DR will
> start forwarding ( S(Host),G) packets from Host. When happens to DR
> there ? How long will it maintian (S,G) register state ? 
> 
> Who will take care of refreshing Rp's state by sending Null register 
> messages ? Is it DR/NON-DR ? 
> 
> Thanks for any help,
> Jyotheesh
>  
> --------------------------------------------------------------------
> Every moment is a golden one for him who has the vision to 
> recognize it 
> as such. 
> -- Henry Miller 
> 
>

---

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Fri, 08 Jun 2001 08:58:30 +0500

> When the packets arrive on the (S,G) SPT at the RP, the RP will
> consider the SPT for the source established and will respond to
> further registers with register-stop messages.
> The DR will stop registering after it receives the register-stop
> but since it still is directly connected to the source, it will 
> maintain(S,G) state as long as the source is active.
> 
> The DR will send the null-registers.

Yes, I could Understand what you wrote. But What I am wondering is
why is DR there interested in sending register stops, to RP, anyway for
DR here (S,G) oif-list will be always non-null ( assuming no other 
receivers , and just considering this simple case), and NON-DR's 
(S,G) oif-list will contain RPF(RP) . So in any case, if at all if 
there is something that let's a router to refresh RP's state, i.e to 
know whether it has any down stream receivers for this group , it 
should be done by a router which is actually forwarding those (S,G) 
packets, here in this case it is NON-DR. 

Please let me know if I am misunderstanding anything ?

Thanks,
Jyotheesh

---

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Fri, 08 Jun 2001 10:14:15 +0500

Sorry , for a simple mistake , 
DR's oif-list is NULL( written wrongly as NON-NULL)
, in the above mail (case) that I quoted.

Thanks,
Jyotheesh

--------------------------------------------------------------------
Every moment is a golden one for him who has the vision to recognize it 
as such. 
-- Henry Miller

---

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Fri, 08 Jun 2001 11:54:54 +0500

No , It cann't , As per the current draft, register stop will be sent 
only in response to a register packet. So after the native multicast 
packet , next register packet can only trigger RP to send a register 
stop message to DR. In other case as you wrote , i.e sending register 
stop message in response to a native multicast data packet, RP needs to 
store DR's address.

Update me if I am wrong,
Jyotheesh

---

From: Billy Ng <[email-masked]>
Date: Fri, 8 Jun 2001 10:12:26 -0400

Yes, you're correct.  I wrote too quick :)  
The register stop is sent on the next register packet.

--Billy

> Sent: Friday, June 08, 2001 1:55 AM
> To: Billy Ng
> Cc: [email-masked]
> Subject: Re: RE: Dr and Non -DR
> 
> 
>

---

From: "P N H" <[email-masked]>
Date: 9 Jun 2001 17:17:31 -0000

DR must be sending Register message "Register Probe Time" interval before "Register Suppression Timer" expires. DR can respond back with "Register-Stop" to this. DR must continue to send "Register message" at above mentioned time as long as there is a (S,G) state at the DR. Note that DR will maintain (S,G) state even though it is not doing any forwarding, as long as Keepalive Timer is alive.

Pawan

------------- Original Message --------------
Billy Ng <[email-masked]> wrote:
To:"'Jyotheeswara Rao Kurma'" <[email-masked]>,
       Billy Ng
 <[email-masked]>
From:Billy Ng <[email-masked]>
Date:Fri, 8 Jun 2001 10:12:26 -0400 
CC:[email-masked]
Subject:RE: RE: Dr and  Non -DR

--Billy

> stop message in response to a native multicast data packet, 

_____________________________________________________
Chat with your friends as soon as they come online. Get Rediff Bol at
http://bol.rediff.com