Subject: RE: How to disable DR election on an interface ?

From: Mathur Sonum-CSM109 <[email-masked]>
Date: Tue, 5 Jun 2001 13:15:57 -0500

Motorola accepts Join/Prune messages from neighbors that are not present in the PIM neighbor list.

--
Sonum

-----Original Message-----
From: Andrew Adams [mailto:[email-masked]]
Sent: Tuesday, June 05, 2001 4:43 AM
To: Chris Hall
Cc: 'Bill Fenner'; [email-masked]; [email-masked]
Subject: Re: How to disable DR election on an interface ?

Gated _accepts_ joinprune messages from neighbors that don't have hello 
status.

-Andy

Chris Hall wrote:
> 
> Which implementations actually reject joinprune messages from neighbors that
> don't have hello status?
> 
> thanks
> 
> Chris
> 
> -----Original Message-----
> From: Bill Fenner [mailto:[email-masked]]
> Sent: Monday, June 04, 2001 2:46 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: How to disable DR election on an interface ?
> 
> >    why not
> >    accept Join/Prune messages from a router that hasn't sent a Hello.
> 
> Because there may be options in the Hello message that need to be
> consistent (e.g. join/prune override time).  e.g. if you're the DR and
> you hear a Join/Prune from a router with a higher IP address, do you
> decide that he's the DR?  Why or why not?
> 
> What I'd really like is for the Hello messages to have neighbor lists
> and ignore a neighbor until you get a Hello message with you in his
> neighbor list, but that got shot down a long time ago.  It's much nicer
> for debugging purposes for the peering to go down on both ends than to
> have a mysteriously one-way peering.
> 
>   Bill

---

From: Chris Hall <[email-masked]>
Date: Tue, 5 Jun 2001 15:40:11 -0700

oops...  

So does Wind River.

Chris

-----Original Message-----
From: Mathur Sonum-CSM109 [mailto:[email-masked]]
Sent: Tuesday, June 05, 2001 11:16 AM
To: [email-masked]
Subject: RE: How to disable DR election on an interface ?

Motorola accepts Join/Prune messages from neighbors that are not present in
the PIM neighbor list.

--
Sonum

-----Original Message-----
From: Andrew Adams [mailto:[email-masked]]
Sent: Tuesday, June 05, 2001 4:43 AM
To: Chris Hall
Cc: 'Bill Fenner'; [email-masked]; [email-masked]
Subject: Re: How to disable DR election on an interface ?

-Andy

---

From: "Sundeep Singatwaria" <[email-masked]>
Date: Tue, 5 Jun 2001 21:09:38 -0700

ditto at nortel.

Sundeep

-----Original Message-----
From: Tom Pusateri [mailto:[email-masked]]
Sent: Monday, June 04, 2001 7:26 PM
To: Chris Hall
Cc: 'Bill Fenner'; [email-masked]; [email-masked];
[email-masked]

Currently, Juniper ignores joins, prunes, grafts, graft acks,
bootstrap messages and asserts from neighbors it hasn't seen a hello from.

Tom