Subject: RE: Pim packet length.

From: "Sridhar Vallepalli" <[email-masked]>
Date: Tue, 26 Jun 2001 16:11:27 -0700

That is true, but I have seen one of the leading router vendors having 
incorrect value in the total length field of the IP header. 
By having the length in pim header the dependency on finding it of the 
IP header is eliminated. ( The way it is done in OSPF)

Thanks
Sridhar

-----Original Message-----
From: Yiqun Cai [mailto:[email-masked]]
Sent: Tuesday, June 26, 2001 2:05 PM
To: Vallepalli, Sridhar [SC9:T337:EXCH]
Cc: [email-masked]
Subject: Re: Pim packet length.

It can be computed from the length field in the IP header. 

> 
> Hi all,
> 	In the existing pim packet formats there is no field in pim header
> which tells how big the packet is.
> I would suggest to use the reserved byte in the pim header for this
purpose.
> Please comment..
> Thanks
> Sridhar

-- 
Yiqun

---

From: Yiqun Cai <[email-masked]>
Date: Tue, 26 Jun 2001 19:10:15 -0700 (PDT)

Well, if the total length field in the IP header is not trust worthy,
why should the length field of PIM header be? They are built by the
same router running the same software.

I assume you are proposing this to ensure the integrity of PIM messages. 
If so, the checksum field should serve the purpose. If an implementation 
believes that the checksum field is not strong enough to protect against 
a wrong total length value in the IP header, it can always determine the 
exact number of bytes received from the driver.

-- 
Yiqun