Subject: Re: IP destination address of PIM Join/Prune message

From: "Jyotheeswara Rao Kurma" <[email-masked]>
Date: Fri, 15 Jun 2001 10:46:37 +0500

Hi :

   Destination address for join/prune messages will be 224.0.0.13 only.
But there is a field called upstream neighbor, this is the ip address 
of the upstream neighbor to whom we are sending join/prunes. i.e to 
whom this message is addressed/intended.

All pim routers(on shared media) will receive this message, but only 
one will process.

If this field is one of my addresses , then that router will process 
that packet. 

Hope this helps,
Jyotheesh

--------------------------------------------------------------------
Every moment is a golden one for him who has the vision to recognize it 
as such. 
-- Henry Miller 

----- Original Message -----
From: arindamc <[email-masked]>
Date: Friday, June 15, 2001 10:41 am
Subject: IP destination address of PIM Join/Prune message

> Hi,
> 
>  I am working on PIM-SMv2. The draft draft-ietf-pim-sm-v2-new-02.txt
>  on page no.92 says that 
>  "PIM messages are either unicast (e.g.  Registers and Register-
> Stop),   or multicast with TTL 1 to the `ALL-PIM-ROUTERS' group 
> (e.g. Join/Prune, 
>   Asserts, etc.)"
> 
>  But on page no 34 it says,
>  "Receive Join(*,*,RP)
>          A Join(*,*,RP) is received on interface I with its IP
>          destination set to the router's address on I."
> 
>  How is this possible ? The IP destination field of the PIM 
> Join/Prune  message must be set to the address "224.0.0.13"(ALL-
> PIM-ROUTERS).
>  plz explain me what does it want to mean by that.
> 
> thanks in advance,
> 
> arindam C. 
> 
>

---

From: Apoorva Karan <[email-masked]>
Date: Fri, 15 Jun 2001 19:17:26 -0700

Please look for ##### for inline comment.

> If this field is one of my addresses , then that router will process

##### A minor correction to the statement above. The router should
process the packet only if the target address in the jp message is the
address of the interface on which the packet was received (and not any
one of the routers addresses).

Thanks,
Apoorva