Subject: [pim] Security thteats...in the current PIM protocol...

From: "P.Jhingran" <[email-masked]>
Date: 13 Dec 2001 16:22:41 -0000

hi all, 
      I would like to know that how can the following be avoided:- 

   HOST--------DDR------IR-------CRP------//----etc 
   Lan       firsthop 
              router 
A host can always form PIM control packet and can forward to the DDR, which can lead to DR election. A host can always form a hello packet with a higher priority than the DDR.Similarly any packet can be forged. 

Since there is no standard for preventing such possible atacks...don't you all think that if this is made implementation specific then there can be problem with interoperability. 
Rather the scope of a particular vendor will become something like "Admin Scope "specific... 

The worst part is any router can advertise itself as an RP and can receive packets from all the sources for that group ( incase it becomes an RP).A host just needs to send "hello" , "CRP advertisement" and should be able to process RP specific requirements. 

Hence don't you all think that a standard should come ASAP. 
regards, 
P.Jhingran

---

From: Hugh Holbrook <[email-masked]>
Date: Thu, 13 Dec 2001 09:32:54 -0800 (PST)

Hello,

The Security Considerations sections of both the latest PIM and BSR
specs describe mechanisms for authenticating PIM Hellos (among other
messages) and Bootstrap messages.  Perhaps you're looking at an old
version of the spec?

-Hugh

> Date: 13 Dec 2001 16:22:41 -0000
> From: "P.Jhingran" <[email-masked]>
> Reply-To: "P.Jhingran" <[email-masked]>
> 
> 
> 
> hi all,